E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > E46 Xi Forum

E46 Xi Forum
The E46 XI was produced from 01-05 in sedan and touring body styles. Powered by either a 2.5L inline 6 in the 325xi or a 3.0L inline 6 330xi. Discuss all thing about BMW AWD E46 'Xi' here.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 10-01-2012, 12:14 PM   #1
SharkmanBMW
Registered User
 
Join Date: Mar 2006
Location: Montreal
Posts: 336
My Ride: 03 330xi, 4th bimmer
Send a message via MSN to SharkmanBMW
STRANGE Shock / shock mount problem - perplexed!

Hi all,

Bilstein M3 rear shocks seem to have a strange problem.

I have the Bilstein M3 shocks, on one side, there are more threads sticking out of the top nut than the other.

The mounts have been remoeved & reinstalled by different pros, always the same result. As if one shaft is longer than the other.
Bilstein tells me that is not likely at all.

So, what else could make one side tighten more on the shaft? It is always exactly the same - so I highly doubt they are not tightened equally every time - there has to be another cause.

On the Driver side I see about 7 threads above the nut and passenger side about 4 threads above the nut. Anyone have photos of their M3 shocks / top nut from inside the trunk?

Any ideas?!
THANKS
__________________
^^ ><((({>
H&R Sport, Bilstein E46 Sport (Front), Bilstein E36 M3 Sport (Rear), Rogue Engineering RSMs
SharkmanBMW is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 11-04-2012, 10:47 AM   #2
SharkmanBMW
Registered User
 
Join Date: Mar 2006
Location: Montreal
Posts: 336
My Ride: 03 330xi, 4th bimmer
Send a message via MSN to SharkmanBMW
B b b bump!
__________________
^^ ><((({>
H&R Sport, Bilstein E46 Sport (Front), Bilstein E36 M3 Sport (Rear), Rogue Engineering RSMs
SharkmanBMW is offline   Reply With Quote
Old 11-04-2012, 11:54 AM   #3
lovesm3s
Registered User
 
Join Date: Jul 2011
Location: New Jersey
Posts: 80
My Ride: '03 330xi 5 speed
are there the same amount of threads on each shock?
lovesm3s is offline   Reply With Quote
Old 11-04-2012, 06:03 PM   #4
Gus330vrum
Registered User
 
Join Date: Mar 2011
Location: atlanta
Posts: 1,506
My Ride: 330ci
I have m3 1999 strut , did u upgrade shock mount to rogue RSM. ?

I'm having issue where my rear sway bar is touching the rear control arms cuz some how control arms bent and went car bounce up&down it touchs the control arm causing metal to metal noise.

Its not touching completely but the distance bettwen the sway and control arm is not long enough.

Sent from my LG-MS770 using Bimmer App

Last edited by Gus330vrum; 11-04-2012 at 06:04 PM.
Gus330vrum is online now   Reply With Quote
Old 12-15-2012, 06:41 PM   #5
dambro24
Registered User
 
Join Date: Oct 2003
Location: nyny
Posts: 618
My Ride: 330ci
Quote:
Originally Posted by mrlatexxx View Post
I have m3 1999 strut , did u upgrade shock mount to rogue RSM. ?

I'm having issue where my rear sway bar is touching the rear control arms cuz some how control arms bent and went car bounce up&down it touchs the control arm causing metal to metal noise.

Its not touching completely but the distance bettwen the sway and control arm is not long enough.

Sent from my LG-MS770 using Bimmer App
what did you do for this?
__________________
dambro24 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 10:52 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use