E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 07-13-2012, 08:39 PM   #1
nightflex
Registered User
 
Join Date: Jul 2012
Location: Markham/Toronto, Ontario
Posts: 7
My Ride: 05 BMW 330CI S+P+C
Picked up an 05 330ci... already need more $$

First bmw against all odds.

Picked up an 05 330ci with 75k miles on the dot.

Third owner now has premium + sport + winter pkg

Black on Black

$12500 CAD out the door with taxes and all in.
$147 hood insulator
$62 Bmw Oil + Filter
$45 DRL with Plate Leds
$70 Angel Eyes
$90 Dorman Control Arm Bushings
-Thinking about overhauling A/C, scary postings on the forum about catastrophic failures.
-Mtech 2 Bumper front/rear + skirts future purchase, bmw quited $2900 all the parts out the door, then pain, then install (not cheap)

-Oil Pressure light flickering under 1-2k Rpm sometimes until I give it gas..
-Steering wheel vibration is complete gone after control arm bushing install
-Revved the car repeatedly over a 110km(68 m) drive doing about 140-160 kms (100 miles) - engine light came on, brought it to my shop hooked it up some sensor was tripped has to do with exhaust - got it taken out will see if it pops up again would need a new sensor or something.


Only scary thing is the red Oil pressure light, couldn't find any solution on the internet. Anyone know any solutions?

is this normal in terms of upgrades and maintenance?
nightflex is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 07-13-2012, 08:49 PM   #2
Crespo5190
Registered User
 
Join Date: Aug 2010
Location: El Monte CA
Posts: 1,420
My Ride: 2001 325CI
Interested in a seibon carbon fiber hood?
__________________
-Tony
Crespo5190 is offline   Reply With Quote
Old 07-13-2012, 08:58 PM   #3
Mango
A full five stars, son
 
Mango's Avatar
 
Join Date: Mar 2006
Location: Southern California
Posts: 23,007
My Ride: M54B30
Interested in spun main/connecting rod bearings? That oil light is extremely serious. You sure the p/o wasn't trying to unload a bad car on you? Any weird noises?
__________________
A lifetime free of problems if you follow my guides
Cooling | Maintenance | Suspension | Vacuum | Supreme Reliability | Details

OVER A MILLION VIEWS
Mango is online now   Reply With Quote
Old 07-13-2012, 09:02 PM   #4
325guy
Banned User
 
Join Date: Jun 2012
Location: manhattan, new york
Posts: 215
My Ride: 2003 325i stick
That oil pressure light could easily be the sensor
325guy is offline   Reply With Quote
Old 07-13-2012, 09:09 PM   #5
pipo1123
Registered User
 
Join Date: May 2012
Location: maryland
Posts: 23
My Ride: 2004 bmw 330ci
Quote:
Originally Posted by 325guy View Post
That oil pressure light could easily be the sensor
Yep yep, i have the same thing right now my red oil light flickers when im in idle. It doesent show on codes so im changing the senson on next oil change.
pipo1123 is offline   Reply With Quote
Old 07-13-2012, 09:12 PM   #6
Mango
A full five stars, son
 
Mango's Avatar
 
Join Date: Mar 2006
Location: Southern California
Posts: 23,007
My Ride: M54B30
You guys even know what sensor you're talking about?
__________________
A lifetime free of problems if you follow my guides
Cooling | Maintenance | Suspension | Vacuum | Supreme Reliability | Details

OVER A MILLION VIEWS
Mango is online now   Reply With Quote
Old 07-13-2012, 09:13 PM   #7
Vandyinc
Registered User
 
Join Date: Aug 2010
Location: Goose Creek, SC
Posts: 136
My Ride: 2000 323 Cic
Why wait. Pressure sensor should be on the OFH.
__________________
Done:FCABs, OFHG, CCV, Cooling Sytem refresh, Coolantsnitch. Yet to do:Transmission fluid & filter, Shocks & Struts, VCG
Vandyinc is offline   Reply With Quote
Old 07-13-2012, 09:14 PM   #8
Steven747
Registered User
 
Join Date: Aug 2010
Location: Orange County, CA
Posts: 4,386
My Ride: 05 330ci
oil level sensor causes yellow light. your bad blown up engine causes the red
__________________
Steven747 is offline   Reply With Quote
Old 07-13-2012, 09:15 PM   #9
Mango
A full five stars, son
 
Mango's Avatar
 
Join Date: Mar 2006
Location: Southern California
Posts: 23,007
My Ride: M54B30
Quote:
Originally Posted by Vandyinc View Post
Why wait. Pressure sensor should be on the OFH.
ding ding ding

Though why it would read "OK" once revs are up is odd. Any confirmed cases where a new oil pressure sensor fixed a red light at idle? You really don't hear about these failing.
__________________
A lifetime free of problems if you follow my guides
Cooling | Maintenance | Suspension | Vacuum | Supreme Reliability | Details

OVER A MILLION VIEWS
Mango is online now   Reply With Quote
Old 07-13-2012, 09:17 PM   #10
choxor
Registered User
 
Join Date: Nov 2010
Location: Atlanta, GA
Posts: 4,501
My Ride: JDM
I have to ask, did you even check the oil before revving the snot out of it.
__________________
choxor is offline   Reply With Quote
Old 07-13-2012, 09:35 PM   #11
trive2
Registered User
 
Join Date: Sep 2011
Location: Brisbane
Posts: 1,100
My Ride: 1989 BMW 535i
The moment that little red oil light turns on for even the briefest moment when it's not supposed to, you NEED to investigate seriously and immediately.

Red oil light means you're already doing engine damage. It's not a warning that the pressure is about to drop low enough that it could cause engine damage, it's telling you the pressure has already dropped far enough to be causing irreversible damage.
__________________
trive2 is offline   Reply With Quote
Old 07-13-2012, 10:31 PM   #12
budysr
Registered User
 
Join Date: May 2012
Location: Pensacola, FL.
Posts: 17
My Ride: 330ci
I bought an 03 330ci a few weeks ago, and it also had a red oil light flicker show up on me a couple times, but only with the engine warm and at idle for extended time. It would immediately go away with the slightest tap on the gas pedal to raise rpm, and NEVER came on while driving. I think the car was idling a bit too low(just barely above 500) when this was happening. I have since had a refresh of some stuff under the hood including a new MAF, ICV, CVV, plugs, filters, and any vac leaks fixed. Car idles perfectly now around 650/700 or whatever it is supposed to idle at, and runs like a scalded dog! AND, I have not seen a trace of red oil light flicker. I think in my case it was from the rpm dropping too low. That red light is either the oil pressure sending unit sensor, or there is a legit problem with the oil pressure. If yours is coming on at higher rpm then idle, you need to try a new sensor ASAP, and make sure it's not the actual oil pressure
budysr is offline   Reply With Quote
Old 07-13-2012, 10:38 PM   #13
Lusticles
Registered User
 
Join Date: Aug 2010
Location: Annapolis
Posts: 2,803
My Ride: 325Ci
For all you're about to spend, or have, you could have picked up a better one.
__________________
number one Audi Fan
Lusticles is offline   Reply With Quote
Old 07-14-2012, 01:08 AM   #14
nightflex
Registered User
 
Join Date: Jul 2012
Location: Markham/Toronto, Ontario
Posts: 7
My Ride: 05 BMW 330CI S+P+C
Car has no problems.
Engine is as smooth as cream.
No weird noises, steering wheel is a bit stiff but that's binmers.
the day I got an oil change done was the only day when the light flickered once.
It was like when the car was in motion as the oil slushed back and forth it tripped the light. It was momentarily but I haven't got it since.

I did some research and found out that many e46 owners have had the same red light issue with no remedy. Even some have gone as at as taking it back you he dealer 2- or 3 times and no one has figured out anything.

I am waiting to see if it comes back ill probably get ICV and pressure sensor changed as a precaution and then go from there.

Other than that the ride is sweet, the engine revvs strong no clunking or knocking sounds - HK sound system is a god send.

Very very pleased with the purchase ... Also the o-ring seal is another thing that I'll change as prescribed by another poster.

Let me know if anyone has a decent solution for that..
nightflex is offline   Reply With Quote
Old 07-14-2012, 01:18 AM   #15
Mango
A full five stars, son
 
Mango's Avatar
 
Join Date: Mar 2006
Location: Southern California
Posts: 23,007
My Ride: M54B30
I'd suggest changing your oil and filter for starters.
__________________
A lifetime free of problems if you follow my guides
Cooling | Maintenance | Suspension | Vacuum | Supreme Reliability | Details

OVER A MILLION VIEWS
Mango is online now   Reply With Quote
Old 07-14-2012, 02:41 AM   #16
nightflex
Registered User
 
Join Date: Jul 2012
Location: Markham/Toronto, Ontario
Posts: 7
My Ride: 05 BMW 330CI S+P+C
Genuine BMW + Oil filter was used 50kms before the light flickered.

Here are the other people with the same problem on the internet with no solution...

They have cleaned ICVs, changed sensors, used different oils - dealer has got them changing everything under the hood but nothing has fixed the problem.

A few people have had this problem fixed but increasing their rpm idle speed. They say that the idle speed is too low. Other than that no matter what they changed under the hood, the light still flickered - I am concerned but not overly as I haven't come across anyone with gasket blown, or pistons rings warped due to this although in the long term if it start to pop-up more often id just sell it as I cant find a solution and I can't go to sleep at night.

Found a video on youtube of someone else looking for a solution:


Other people with the same problem on their e46

http://www.bimmerfest.com/forums/sho...d.php?t=524573
http://www.bimmerfest.com/forums/sho...d.php?t=629311
http://www.bimmerfest.com/forums/sho...d.php?t=601031
http://forums.bimmerforums.com/forum....php?t=1752267
http://forums.bimmerforums.com/forum....php?t=1638548
http://forums.bimmerforums.com/forum....php?t=1479638
http://forums.bimmerforums.com/forum...7#post19702257
http://forums.bimmerforums.com/forum....php?t=1251020
http://www.e46fanatics.com/forum/sho...d.php?t=830842
http://www.e46fanatics.com/forum/sho...d.php?t=834225
http://www.e46fanatics.com/forum/sho...d.php?t=769289
http://www.e46fanatics.com/forum/sho...d.php?t=747012
http://forum.e46fanatics.com/showthread.php?t=713945
http://forum.e46fanatics.com/showthread.php?t=930140
http://www.e46zone.com/forum/topic/3...t-at-hot-idle/
http://bmwland.co.uk/forums/viewtopic.php?t=110978
http://www.bimmerforums.co.uk/forum/...ht-red-t86149/
http://www.e46fanatics.com/forum/sho...d.php?t=790607
http://forum.e46fanatics.com/showthread.php?t=867631
http://forum.e46fanatics.com/showthread.php?t=846304
http://forum.e46fanatics.com/showthread.php?t=791181
http://www.bimmerfest.com/forums/sho...d.php?t=595778

nightflex is offline   Reply With Quote
Old 07-14-2012, 07:20 AM   #17
NOVAbimmer
Registered User
 
Join Date: Aug 2006
Location: VA
Posts: 12,572
My Ride: 14 Impala FXST M796
Our cars have catastrophic a/c failures?
__________________
NOVAbimmer is online now   Reply With Quote
Old 07-14-2012, 08:01 AM   #18
Adamo99
Registered User
 
Join Date: Jul 2008
Location: Port Credit, ON
Posts: 288
My Ride: e39 530i, e93 335i
Quote:
Originally Posted by NOVAbimmer View Post
Our cars have catastrophic a/c failures?
I think OP might be thinking the A/C system, instead of the cooling system.
Adamo99 is offline   Reply With Quote
Old 07-14-2012, 08:19 AM   #19
MercForHire
Registered User
 
Join Date: Mar 2011
Location: Waterloo,Ontario
Posts: 4,417
My Ride: 323Ci 5 Speed Black
He obviously doesn't know the reasons why the car breaks down. Only from what he heard.
But it's a good start i guess.
MercForHire is offline   Reply With Quote
Old 07-14-2012, 08:20 AM   #20
Solidjake
Zero. Oil. Leaks.
 
Solidjake's Avatar
 
Join Date: May 2008
Location: NYC
Posts: 22,559
My Ride: 2002 330i
Fix that oil issue before anything else.
Solidjake is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 06:12 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use