E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 10-27-2012, 11:54 AM   #1
willsbma
Registered User
 
Join Date: Jul 2006
Location: north babylon NY
Posts: 2,529
My Ride: 99 323i
Question Water pump/expansion tank dilemma

I was trying to search around but I'm not sure of what to search for.

Under normal operation the fill neck of the expansion tank has a small little hole that pisses coolant into the tank. I've observed this many times. Now if coolant does not piss from that little hole, does that mean the water pump is bad? My radiator is hot at the top and cold along the bottom which means either air pockets or no flow. Def no air in the system. My water pump is aftermarket with metal impeller but isn't weeping or making any noise. I might just pull it/replace anyway to be sure but I wanted some opinions. TIA fellas
__________________
Matte Black Kidney Grilles | Smoked Tails & Corners | Mtech II Bumper | Hotchkis Springs | ACS Roof Spoiler | M3 Spoiler | 20% Tint
WTB: Black sun visors & grab handles - PM ME!

I have P.A. Soft and a 20-pin adapter. Only used it a few times but pm me if you need anything coded!
willsbma is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 10-27-2012, 12:58 PM   #2
dmax
Registered User
 
dmax's Avatar
 
Join Date: Aug 2006
Location: NJ
Posts: 22,774
My Ride: '99 328i 1.04646 mu
First, lets start with the 'def no air in system' because there may be and you might not know it.

If you have a small leak somewhere and air gets into system, wp could cavitate when it swallows bubble and not pump.

That said, the coolant goes into top of radiator hot and should come out cooler from the bottom hose.

I never open mine up when it's running, so don't know if that little stream is diagnostic or not.

Maybe start with my 'alternative bleeding' method? Search me, 4K rpms, and 20 secs. I've written instructions a hundred times...should be easy to find. Give that a shot...and confirm that you're not leaking/seeping coolant.

Keep eT filled only to between min and max...don't overfill--I'm sure you know this.

...and a bump for you!

HTH
__________________


Performing at the Comedy Cove--595 Morris Ave. Springfield NJ reservations 973 376-3840

A recent set

dmax on the radio every Wednesday 7-9 p.m. NYC time. Call in! (661) 449-9340 watsonnwatson.com
dmax is offline   Reply With Quote
Old 10-27-2012, 01:09 PM   #3
///MPR77
Registered User
 
Join Date: Dec 2007
Location: Los Angeles
Posts: 1,852
My Ride: 02 ///M3 Tri-Ped
Quote:
Originally Posted by dmax View Post
First, lets start with the 'def no air in system' because there may be and you might not know it.

If you have a small leak somewhere and air gets into system, wp could cavitate when it swallows bubble and not pump.

That said, the coolant goes into top of radiator hot and should come out cooler from the bottom hose.

I never open mine up when it's running, so don't know if that little stream is diagnostic or not.

Maybe start with my 'alternative bleeding' method? Search me, 4K rpms, and 20 secs. I've written instructions a hundred times...should be easy to find. Give that a shot...and confirm that you're not leaking/seeping coolant.

Keep eT filled only to between min and max...don't overfill--I'm sure you know this.

...and a bump for you!

HTH
+1
I do this as well...get the car just warm enough to build some pressure. Then proceed with proper bleeding.

When the process is complete, you will need to remove excess coolant from et.
I believe it took about 5 normal size turkey basters to get it to the proper level on mine.

And damned if I didn't have to do it a couple of times.

So don't assume def no air in the system quite yet.
__________________

Bewahren Sie ihre ultimative fahrmaschine

Last edited by ///MPR77; 10-27-2012 at 01:15 PM.
///MPR77 is offline   Reply With Quote
Old 10-27-2012, 01:17 PM   #4
willsbma
Registered User
 
Join Date: Jul 2006
Location: north babylon NY
Posts: 2,529
My Ride: 99 323i
I should have mentioned i did the 4k 20 sec bleed too. I just finished replacing everything so im 99.9% pos of no leaks or air. Im gonna pull the belt and feel the pump now. If it feels funny at all im ripping it out.

Sent from my DROIDX using Bimmer App
__________________
Matte Black Kidney Grilles | Smoked Tails & Corners | Mtech II Bumper | Hotchkis Springs | ACS Roof Spoiler | M3 Spoiler | 20% Tint
WTB: Black sun visors & grab handles - PM ME!

I have P.A. Soft and a 20-pin adapter. Only used it a few times but pm me if you need anything coded!
willsbma is offline   Reply With Quote
Old 10-27-2012, 01:35 PM   #5
willsbma
Registered User
 
Join Date: Jul 2006
Location: north babylon NY
Posts: 2,529
My Ride: 99 323i
I just pulled the pump, the impeller was totally disconnected from the pump shaft and circulating no water. Figures...New w/p will be installed shortly.
__________________
Matte Black Kidney Grilles | Smoked Tails & Corners | Mtech II Bumper | Hotchkis Springs | ACS Roof Spoiler | M3 Spoiler | 20% Tint
WTB: Black sun visors & grab handles - PM ME!

I have P.A. Soft and a 20-pin adapter. Only used it a few times but pm me if you need anything coded!

Last edited by willsbma; 10-27-2012 at 02:03 PM.
willsbma is offline   Reply With Quote
Old 10-27-2012, 02:12 PM   #6
dmax
Registered User
 
dmax's Avatar
 
Join Date: Aug 2006
Location: NJ
Posts: 22,774
My Ride: '99 328i 1.04646 mu
Very nice you found it so quickly.

One thing you didn't mention in your first post was whether you were overheating or not. I'm presuming that maybe you noticed something...IDK.

Without wp circulating, your temp sensor on lower hose wouldn't raise the temp gauge, so I hope you hadn't been driving too far before you noticed this. I doubt it. There are other temp sensors that would probably have noticed something amiss...like oil temp sensor...so hope that's all it was.

Impressive you found it so quickly...glad you didn't mess around!

GL! (Oh, give us age and brand of that WP so we know to avoid it please!)
__________________


Performing at the Comedy Cove--595 Morris Ave. Springfield NJ reservations 973 376-3840

A recent set

dmax on the radio every Wednesday 7-9 p.m. NYC time. Call in! (661) 449-9340 watsonnwatson.com
dmax is offline   Reply With Quote
Old 10-27-2012, 07:20 PM   #7
willsbma
Registered User
 
Join Date: Jul 2006
Location: north babylon NY
Posts: 2,529
My Ride: 99 323i
Yea im glad i caught it fast too. I should have known earlier when the heat stopped working but ive been stressed and not really dedicated lately. I was mistaken when i said it was an upgraded metal impeller, it was not. I did however use metal this time. It's a brand new bosch for $50 from pep boys. I just did a leak down test and all the cylinders were within 20% so im pretty sure the motor is healthy still.

Sent from my DROIDX using Bimmer App
__________________
Matte Black Kidney Grilles | Smoked Tails & Corners | Mtech II Bumper | Hotchkis Springs | ACS Roof Spoiler | M3 Spoiler | 20% Tint
WTB: Black sun visors & grab handles - PM ME!

I have P.A. Soft and a 20-pin adapter. Only used it a few times but pm me if you need anything coded!
willsbma is offline   Reply With Quote
Old 10-27-2012, 09:03 PM   #8
Stinger9
Registered User
 
Join Date: Sep 2011
Location: New York
Posts: 7,747
My Ride: '04 330Ci
That's why I'm so comfortable with my Stewart pump.

Totally personal decision.

Last edited by Stinger9; 10-27-2012 at 09:46 PM.
Stinger9 is offline   Reply With Quote
Old 10-27-2012, 09:40 PM   #9
willsbma
Registered User
 
Join Date: Jul 2006
Location: north babylon NY
Posts: 2,529
My Ride: 99 323i
I've read a lot about the stewart pump and from what I've researched it seems that it's not worth the money. To each his own I guess.
__________________
Matte Black Kidney Grilles | Smoked Tails & Corners | Mtech II Bumper | Hotchkis Springs | ACS Roof Spoiler | M3 Spoiler | 20% Tint
WTB: Black sun visors & grab handles - PM ME!

I have P.A. Soft and a 20-pin adapter. Only used it a few times but pm me if you need anything coded!
willsbma is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 09:37 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use