E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 09-19-2012, 09:15 AM   #1
318ise
Registered User
 
Join Date: Sep 2012
Location: uk
Posts: 34
My Ride: 318i se
engine rattle help

hi guys, recently joined the forum but I have been on from time to time !

I have a problem with my 1999 318i , over the past few days a rattle has appeared .... it seems to be coming from inside the inlet manifold somewhere but its hard to narrow down where it is coming from . The noise does go away when the motor is under load and with throttle pressed but it does sound nasty at idle and de-acceleration.

VIDEO;



Is the anything mechanical that could be making this noise to the rear of the throttle cables ?or beneath that area ?

has anyone had similar problems ?

the car has covered 120.000miles but with full service history .

any help would be greatly appreciated,

M
318ise is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 09-19-2012, 10:16 AM   #2
GSherbs
Registered User
 
Join Date: Jun 2012
Location: Chicago
Posts: 399
My Ride: 2002 330 xi
Sounds like the DISA... replace it

Item #8: http://realoem.com/bmw/showparts.do?...13&hg=11&fg=40

Last edited by GSherbs; 09-19-2012 at 10:19 AM.
GSherbs is offline   Reply With Quote
Old 09-20-2012, 07:23 AM   #3
318ise
Registered User
 
Join Date: Sep 2012
Location: uk
Posts: 34
My Ride: 318i se
what is the adjuster unit is it a common fault ? has it got moving parts ? thanks
318ise is offline   Reply With Quote
Old 09-20-2012, 07:43 AM   #4
GSherbs
Registered User
 
Join Date: Jun 2012
Location: Chicago
Posts: 399
My Ride: 2002 330 xi
Yep. Sure does and it is a common failure.

Search youtube for DISA replacement - quite a few videos showing how it fails and makes noise.
GSherbs is offline   Reply With Quote
Old 09-20-2012, 08:27 AM   #5
318ise
Registered User
 
Join Date: Sep 2012
Location: uk
Posts: 34
My Ride: 318i se
thanks for the assistance! I'll let you know how it goes ,

M
318ise is offline   Reply With Quote
Old 09-20-2012, 08:33 AM   #6
GSherbs
Registered User
 
Join Date: Jun 2012
Location: Chicago
Posts: 399
My Ride: 2002 330 xi
Not a problem - definitely report back success or failure. Too many threads end without conclusions.

-G
GSherbs is offline   Reply With Quote
Old 09-20-2012, 04:10 PM   #7
318ise
Registered User
 
Join Date: Sep 2012
Location: uk
Posts: 34
My Ride: 318i se
Sure will! I might even make a video of the repair/removal if it will help people diy. I cant find a video on youtube that caters for the M43 4cyl but im sure i'll figure it out ! Thanks again.
318ise is offline   Reply With Quote
Old 10-07-2012, 01:34 PM   #8
318ise
Registered User
 
Join Date: Sep 2012
Location: uk
Posts: 34
My Ride: 318i se
Hi there ,

the conclusion is that it was the DISA valve which had play in the butterfly mechanisim , replaced it with a new unit and there is no noise ... AWSOME

thanks GSherbs for you pointing me in the right direction.
318ise is offline   Reply With Quote
Old 10-08-2012, 08:02 AM   #9
GSherbs
Registered User
 
Join Date: Jun 2012
Location: Chicago
Posts: 399
My Ride: 2002 330 xi
Welcome!

Glad the issue is fixed!
GSherbs is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 10:20 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use