E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > New Member Introductions

New Member Introductions
New members check-in, introduce yourselves, and post a picture of your BMW here!

Reply
 
Thread Tools Search this Thread Display Modes
Old 10-12-2012, 06:38 PM   #1
paulbbelt
Registered User
 
Join Date: Oct 2012
Location: ROANOKE VA
Posts: 4
My Ride: 2004 330 CI
Fault codes P2240, P0171, and P0174

New member. I have an 04 330ci w/ 90k miles. Threw above codes. I replaced 02 sensors bfore cat. Code still there. Slight smell?? Any ideas?
Thanks
Paul
PS foolish question....does car have to be off to reset code?
paulbbelt is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 10-12-2012, 06:47 PM   #2
jhaurimn
Registered User
 
Join Date: Aug 2010
Location: Minnesota
Posts: 534
My Ride: 01' 330ci
Check for vacuum leaks in all vacuum hoses an especially the intake boots. If they look old you should just replace them. They are cheap. And no the car doesn't have to be off ... But then again my car is never on when I read codes
__________________
PAST
2001 330ci - 117xxx (sold)
PRESENT
2001 M3 - 90xxx
1989 325i - 2??,???
jhaurimn is offline   Reply With Quote
Old 10-12-2012, 06:47 PM   #3
jhaurimn
Registered User
 
Join Date: Aug 2010
Location: Minnesota
Posts: 534
My Ride: 01' 330ci
And the smell... Smell like oil?
__________________
PAST
2001 330ci - 117xxx (sold)
PRESENT
2001 M3 - 90xxx
1989 325i - 2??,???
jhaurimn is offline   Reply With Quote
Old 10-12-2012, 07:58 PM   #4
a32axo
Registered User
 
Join Date: Dec 2010
Location: Cali
Posts: 245
My Ride: 2004 bmw 330CI
Vcg or oil filter housing gasket, your lean codes are prolly disa and intake boots, the p2240 still haven't figured out. I have same car as you but with 80000 miles.
a32axo is offline   Reply With Quote
Old 10-13-2012, 09:08 AM   #5
Solidjake
Zero. Oil. Leaks.
 
Solidjake's Avatar
 
Join Date: May 2008
Location: NYC
Posts: 22,211
My Ride: 2002 330i
+1 check your valve cover gasket. Simple DIY.
Solidjake is offline   Reply With Quote
Old 10-14-2012, 05:49 AM   #6
paulbbelt
Registered User
 
Join Date: Oct 2012
Location: ROANOKE VA
Posts: 4
My Ride: 2004 330 CI
Quote:
Originally Posted by a32axo View Post
Vcg or oil filter housing gasket, your lean codes are prolly disa and intake boots, the p2240 still haven't figured out. I have same car as you but with 80000 miles.
Read that it may be DME(?). Needs to be updated?
paulbbelt is offline   Reply With Quote
Old 10-14-2012, 05:49 AM   #7
paulbbelt
Registered User
 
Join Date: Oct 2012
Location: ROANOKE VA
Posts: 4
My Ride: 2004 330 CI
Quote:
Originally Posted by a32axo View Post
Vcg or oil filter housing gasket, your lean codes are prolly disa and intake boots, the p2240 still haven't figured out. I have same car as you but with 80000 miles.
Read that DME (?) may have to be updated?
paulbbelt is offline   Reply With Quote
Old 10-15-2012, 06:25 PM   #8
a32axo
Registered User
 
Join Date: Dec 2010
Location: Cali
Posts: 245
My Ride: 2004 bmw 330CI
Yea I know I searched and people say dme update, just want to be 100% sure.
a32axo is offline   Reply With Quote
Old 10-15-2012, 06:36 PM   #9
BWOODM3
Registered User
 
Join Date: Dec 2010
Location: Brentwood, CA
Posts: 394
My Ride: 2002 M3 convertible
Let us know when you figure this out
BWOODM3 is offline   Reply With Quote
Old 10-15-2012, 08:26 PM   #10
777eThOd*
Registered User
 
Join Date: Jun 2011
Location: Houston, TX
Posts: 1,151
My Ride: spins too much
I've had P0171 and P0174 for a year lol, I've changed out so much Sh*t that I just stopped lol. I ordered a new MAF Sensor and that didn't get rid of it and I ordered a new Intake boot but I haven't installed it. Tell me How this goes, btw Welcome..
__________________

2007 BMW 335i FBO 6MT - Current
2013 Nissan Nismo 370Z - Current
2004 Non-M Facelift Coupe - SOLD
2006 BMW M3 - SOLD
777eThOd* is offline   Reply With Quote
Old 10-15-2012, 10:35 PM   #11
a32axo
Registered User
 
Join Date: Dec 2010
Location: Cali
Posts: 245
My Ride: 2004 bmw 330CI
Quote:
Originally Posted by 777eThOd* View Post
I've had P0171 and P0174 for a year lol, I've changed out so much Sh*t that I just stopped lol. I ordered a new MAF Sensor and that didn't get rid of it and I ordered a new Intake boot but I haven't installed it. Tell me How this goes, btw Welcome..
Those codes I had also, bought intake boots and disa. Lean vides went away, I think it was disa valve!
a32axo is offline   Reply With Quote
Old 10-15-2012, 10:40 PM   #12
a32axo
Registered User
 
Join Date: Dec 2010
Location: Cali
Posts: 245
My Ride: 2004 bmw 330CI
P2240 p2237 still comes and goes, refers to oxygen sensors or dme update. I gen sensors are money for these years, $125 each. Dme update $80.
a32axo is offline   Reply With Quote
Old 10-15-2012, 10:41 PM   #13
777eThOd*
Registered User
 
Join Date: Jun 2011
Location: Houston, TX
Posts: 1,151
My Ride: spins too much
Quote:
Originally Posted by a32axo View Post
Those codes I had also, bought intake boots and disa. Lean vides went away, I think it was disa valve!
That's funny cause I was about to order a new DISA cause it's making a wierd rattling noise lol, then I can change out my intake boot aswell, thanks for the info.
__________________

2007 BMW 335i FBO 6MT - Current
2013 Nissan Nismo 370Z - Current
2004 Non-M Facelift Coupe - SOLD
2006 BMW M3 - SOLD
777eThOd* is offline   Reply With Quote
Old 10-15-2012, 11:07 PM   #14
a32axo
Registered User
 
Join Date: Dec 2010
Location: Cali
Posts: 245
My Ride: 2004 bmw 330CI
No problem man, here to help, that's what the forum is for, while your at it clean out your icv valve also.
a32axo is offline   Reply With Quote
Old 10-15-2012, 11:39 PM   #15
777eThOd*
Registered User
 
Join Date: Jun 2011
Location: Houston, TX
Posts: 1,151
My Ride: spins too much
Quote:
Originally Posted by a32axo View Post
No problem man, here to help, that's what the forum is for, while your at it clean out your icv valve also.
Already did a while ago
__________________

2007 BMW 335i FBO 6MT - Current
2013 Nissan Nismo 370Z - Current
2004 Non-M Facelift Coupe - SOLD
2006 BMW M3 - SOLD
777eThOd* is offline   Reply With Quote
Old 10-16-2012, 12:00 AM   #16
a32axo
Registered User
 
Join Date: Dec 2010
Location: Cali
Posts: 245
My Ride: 2004 bmw 330CI
Now only if we can get some help on the other codes, a lot of forum mechanics here but no one seems to have the answers, lol.
a32axo is offline   Reply With Quote
Old 10-16-2012, 08:32 PM   #17
paulbbelt
Registered User
 
Join Date: Oct 2012
Location: ROANOKE VA
Posts: 4
My Ride: 2004 330 CI
New twist. Drove car 35 miles. (car has been idling rough) Went to lunch and at start up the low coolant indicator came on. I put approx 1pint in radiator after allowing 5 hrs to cool. Drove back 35 miles. towards end of drive, a "smell" was coming through ac vents. Got home and lifted hood. Smells like coolant. No easily recognizable leaks or mist.
paulbbelt is offline   Reply With Quote
Old 10-16-2012, 09:11 PM   #18
777eThOd*
Registered User
 
Join Date: Jun 2011
Location: Houston, TX
Posts: 1,151
My Ride: spins too much
Quote:
Originally Posted by paulbbelt View Post
New twist. Drove car 35 miles. (car has been idling rough) Went to lunch and at start up the low coolant indicator came on. I put approx 1pint in radiator after allowing 5 hrs to cool. Drove back 35 miles. towards end of drive, a "smell" was coming through ac vents. Got home and lifted hood. Smells like coolant. No easily recognizable leaks or mist.
Welcome to my world, where the CEL is always on 24/7 cause of P0171 and P0174 and the low coolant lights up every morning and sometimes afternoon. I'm already used to it lol..
__________________

2007 BMW 335i FBO 6MT - Current
2013 Nissan Nismo 370Z - Current
2004 Non-M Facelift Coupe - SOLD
2006 BMW M3 - SOLD
777eThOd* is offline   Reply With Quote
Old 10-16-2012, 09:19 PM   #19
a32axo
Registered User
 
Join Date: Dec 2010
Location: Cali
Posts: 245
My Ride: 2004 bmw 330CI
These cars are very sensitive!!!! Lol. At least it has me learning how to be a mechanic. Never touch under a good of a car before.

So far, change differential oil, coolant flush with thermostat change, expansion tank and hoses, intake boots, cleaned icv, replaced disa. Next is ofhg, spark plugs, vanos.
a32axo is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 10:01 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use