E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Lighting Forum

Lighting Forum
Angel Eyes, DDEs, lighted rings, Clear Turn Signals, LEDs, Xenon, HID, or Bi-Xenon. If it lights up and you want to discuss it, post here!

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 1 votes, 5.00 average. Display Modes
Old 03-03-2013, 06:06 PM   #1
nerburgring
Registered User
 
Join Date: Jul 2007
Location: Swansea,South Wales.
Posts: 47
My Ride: 320ci M sport coupe
Question E46 Facelift Dip Headlamp Warning Light

Hiya guys, today my L/H Dip Headlamp warning lamp came on!

On further inspection of the headlamp bulbs, I realised that all the bulbs work ok!

But for some reason the warning lamp stays illuminated?

Also the L/H indicator bulb glows very dim when I switch on my side lights?

I have checked all bulbs and connections, but can't seem to sort the problem?

Any ideas chaps?? PLEEEEEASE!!!!
__________________
nerburgring is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 03-03-2013, 06:08 PM   #2
Zell
Registered User
 
Zell's Avatar
 
Join Date: Jun 2009
Location: Such City
Posts: 5,662
My Ride: '02 Dogemobile Shibe
I'd start by testing the battery and go from there, seeing as the indicator dims when you switch on the side lights.
__________________
Zell is offline   Reply With Quote
Old 03-03-2013, 06:12 PM   #3
nerburgring
Registered User
 
Join Date: Jul 2007
Location: Swansea,South Wales.
Posts: 47
My Ride: 320ci M sport coupe
Funny you should say that?

After constant ignition and headlights switched on for half an hour or so, I started the car, but the battery was sluggish!!

I have left my battery charging overnight as we speak, to try it again in the morning?

Still not sure about the warning lamp though??
__________________
nerburgring is offline   Reply With Quote
Old 03-03-2013, 06:17 PM   #4
Zell
Registered User
 
Zell's Avatar
 
Join Date: Jun 2009
Location: Such City
Posts: 5,662
My Ride: '02 Dogemobile Shibe
Really funky things happen on these cars when the battery starts to die because they are so computer-dependent. Undervolting electronics produces funny results. It could be that not a strong enough voltage is getting back to the ECU to determine if the lights are there or not.

The other month, my battery was dying, and I walked outside to find all my lights on, warning lights everywhere, and my key wasn't even in the ignition. Changed my battery and all's been well since. Start there, and if it doesn't fix it, we can delve into the LCM.
__________________
Zell is offline   Reply With Quote
Old 03-03-2013, 06:23 PM   #5
nerburgring
Registered User
 
Join Date: Jul 2007
Location: Swansea,South Wales.
Posts: 47
My Ride: 320ci M sport coupe
Ok Cheers Zell

I'll try that tomorrow and see how we get on?

Thank you again my friend!!
__________________
nerburgring is offline   Reply With Quote
Old 03-04-2013, 09:31 AM   #6
nerburgring
Registered User
 
Join Date: Jul 2007
Location: Swansea,South Wales.
Posts: 47
My Ride: 320ci M sport coupe
Well I've charged battery, voltage 13.7 volts, so battery holding charge ok!
But still the L/H indicator glows when the side lights are switched on?
But goes off when the dip beam is switched on?
Warning lamp on dash stays illuminated the whole time though??
Anyone got any ideas??
__________________
nerburgring is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 12:11 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use