E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 10-23-2012, 02:03 PM   #1
ebarry
Registered User
 
Join Date: Oct 2012
Location: AZ
Posts: 4
My Ride: 2002 330ci
New to Forum, code p0174

Got code p0174 found a vacuum line broken fixed it and it is still there. Car runs for about 5 min. then runs rough then stalls. I had to have it towed to my house didnt want to drive it. Could it be pre-cat sensors 146,000 miles I dont think they were ever changed
ebarry is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 10-23-2012, 02:15 PM   #2
330i ZHP
Registered User
 
330i ZHP's Avatar
 
Join Date: Mar 2005
Location: Washington, DC
Posts: 21,641
My Ride: have 5 doors and FI
Send a message via AIM to 330i ZHP Send a message via Yahoo to 330i ZHP
vacuum leak - cheak the intake piping - often cracked
__________________
/_________\
OO=[][]=OO
330i ZHP is offline   Reply With Quote
Old 10-23-2012, 02:22 PM   #3
ebarry
Registered User
 
Join Date: Oct 2012
Location: AZ
Posts: 4
My Ride: 2002 330ci
I checked didnt find anything, cleaned MAS, getting ready to check DISA valve, if anyone has any input please help before I tear the whole car apart
ebarry is offline   Reply With Quote
Old 10-23-2012, 08:22 PM   #4
jfoj
Registered User
 
Join Date: Nov 2009
Location: Fairfax, VA USA
Posts: 8,493
My Ride: '06 330CiC, '03 M5
Suggest you read the first link below in my signature.

Probably will give you all the info you need to know.

One common problem that is hard to find is the CCV lower oil return hose that connects to the dipstick.
__________________
Solve your misfires, lean codes, rough idle - http://forum.e46fanatics.com/showthread.php?t=897616

Fuel pump failures - http://forum.e46fanatics.com/showthread.php?t=929501

Temp Info - http://forum.e46fanatics.com/showthread.php?t=964491

Hidden OBC Menu - Check Voltage, Temps, Fuel Level - http://forum.e46fanatics.com/showthread.php?t=239619

E46/E39 GM5 Door Lock Info - www.bmwgm5.com

Lower hose fan switch O-ring - BMW #13621743299
jfoj is offline   Reply With Quote
Old 10-24-2012, 10:43 AM   #5
ebarry
Registered User
 
Join Date: Oct 2012
Location: AZ
Posts: 4
My Ride: 2002 330ci
Thanks I did read it the other day, I read alot that the car runs rough but not stalling, I can drive mine for a few minutes then it starts running rough then stalls. I checked the disa valve and it is shot could this be the reason?
ebarry is offline   Reply With Quote
Old 10-24-2012, 10:52 AM   #6
Mango
Grand Superpatriot Sport+
 
Mango's Avatar
 
Join Date: Mar 2006
Location: Southern California
Posts: 22,153
My Ride: M54B30
You won't find anything. A tear in the vacuum system or weak link in the fuel delivery system can cause these codes. My honest and genuine suggestion is to see sig, do it all.

__________________
A lifetime free of problems if you follow my guides
Cooling | Maintenance | Suspension | Vacuum | Supreme Reliability | Details

OVER A MILLION VIEWS
Mango is offline   Reply With Quote
Old 10-24-2012, 10:56 AM   #7
GSherbs
Registered User
 
Join Date: Jun 2012
Location: Chicago
Posts: 399
My Ride: 2002 330 xi
Quote:
Originally Posted by ebarry View Post
Thanks I did read it the other day, I read alot that the car runs rough but not stalling, I can drive mine for a few minutes then it starts running rough then stalls. I checked the disa valve and it is shot could this be the reason?
It is likely one of several reasons. If its toast, replace it and move on to the next possible culprit.
GSherbs is offline   Reply With Quote
Old 10-24-2012, 11:13 AM   #8
ebarry
Registered User
 
Join Date: Oct 2012
Location: AZ
Posts: 4
My Ride: 2002 330ci
that seems to be the way to go just trying to keep costs down, I forgot to mention that I also got a p0444 code to start the whole thing. I went to autozone to see why the check engine light was on, they got 2 codes and cleared them and forgot what one of them was. the one they told me was p0444 and i guess the one they forgot was the p0174 because when i got stuck on the side of the road on the way to get the code checked again the code was the p0174
ebarry is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 06:13 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use