E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 10-17-2012, 09:43 PM   #1
The last emperor
Registered User
 
Join Date: Aug 2012
Location: Virginia
Posts: 182
My Ride: 03 BMW e46
Abs, brake and traction control lights came on

What could have caused this? What's the problem and how can I fix it? Should I still drive the car on the hwy or is it dangerous?
Attached Thumbnails
Click image for larger version

Name:	ImageUploadedByBimmerApp1350528213.280390.jpg
Views:	68
Size:	29.8 KB
ID:	474424  
__________________
Respect all, Fear none
The last emperor is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 10-17-2012, 11:21 PM   #2
afstud
Registered User
 
Join Date: Jun 2010
Location: NE Wisconsin
Posts: 1,011
My Ride: 2003 ZHP 6-speed
Search its probably one of your front abs sensors that's mounts to the wheel hub assembly, I had this issue a few weeks back, if those lights are on and your speedo doesn't work then its a rear abs sensor
__________________
2003 330i ZHP 6 speed
afstud is offline   Reply With Quote
Old 10-22-2012, 04:43 PM   #3
TheJonRoss
Registered User
 
Join Date: Mar 2012
Location: Lincoln, NE
Posts: 141
My Ride: 2002 325xi, 2005 X5
That will sometimes happen after you've disconnected your battery. It will go away after a few minutes of driving. But your case may be different.
__________________
-Jon

BMWCCA# 473325



Join the Experience
TheJonRoss is offline   Reply With Quote
Old 10-25-2012, 01:44 PM   #4
Mike666
Registered User
 
Join Date: Nov 2007
Location: MA
Posts: 19
My Ride: 2000 323i
Wheel Speed sensor has gone bad - happened to me.
Mike666 is offline   Reply With Quote
Old 10-25-2012, 01:50 PM   #5
Custom3
Registered User
 
Join Date: Sep 2005
Location: Dirty Jersey
Posts: 5,437
My Ride: HellRot 330CI
that sensor isnt cheap either ......smh
Custom3 is offline   Reply With Quote
Old 10-25-2012, 01:51 PM   #6
The last emperor
Registered User
 
Join Date: Aug 2012
Location: Virginia
Posts: 182
My Ride: 03 BMW e46
They turned off after a while but I should replace it anyways
__________________
Respect all, Fear none
The last emperor is offline   Reply With Quote
Old 10-25-2012, 04:09 PM   #7
shahbaz99
Registered User
 
Join Date: Apr 2009
Location: Toronto,On
Posts: 263
My Ride: Clean 330ci
wheel speed sensor. try cleaning it first, theres diy out there for it. I cleaned mine up and haven't had the lights since.
__________________
shahbaz99 is offline   Reply With Quote
Old 10-26-2012, 10:05 AM   #8
aahmed2016
Registered User
 
Join Date: Sep 2012
Location: Jonesboro, GA, USA
Posts: 759
My Ride: 2003 330i ZSP/CP/PP
Quote:
Originally Posted by The last emperor View Post
What could have caused this? What's the problem and how can I fix it? Should I still drive the car on the hwy or is it dangerous?
Do this,
Turn your car on, but not the engine. turn on your stereo. LOUD. Flash your headlights. if the stereo shuts off or headlights are dim, its just your battery. you just need to charge it.
__________________

Quote:
Originally Posted by MercForHire View Post
Spends $2000 on car DVD + stereo -> Running 25000 mile oil changes and 87 gas with blown shocks
aahmed2016 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 04:55 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use