E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Forced Induction Forum Sponsored by Active Autowerke

Forced Induction Forum Sponsored by Active Autowerke
Discuss supercharging, turbocharging and even nitrous and water injection here.
Sponsored by Active Autowerke

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 06-24-2012, 12:26 PM   #1
bAby norAA
Registered User
 
Join Date: Feb 2010
Location: Vermont
Posts: 513
My Ride: 01 BMW 330i
newly supercharged. keep throwing P1500 cosde (ICV)

Like the title says, I just finished my supercharger install last night, and it ran a good 100 miles without a code or problem. Now all of a sudden I keep throwing a P1500 code and sending my car into limp mode. My ICV is fairly new, I replaced it less then 5,000 miles ago. Where should I start my troubleshooting? All lines are tight, and vacuum sources are all connected properly.

It doesn't throw the code during hard acceleration, just while cruising.

Any ideas or imput is welcome.
__________________

| VF Supercharged Stage 1.5| Southbend Stage 2 Clutch | ZHP Cams | Technik Headers |
bAby norAA is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 06-24-2012, 10:50 PM   #2
xphiledan
Registered User
 
Join Date: Oct 2010
Location: East Hanover, NJ
Posts: 70
My Ride: 01 330i, 89 325i
did you get the car tuned after the sc install?
xphiledan is offline   Reply With Quote
Old 06-25-2012, 09:58 AM   #3
Viral@ActiveAutowerke
Sponsor
 
Viral@ActiveAutowerke's Avatar
 
Join Date: Nov 2008
Location: Miami, Florida
Posts: 1,195
My Ride: E46 M3
Quote:
Originally Posted by bAby norAA View Post
Like the title says, I just finished my supercharger install last night, and it ran a good 100 miles without a code or problem. Now all of a sudden I keep throwing a P1500 code and sending my car into limp mode. My ICV is fairly new, I replaced it less then 5,000 miles ago. Where should I start my troubleshooting? All lines are tight, and vacuum sources are all connected properly.

It doesn't throw the code during hard acceleration, just while cruising.

Any ideas or imput is welcome.
Congrats on your recent install of our Active Autowerke Supercharger Kit on your E46. The P1500 fault code could be related to the Mass Meter being faulty or you have directly air hitting the intake causing turbulence. If that doesn't smoke test the vehicle for possible leaks. If you have any questions please feel free to contact me directly via E-mail or by Phone listed below.
__________________
Viral Vahia
Active Autowerke | 9940 SW 168 Terrace Miami, Florida 33157
www.activeautowerke.com | viral@activeautowerke.com
Phone: 305.233.9300 Ext. 232 | Fax: 305-253-8921
Viral@ActiveAutowerke is offline   Reply With Quote
Old 06-25-2012, 11:21 AM   #4
bAby norAA
Registered User
 
Join Date: Feb 2010
Location: Vermont
Posts: 513
My Ride: 01 BMW 330i
Quote:
Originally Posted by xphiledan View Post
did you get the car tuned after the sc install?
Nope I haven't yet. I plan to soon

Quote:
Originally Posted by Viral@ActiveAutowerke View Post
Congrats on your recent install of our Active Autowerke Supercharger Kit on your E46. The P1500 fault code could be related to the Mass Meter being faulty or you have directly air hitting the intake causing turbulence. If that doesn't smoke test the vehicle for possible leaks. If you have any questions please feel free to contact me directly via E-mail or by Phone listed below.
Thanks! I didn't have any problems with the MAF before hand, so I pulled out my ICV again and put a full can of carb cleaner through it with some compressed air. I haven't thrown the code again yet, so we shall see. I plan on getting a smoke test done later on this week
__________________

| VF Supercharged Stage 1.5| Southbend Stage 2 Clutch | ZHP Cams | Technik Headers |
bAby norAA is offline   Reply With Quote
Old 06-25-2012, 01:51 PM   #5
Viral@ActiveAutowerke
Sponsor
 
Viral@ActiveAutowerke's Avatar
 
Join Date: Nov 2008
Location: Miami, Florida
Posts: 1,195
My Ride: E46 M3
Quote:
Originally Posted by bAby norAA View Post
Nope I haven't yet. I plan to soon



Thanks! I didn't have any problems with the MAF before hand, so I pulled out my ICV again and put a full can of carb cleaner through it with some compressed air. I haven't thrown the code again yet, so we shall see. I plan on getting a smoke test done later on this week
Alright perfect please send in the ECU ASAP to get the Software Tuning
__________________
Viral Vahia
Active Autowerke | 9940 SW 168 Terrace Miami, Florida 33157
www.activeautowerke.com | viral@activeautowerke.com
Phone: 305.233.9300 Ext. 232 | Fax: 305-253-8921
Viral@ActiveAutowerke is offline   Reply With Quote
Old 06-25-2012, 02:04 PM   #6
bAby norAA
Registered User
 
Join Date: Feb 2010
Location: Vermont
Posts: 513
My Ride: 01 BMW 330i
Quote:
Originally Posted by Viral@ActiveAutowerke View Post
Alright perfect please send in the ECU ASAP to get the Software Tuning
oh oh oh no, i have all the correct ecu software installed, sorry i was thinking getting it tuned on a dyno.
__________________

| VF Supercharged Stage 1.5| Southbend Stage 2 Clutch | ZHP Cams | Technik Headers |
bAby norAA is offline   Reply With Quote
Old 11-08-2012, 07:07 PM   #7
03E40sick
Registered User
 
Join Date: Feb 2009
Location: Metairie, La
Posts: 228
My Ride: 2003 bmw 325ci
Send a message via Yahoo to 03E40sick Send a message via Skype™ to 03E40sick
Anything new with your car, did you ever get the code again ?
__________________
bimmers is the way to go........
03E40sick is offline   Reply With Quote
Old 11-09-2012, 03:03 PM   #8
STORMER
Registered User
 
Join Date: Sep 2009
Location: Canada
Posts: 1,055
My Ride: AA SC 98 M3
Quote:
Originally Posted by 03E40sick View Post
Anything new with your car, did you ever get the code again ?
Chances are he didnt since we never heard from him again
__________________


360+rwhp

AA Stage 2, Arp2000, Underdrive Pulley, M50 Manifold, Cat Delete, Supersprint Exhaust, M5 Clutch w/ Lightweight Flywheel, Euro Fan, FK Coilovers, AEM Boost Gauge, Zhp Knob, Stoptech Brakes, R1 Rotors

Quote:
Originally Posted by Sweetness View Post
You sir, just thread jacked the sh!t out of OP.
STORMER is offline   Reply With Quote
Old 11-09-2012, 04:30 PM   #9
03E40sick
Registered User
 
Join Date: Feb 2009
Location: Metairie, La
Posts: 228
My Ride: 2003 bmw 325ci
Send a message via Yahoo to 03E40sick Send a message via Skype™ to 03E40sick
Well I still have this issue don't know what els to do .. Taking everything out this weekend and cleaning it really good .. We will go from there
__________________
bimmers is the way to go........
03E40sick is offline   Reply With Quote
Old 11-21-2012, 12:25 AM   #10
myOwnM3
Registered User
 
Join Date: Oct 2004
Location: NYC
Posts: 239
My Ride: 00 S4
correct me if im wrong but ICV is totally different from a MAF. defenitly check for a leak in the system.
myOwnM3 is offline   Reply With Quote
Old 11-21-2012, 03:16 AM   #11
332xi
Registered User
 
Join Date: Jul 2008
Location: haymarket, va
Posts: 142
My Ride: too fast e46/330xi
when i kept getting the icv code after supercharging, it was cause my iat was malfunctioning and the ecu would thought the icv was stuck due to the faulty high temp reading from my sensor.

what kind of supercharger setup do you have? and where is your sensor mounted?
332xi is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 09:56 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use