E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 10-14-2012, 03:33 PM   #1
Jmett1988
Registered User
 
Join Date: Oct 2012
Location: ohio
Posts: 8
My Ride: 2002 bmw 325i
HELP PLEASE!! 2002 bmw 325i with idle problems and eml light

Hi everyone! i have a 2002 bmw 325i 6 cyl. and i have been having all kinds of problems. I bought the car a year ago used and about a day after i bought it,the SES light came on. The bmw dealership said it was a cam sensor and replaced it. But there were still idle problems. i took it back and then they said it was the exhaust cam sensor this time. I put that on and it was still doing it, and they replaced the cam sensor again under warranty bc that was the code for the 3rd time. i was driving a hour and fifteen minutes to the bmw dealer and got tired of it so i'm trying to do the stuff myself to save money. i replaced the ICV and mass air flow sensor and still does it. When i go to slow down at a stop light the RPM's drop to like 400 then jump to like 1000 then fall to 200 then to 800 then it stalls. I also notice the gas mpg gaugen(which is from 50-12mpg), when the rpm start jumping its jumping up and down as well. Its real bad when I'm pulling through a drive through. If i play with the throttle a couple times then it will be okay and not stall and the rpms will be normal. Also recently when im driving the EML light,Traction control hazard light, brake like (lights up yellow) comes on. when i let off the gas while driving it jerks a little bit and when i slow down the rpms go to like 3-400 and kinda bounce. But when it comes on i just turn the car off and back on and it goes away for a while. If anyone can please direct me it would be much appreciated. i think it has something to do with fuel but here are the codes i just got from advance auto. P0313 P0313pending p0103 p1500 p0172 p175. THANKS
Jmett1988 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 10-14-2012, 04:15 PM   #2
Wickedly
Registered User
 
Join Date: Jun 2010
Location: Pittsburgh-DC Area
Posts: 846
My Ride: BMW 2003 325i
how many miles the car has?
Wickedly is offline   Reply With Quote
Old 10-14-2012, 05:45 PM   #3
jfoj
Registered User
 
Join Date: Nov 2009
Location: Fairfax, VA USA
Posts: 8,545
My Ride: '06 330CiC, '03 M5
Suggest you start by reviewing the first 2 links below in my signature.

These cover VERY common issues with the E46.
__________________
Solve your misfires, lean codes, rough idle - http://forum.e46fanatics.com/showthread.php?t=897616

Fuel pump failures - http://forum.e46fanatics.com/showthread.php?t=929501

Temp Info - http://forum.e46fanatics.com/showthread.php?t=964491

Hidden OBC Menu - Check Voltage, Temps, Fuel Level - http://forum.e46fanatics.com/showthread.php?t=239619

E46/E39 GM5 Door Lock Info - www.bmwgm5.com

Lower hose fan switch O-ring - BMW #13621743299
jfoj is offline   Reply With Quote
Old 10-14-2012, 06:35 PM   #4
Jmett1988
Registered User
 
Join Date: Oct 2012
Location: ohio
Posts: 8
My Ride: 2002 bmw 325i
it has 91000 miles
Jmett1988 is offline   Reply With Quote
Old 10-14-2012, 06:41 PM   #5
Jmett1988
Registered User
 
Join Date: Oct 2012
Location: ohio
Posts: 8
My Ride: 2002 bmw 325i
thaks jfoj. Thanks that actually helps out i just don't understand why the dealer cant say what it is..when the mpg gauge kinda rises and drops randomly could that mean one of the hoses for vacuum that goes to the fuel regulator be it. I thought that mpg gauge went off vacuum and if so i wonder if it could have a leak and suck air when i let off the gas
Jmett1988 is offline   Reply With Quote
Old 10-14-2012, 07:07 PM   #6
Mcbridges11
Registered User
 
Join Date: Mar 2012
Location: Maine
Posts: 143
My Ride: 03 325i, 03 540i
could be a lot of things- id go by the codes to diagnose to start- at 91k id suggest looking into a fuel filter- maybe ccv...ill think about it and get back to ya!
Mcbridges11 is offline   Reply With Quote
Old 10-14-2012, 07:08 PM   #7
Mcbridges11
Registered User
 
Join Date: Mar 2012
Location: Maine
Posts: 143
My Ride: 03 325i, 03 540i
Quote:
Originally Posted by jfoj View Post
Suggest you start by reviewing the first 2 links below in my signature.

These cover VERY common issues with the E46.
- vanos could be another place to start- jfoj gave you some good places to start! use them!
Mcbridges11 is offline   Reply With Quote
Old 10-14-2012, 07:30 PM   #8
Jmett1988
Registered User
 
Join Date: Oct 2012
Location: ohio
Posts: 8
My Ride: 2002 bmw 325i
well i will start with the fuel and if that's not it to the vanos i go lol thanks everyone its much appreciated. If anyone thinks of anything else feel free to let me know!
Jmett1988 is offline   Reply With Quote
Old 10-15-2012, 02:11 AM   #9
madunix
Registered User
 
Join Date: Jan 2008
Location: NY
Posts: 109
My Ride: Silver 01' BMW 325ci
also cleaning out your IACV and Throttle body won't hurt. might help a bit.
madunix is offline   Reply With Quote
Old 10-15-2012, 06:43 PM   #10
Jmett1988
Registered User
 
Join Date: Oct 2012
Location: ohio
Posts: 8
My Ride: 2002 bmw 325i
well i just purchased a fuel filter for it. While i was their i had them run the codes since i reset them the other day. Now the codes i have are p1500 p0172 p0175. I have not yet put the new fuel filter on but i plan to put it on tomorrow. I have also noticed if i sit in neutral and barley keep hittin the gas pedal it sputters and acts like its going to stall..im still leaning towards a fuel problem since its only when im pressing the gas pedal erratically. Any advice???Thanks again everyone
Jmett1988 is offline   Reply With Quote
Old 11-04-2012, 03:13 PM   #11
03E40sick
Registered User
 
Join Date: Feb 2009
Location: Metairie, La
Posts: 228
My Ride: 2003 bmw 325ci
Send a message via Yahoo to 03E40sick Send a message via Skype™ to 03E40sick
Anything new with the your car ?? Did you end up solving the problem ? What was the issue ?
__________________
bimmers is the way to go........
03E40sick is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 01:35 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use