E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 11-04-2012, 03:02 PM   #1
geoffriehl
Registered User
 
Join Date: Dec 2011
Location: GA
Posts: 327
My Ride: 2001 330ci ZSP
coolant drip...drip...drip...drip

hey guys, well I did replace my radiator with one from Pelican about 2 months ago and everything was good to go...get home today after running errands...drip....drip....drip.....crawl under the car....the coupling point between the lower hose (heater hose maybe?) off the reservoir and the reservoir is dripping steady....here is the million dollar question...I know I need to take it all apart to see what is what to begin with but....can I maybe just replace the o-rings in there or will I need an entire new hose? --- I did replace my reservoir about a year ago...I had been planning on doing my water pump, off-set roller, and tensioner anyway soon, so I parked it until I get all my parts together....

suggestions on the current drip?
__________________
2001 330ci ZSP 5 sp, 217k and counting!!!

fancy M3 steering wheeL, 19's, clear lens set

stock otherwise

geoffriehl is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 11-04-2012, 03:06 PM   #2
scarede46er
Registered User
 
Join Date: Aug 2012
Location: Clemson, SC
Posts: 1,256
My Ride: 2001 BMW 325i ZSP
well if you never changed the hose you should get a new one. cheap insurance.

Last edited by scarede46er; 11-04-2012 at 03:07 PM.
scarede46er is offline   Reply With Quote
Old 11-04-2012, 03:15 PM   #3
geoffriehl
Registered User
 
Join Date: Dec 2011
Location: GA
Posts: 327
My Ride: 2001 330ci ZSP
is that hose the "Water Hose, Water Pipe to Expansion Tank" hose?
__________________
2001 330ci ZSP 5 sp, 217k and counting!!!

fancy M3 steering wheeL, 19's, clear lens set

stock otherwise

geoffriehl is offline   Reply With Quote
Old 11-04-2012, 04:13 PM   #4
dmax
Registered User
 
dmax's Avatar
 
Join Date: Aug 2006
Location: NJ
Posts: 22,851
My Ride: '99 328i 1.04646 mu
AFAIK, no one has found a PN for just the o-ring in the hose, but that's probably all it is. Hoses are pretty good. But failing that, the hose sounds like your issue. Maybe you'll get lucky and you just need to push it on further...but not too likely.

If you drained the entire system when doing radiator, save what coolant you can and strain through paint strainer. You probably could find 0-ring...and if it's the hose going to the hard pipe, good luck. That one took me an hour to get apart since I didn't want to be too rough on the hard pipe. It's pretty firm, but still, old brittle plastic. If the hard pipe cracks, you have to remove intake mani to get it.
__________________


Performing at the Comedy Cove--595 Morris Ave. Springfield NJ reservations 973 376-3840

A recent set Skip to 1:30
dmax is offline   Reply With Quote
Old 11-04-2012, 05:45 PM   #5
geoffriehl
Registered User
 
Join Date: Dec 2011
Location: GA
Posts: 327
My Ride: 2001 330ci ZSP
So the o-ring in the hose fails? Can I just try and match up an o-ring? Is it made as part of the hose? And I already made sure I had it installed all the way in
__________________
2001 330ci ZSP 5 sp, 217k and counting!!!

fancy M3 steering wheeL, 19's, clear lens set

stock otherwise

geoffriehl is offline   Reply With Quote
Old 11-04-2012, 06:04 PM   #6
Zell
Registered User
 
Zell's Avatar
 
Join Date: Jun 2009
Location: wow such city
Posts: 5,751
My Ride: Has no throttle
The O-ring is inside the hose, you can see it when you take out the hose.

It is removable, I just removed it from my old one just now. Here are some reference pictures to help find the right size:



__________________
Zell is offline   Reply With Quote
Old 11-04-2012, 06:09 PM   #7
geoffriehl
Registered User
 
Join Date: Dec 2011
Location: GA
Posts: 327
My Ride: 2001 330ci ZSP
Sweet! I'm oing to try that first!!! Appreciate it!
__________________
2001 330ci ZSP 5 sp, 217k and counting!!!

fancy M3 steering wheeL, 19's, clear lens set

stock otherwise

geoffriehl is offline   Reply With Quote
Old 11-04-2012, 06:14 PM   #8
Zell
Registered User
 
Zell's Avatar
 
Join Date: Jun 2009
Location: wow such city
Posts: 5,751
My Ride: Has no throttle
BTW:

http://diytoolshopper.com/product_in...621e8fb106558f

Best thing you can have in your toolkit!
__________________
Zell is offline   Reply With Quote
Old 11-04-2012, 06:17 PM   #9
geoffriehl
Registered User
 
Join Date: Dec 2011
Location: GA
Posts: 327
My Ride: 2001 330ci ZSP
Nice!
__________________
2001 330ci ZSP 5 sp, 217k and counting!!!

fancy M3 steering wheeL, 19's, clear lens set

stock otherwise

geoffriehl is offline   Reply With Quote
Old 11-05-2012, 03:27 PM   #10
SDpnoy
Registered User
 
Join Date: Oct 2003
Location: Cali
Posts: 645
My Ride: 330Ci and M3
I see that you have a 2001. I would recommend replacing the hose as well. I'm replacing mine this week.
SDpnoy is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 02:27 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use