E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Driveline, Engine & DME Tuning

Driveline, Engine & DME Tuning
Talk about driveline improvements, NA tuning and DME tuning your E46 BMW here. This includes diffs, intakes, exhausts, chips, software and OBD tuning.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 06-23-2013, 01:34 AM   #1
YOLO89
Registered User
 
Join Date: Apr 2012
Location: Tampa, FL
Posts: 138
My Ride: Hooptie
Is my transmission malfunctioning?

I have an 03 325ci auto with 134k miles on it. Tonight I was driving onto the highway and around the on ramp was a puddle of water that I didn't see till it was too late. I ran through it going 15-20 mph and immediately let off the gas. After I hit the puddle I felt my transmission kind of buckle and then the check engine light came on along with an indicator I've never seen before next to the D gear on screen. Anyone ever come across this issue and if so what's the solution to resolving this problem?

TIA
Click image for larger version

Name:	ImageUploadedByBimmerApp1371965622.385348.jpg
Views:	85
Size:	142.6 KB
ID:	512570


Sent from BimmerApp mobile app
YOLO89 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 06-28-2013, 09:38 AM   #2
hateflkasraei
Registered User
 
Join Date: Feb 2013
Location: Upland, CA, US
Posts: 9
My Ride: 2001 BMW 325I
I know its a little late for this, but that light next to the D means " DO NOT drive the car at all" even if you don't feel anything.

That light basically is for major problems with the car since the check engine light is for small ones which don't matter if you drive the car with it.
Now, that light next to the D might even turn on when your battery is messing up, or it could be major failure in transmission
.
Since you said you ran through water, that is exactly what caused it in your case. The main computer, or the wires are wet and maybe damaged. Mine has a same problem now, its getting fixed. They have to check the wires and the computer. It could be only wired, or only computer, or both. These wires and computer are placed under the transmission, that's why they get damaged like this easily by going through water.
There is no do it yourself job here unless you are an BMW mechanic. Take it to dealer or any autoshop that does BMW. I would say take it to a transmission shop which do BMW transmissions.
I hope the problem is not mechanical. Be careful, if you drive it in this condition, there is a high chance that you damage your transmission or any other parts since the computer actually runs them and for now it doesn't function well. Tow your car, just to be safe.

Good luck!
hateflkasraei is offline   Reply With Quote
Old 06-28-2013, 10:58 AM   #3
swordsman11868
Registered User
 
Join Date: Aug 2006
Location: Las Vegas
Posts: 598
My Ride: 2003 325i
Is my transmission malfunctioning?

That light also comes on when you forget to reconnect the MAF cable.


Sent from BimmerApp mobile app
__________________
Crusaders - killing Takfiris since 1096 A.D.
swordsman11868 is offline   Reply With Quote
Old 06-28-2013, 04:48 PM   #4
YOLO89
Registered User
 
Join Date: Apr 2012
Location: Tampa, FL
Posts: 138
My Ride: Hooptie
Is my transmission malfunctioning?

Quote:
Originally Posted by hateflkasraei View Post
I know its a little late for this, but that light next to the D means " DO NOT drive the car at all" even if you don't feel anything.

That light basically is for major problems with the car since the check engine light is for small ones which don't matter if you drive the car with it.
Now, that light next to the D might even turn on when your battery is messing up, or it could be major failure in transmission
.
Since you said you ran through water, that is exactly what caused it in your case. The main computer, or the wires are wet and maybe damaged. Mine has a same problem now, its getting fixed. They have to check the wires and the computer. It could be only wired, or only computer, or both. These wires and computer are placed under the transmission, that's why they get damaged like this easily by going through water.
There is no do it yourself job here unless you are an BMW mechanic. Take it to dealer or any autoshop that does BMW. I would say take it to a transmission shop which do BMW transmissions.
I hope the problem is not mechanical. Be careful, if you drive it in this condition, there is a high chance that you damage your transmission or any other parts since the computer actually runs them and for now it doesn't function well. Tow your car, just to be safe.

Good luck!
Yeah I ran the codes and it stated that cylinder 4/6 were misfiring and I couldn't seem to figure out the the last code, but if anyone could chime in to what it is I'd appreciate it. Code is P1732. I dried out the filter and MAF and now it seems to be running fine. No lights or anything kind of strange.


Sent from BimmerApp mobile app
YOLO89 is offline   Reply With Quote
Old 06-28-2013, 04:49 PM   #5
YOLO89
Registered User
 
Join Date: Apr 2012
Location: Tampa, FL
Posts: 138
My Ride: Hooptie
Is my transmission malfunctioning?

Quote:
Originally Posted by swordsman11868 View Post
That light also comes on when you forget to reconnect the MAF cable.


Sent from BimmerApp mobile app
Everything was connected and the light came on after I struck a puddle of water. Thankfully now all the warning lights have gone away but I'm still weary on it. Probably going to take it into my buddies shop tomorrow


Sent from BimmerApp mobile app
YOLO89 is offline   Reply With Quote
Old 06-28-2013, 06:48 PM   #6
hateflkasraei
Registered User
 
Join Date: Feb 2013
Location: Upland, CA, US
Posts: 9
My Ride: 2001 BMW 325I
Good to hear that the light is gone, but it might come back after a while. I hope it doesn't though. I'm not a mechanic, so I don't know about that code. But I know some new scanners have details about the code. Maybe u can find out by googling. I also know there are some programs that u can install to your laptop and they act as an scanner. They might have the code.
hateflkasraei is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Censor is OFF





All times are GMT -5. The time now is 03:47 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use