E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Lighting Forum

Lighting Forum
Angel Eyes, DDEs, lighted rings, Clear Turn Signals, LEDs, Xenon, HID, or Bi-Xenon. If it lights up and you want to discuss it, post here!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 04-21-2015, 05:29 PM   #1
mangomagic
Registered User
 
Join Date: Feb 2015
Location: Australia
Posts: 24
My Ride: BMW
Problem with headlight

Hi my head light (R) have been playing up, it flickers then sometimes goes off with his red headlight appearing on the dash (as per pic)
Do i need to replace the bulb? Or is it the wiring?

Any help would be appreciated
Attached Thumbnails
Click image for larger version

Name:	image.jpg
Views:	50
Size:	75.5 KB
ID:	598081  
mangomagic is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 04-21-2015, 05:56 PM   #2
Davconelectric
Registered User
 
Join Date: Apr 2011
Location: Longbeach
Posts: 2,387
My Ride: Mainly cars
Sounds like a loose connection
__________________
Davconelectric is offline   Reply With Quote
Old 04-21-2015, 08:49 PM   #3
bumpgums
Registered User
 
Join Date: May 2014
Location: australia
Posts: 408
My Ride: bmw
Sounds like ignitor is failing. I would check the bulbs first then interchange the ignitors left to right. If issue mirgates then its the ignitor
bumpgums is offline   Reply With Quote
Old 04-21-2015, 09:22 PM   #4
doofdoof
Registered User
 
Join Date: Jul 2014
Location: Australia
Posts: 56
My Ride: E46 330i
Is that Xenon headlights?

If so,
1. check if bulb is clipped on correctly
2. Check for loose connections
3. If still fails, swap bulbs from left to right to check if it's bulb issue
4. If still fails, swap ballast around to check if it's ballast issue
5. If you reach this point, it's coming down to ballast or wirings...

Good luck and stay safe... No mucking Around when lights are on...
doofdoof is offline   Reply With Quote
Old 04-24-2015, 06:13 PM   #5
mangomagic
Registered User
 
Join Date: Feb 2015
Location: Australia
Posts: 24
My Ride: BMW
Thanks guys. This forum is awesome. Next day, my xenon headlight just started working fine again..and no red light flashing on the dash. weird!
mangomagic is offline   Reply With Quote
Old 04-24-2015, 06:15 PM   #6
doofdoof
Registered User
 
Join Date: Jul 2014
Location: Australia
Posts: 56
My Ride: E46 330i
It will come back... Take my word...
doofdoof is offline   Reply With Quote
Old 04-24-2015, 06:32 PM   #7
Bafffyyy
Registered User
 
Join Date: Oct 2013
Location: Sydney, Australia
Posts: 1,258
My Ride: is Individual
Send a message via Skype™ to Bafffyyy
^ word. my mate has the same problem on the same light. except his is halogen projector.
__________________

'03 Individual in Estoril Blue//Electric Fan Conversion//GAS Rebuilt DISA//Eonon GM5150 w/ iGo 8 maps
Mobil1/Redline fluids//ECS Tuning CF Strut Bar//Umnitza Orion V4's//Eagle Eye LED Tails
Bafffyyy is offline   Reply With Quote
Old 04-24-2015, 08:05 PM   #8
mangomagic
Registered User
 
Join Date: Feb 2015
Location: Australia
Posts: 24
My Ride: BMW
Quote:
Originally Posted by Bafffyyy View Post
^ word. my mate has the same problem on the same light. except his is halogen projector.
Did he ever find out what the problem was?
mangomagic is offline   Reply With Quote
Old 04-24-2015, 08:18 PM   #9
Bafffyyy
Registered User
 
Join Date: Oct 2013
Location: Sydney, Australia
Posts: 1,258
My Ride: is Individual
Send a message via Skype™ to Bafffyyy
nope. I suggested it's possibly a ballast, but without eliminating all the other possibilities, it's just shooting in the dark.
__________________

'03 Individual in Estoril Blue//Electric Fan Conversion//GAS Rebuilt DISA//Eonon GM5150 w/ iGo 8 maps
Mobil1/Redline fluids//ECS Tuning CF Strut Bar//Umnitza Orion V4's//Eagle Eye LED Tails
Bafffyyy is offline   Reply With Quote
Old 05-07-2015, 08:19 PM   #10
mangomagic
Registered User
 
Join Date: Feb 2015
Location: Australia
Posts: 24
My Ride: BMW
Where is the ballast in the Driver's side?
mangomagic is offline   Reply With Quote
Old 05-07-2015, 09:09 PM   #11
doofdoof
Registered User
 
Join Date: Jul 2014
Location: Australia
Posts: 56
My Ride: E46 330i
It should be at the bottom of the headlights assembly. It's a silver coloured box...
doofdoof is offline   Reply With Quote
Old 05-08-2015, 06:54 AM   #12
mangomagic
Registered User
 
Join Date: Feb 2015
Location: Australia
Posts: 24
My Ride: BMW
So i need to open up the headlights assembly right? Thanks I'll try it tomorrow
mangomagic is offline   Reply With Quote
Old 05-08-2015, 07:16 AM   #13
Solidjake
Zero. Leaks.
 
Solidjake's Avatar
 
Join Date: May 2008
Location: NYC
Posts: 25,783
My Ride: '02 330i 6MT
Don't need to take it apart, it's mounted under the bottom of the headlight with a few screws. First swap your bulbs around and wait. If the light goes out now on the other side then replace the bulbs in a pair. If the light goes out on the same side again then swap ballasts over.
Solidjake is online now   Reply With Quote
Old 05-09-2015, 12:21 AM   #14
mangomagic
Registered User
 
Join Date: Feb 2015
Location: Australia
Posts: 24
My Ride: BMW
Ahh thanks. I finally took the bulbs out and swapped it. There's green gunk around the Driver's side igniter (side where I am having problem with). I can't seem to wipe it off and no idea what that is.. I'll prob have to take the whole headlight out
mangomagic is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 02:14 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use