E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 11-16-2012, 09:56 PM   #1
koenryuu
Registered User
 
Join Date: Jan 2011
Location: Toronto
Posts: 2
My Ride: 320i
Car getting old...

Our 2001 320i is getting old and lots of problems are popping up lol. I fixed several issues thanks to the DIYs here. (Tail light harness, turn signal grounding, etc.)

But this one doesn't seem covered, or maybe I'm not searching right... This happens randomly when there is less than 1/4 tank of gas. The car would suddenly lose all power (split second) and then come back alive.

For now, we fill up before it reaches 1/4 tank and the problem doesn't show up anymore, so my noob guess is the fuel pump is going. But I want more expert opinion on this.

On another note, about the tail light harness: The "trunk open light" is back on, and this time the reverse lights don't come on when in reverse either Should I get a new harness or, should I just electrical tape the wires some more? lol

Thanks in advance.
koenryuu is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 11-16-2012, 10:46 PM   #2
Patton323I
Registered User
 
Join Date: Jan 2011
Location: Savannah, GA
Posts: 859
My Ride: R1100GS E46 E53
Check you contact to ground on the tail lights, ensure that they are clean and free of any corrosion. And if the car dies below 1/4 tank then you can bet its tank related. Could be the scavenge pump used to move fuel from on side of the tank to the other. If it was your primary fuel pump, logic would dictate that the problem would occur at any fuel level.
__________________
Patton323I is offline   Reply With Quote
Old 11-17-2012, 04:16 AM   #3
e4Tsex
Registered User
 
Join Date: Aug 2007
Location: Klamath Falls, Or.
Posts: 1,349
My Ride: '00 328i ZSP w/ 194k
The less fuel you have, the harder your fuel pump has to work to move the fuel. Mine went out in July and left me stranded 50 miles from home. The car was losing power at certain rpms and then finally died after a few weeks. If your miles are high and you are on the original fuel pump, I'd replace it as a precaution anyway so you don't get stranded like I did.
__________________

dr-z400s / cannondale caad 5
'91 BMW 318is -> '95 BMW 318ti -> '00 BMW 328i

Quote:
Originally Posted by 330msport View Post
i heard that this cars go like 300k miles
e4Tsex is offline   Reply With Quote
Old 11-17-2012, 08:54 AM   #4
BimmersGarage
Registered User
 
Join Date: Mar 2010
Location: Dallas, TX (USA)
Posts: 2,189
My Ride: E46 330i
Send a message via Skype™ to BimmersGarage
Replace fuel filter! If it's the original from the factory... shame on you.
BimmersGarage is offline   Reply With Quote
Old 11-17-2012, 10:13 AM   #5
Stinger9
Registered User
 
Join Date: Sep 2011
Location: New York
Posts: 7,812
My Ride: '04 330Ci
Definitely a fuel pump indicator. Pump gets weak and doesn't have enough power to transfer the fuel, from the driver's side tank over to the passenger side tank where the pickup is located, via the sucking jet pump. So while you still have fuel in the small tank, it isn't able to get to the larger side.
Replace your pump as it is going bad fast.
Stinger9 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 04:21 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use