E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Bavarian Soundwerks' Mobile Electronics Forum

Bavarian Soundwerks' Mobile Electronics Forum
Have all your A/V and electronics questions answered here. Ipods, A/V, Radar Detectors Oh My!
Sponsored by Bavarian Soundwerks

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 11-13-2012, 02:11 AM   #1
vsphantom
Registered User
 
Join Date: Sep 2012
Location: canyon lake, ca
Posts: 16
My Ride: 2001 325i
2001 325i radio problems

so i have a buisness radio and it is malfunctioning
sometimes i get only static when i turn it on
sometimes i get nothing just silent
and sometimes it gets only 1 station across the frequency band
IE
KLOS is 95.5 right but when i switch over to 102.7 which is kiss fm it still plays 95.5 music same thing with 88.8 92.7 etc
i tried adjusting the antenna cable behind the head unit which gives me back some stations but it goes away when i turn on the car

thanks
Attached Thumbnails
Click image for larger version

Name:	IMG_4180.jpg
Views:	153
Size:	90.7 KB
ID:	477952  
vsphantom is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 11-18-2012, 06:10 AM   #2
vsphantom
Registered User
 
Join Date: Sep 2012
Location: canyon lake, ca
Posts: 16
My Ride: 2001 325i
Bump
vsphantom is offline   Reply With Quote
Old 11-18-2012, 12:13 PM   #3
scottjoh
Registered User
 
Join Date: Aug 2008
Location: Torrance, CA
Posts: 2,090
My Ride: '99 323i & '02 540i
Since you are picking up the same station in multiple places it sounds like the radio is not tuning right (bad radio). Just bad reception could be a FZV antenna amplifier problem or antenna problem. I see you're in LA too. I have spare FZV that I use for testing as well as an extra business CD radio.
scottjoh is offline   Reply With Quote
Old 11-19-2012, 01:39 AM   #4
vsphantom
Registered User
 
Join Date: Sep 2012
Location: canyon lake, ca
Posts: 16
My Ride: 2001 325i
Quote:
Originally Posted by scottjoh View Post
Since you are picking up the same station in multiple places it sounds like the radio is not tuning right (bad radio). Just bad reception could be a FZV antenna amplifier problem or antenna problem. I see you're in LA too. I have spare FZV that I use for testing as well as an extra business CD radio.
what does the fzv stand fo?
vsphantom is offline   Reply With Quote
Old 11-19-2012, 10:01 AM   #5
markusmarkus
Registered User
 
Join Date: Jul 2008
Location: USA
Posts: 1,671
My Ride: 2001 330Ci
Try this procedure:
Disconnect both leads from the battery.
Short the leads together for approximately 10 minutes.
Reconnect the battery leads.
By the way this is an approved BMW procedure.
markusmarkus is offline   Reply With Quote
Reply

Tags
radio bmw e46

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 03:27 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use