E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Suspension & Braking Forum by BimmerWorld

Suspension & Braking Forum by BimmerWorld
Have some questions about suspension or brake setups for your E46 BMW? Get all your answers here!
Sponsored by BimmerWorld

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 12-22-2012, 05:35 PM   #1
addbhp
Registered User
 
Join Date: Mar 2012
Location: Aurora, Ontario, Canada
Posts: 19
My Ride: 2001 330ci vert
Ill handling 330ci after install new winter rims and tires

Looking for advice, and insight. I just installed new winter tires and rims, 225/45/17 square set up on 17x8 rims and now the car is almost undriveable on the highway. Car is darting and need to make constant adjustments to the steering wheel, that never had to be done with my stock staggered set up. Feels like driving in a wind storm but it's calm out.

And now anything over 130km/hr the traction control like goes crazy and starts grabbing the drive wheels, even on dry pavement. Traction control is even working when turning at normal speeds.

Directional tires mounted correctly, no wires disconnected as I switched rims myself.

Any insight appreciated. Already not impressed by Tire shop, but will go back if needed. Car has gone from handling well to crap.
__________________
Mark
2001 330Cic
addbhp is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 12-22-2012, 05:39 PM   #2
[USMC]Skywalker
Registered User
 
Join Date: Jun 2008
Location: Virginia
Posts: 296
My Ride: 2006 330CI ZHP
what tires (brand) and make sure they balanced the tires, unbalanced tires will handle very badly at high speed including vibrations.
[USMC]Skywalker is offline   Reply With Quote
Old 12-22-2012, 05:43 PM   #3
E46330iguy
Registered User
 
Join Date: Sep 2009
Location: Canada,SK
Posts: 2,411
My Ride: Supercharged 330i
Sounds like you need an aligmnet
__________________
Winter Authority When Hell freezes over,we'll play Hockey there too



you've Met a terrible fate haven't you ?


KONI /Michelin/Stoptec/Borla/ Bimmerbrake / MTechII/AA Stage one (for now) Automatic--->5 speed swap/ UUC High performance clutch kit

Questions about Header wrap? clickHere
Supercharger build thread click Here
E46330iguy is offline   Reply With Quote
Old 12-22-2012, 06:07 PM   #4
addbhp
Registered User
 
Join Date: Mar 2012
Location: Aurora, Ontario, Canada
Posts: 19
My Ride: 2001 330ci vert
There is no vibration, so ruled out balancing. Tires are Hankook. But will definitely do an alignment, fingers crossed that solves it. Weird I wouldn't feel it with the summer set up.
__________________
Mark
2001 330Cic
addbhp is offline   Reply With Quote
Old 12-22-2012, 10:42 PM   #5
rwall
Registered User
 
Join Date: Jan 2010
Location: WA
Posts: 301
My Ride: 2004 325ci
Check the sidewalls to make sure all are the same aspect ratio (all 45's). If one is different, it'll have a different circumference and screw with your speed sensors. If this doesn't help, temporarily swap your summer set back on and see if the symptoms persist, indicating a new, coincidental suspension or alignment problem. Good luck.
rwall is offline   Reply With Quote
Old 12-22-2012, 11:51 PM   #6
JQuick5156
Registered User
 
Join Date: Jun 2011
Location: NJ - Shore
Posts: 315
My Ride: 2004 330 Coupe
I had a similar situation as this....need an alignment however I also need fcab and probably ball joints....I'd check that stuff out. For some reason it's not noticeable with my summer set up but my winter tires made it very obvious....doing my control arms after Christmas sometime.
__________________
JQuick5156 is offline   Reply With Quote
Old 12-26-2012, 08:38 AM   #7
obd2toolbox
Past Site Sponsor
 
Join Date: Dec 2012
Location: NewYork
Posts: 70
My Ride: BMW 7
PP2000 Peugeot
obd2toolbox is offline   Reply With Quote
Old 12-26-2012, 08:45 AM   #8
stevenluczynski
Registered User
 
Join Date: Oct 2010
Location: orlando
Posts: 1,410
My Ride: Is Steel Blue<3
Quote:
Originally Posted by obd2toolbox View Post
whats with the sponsor spamming
__________________
stevenluczynski is offline   Reply With Quote
Old 12-26-2012, 09:05 AM   #9
willsbma
Registered User
 
Join Date: Jul 2006
Location: north babylon NY
Posts: 2,531
My Ride: 99 323i
You sure the tread is facing the right way

Sent from my DROIDX using Bimmer App
__________________
Matte Black Kidney Grilles | Smoked Tails & Corners | Mtech II Bumper | Hotchkis Springs | ACS Roof Spoiler | M3 Spoiler | 20% Tint
WTB: Black sun visors & grab handles - PM ME!

I have P.A. Soft and a 20-pin adapter. Only used it a few times but pm me if you need anything coded!
willsbma is offline   Reply With Quote
Old 12-26-2012, 10:27 AM   #10
Toad21
Registered User
 
Join Date: Feb 2009
Location: Normal IL
Posts: 893
My Ride: 00' 328CI
Put it on a lift, put in in neutral, and just spin the tires and look. They will have a wobble, and your tires are either not mounted correctly, there is something wrong with the tires (happened to me), or your suspension components are bad. And a possible combination of any of those.

Not really worth asking on here, more of a common sense solution.
__________________
Toad21 is offline   Reply With Quote
Old 01-02-2013, 10:07 AM   #11
SoloII///M
Registered User
 
Join Date: Mar 2005
Location: Columbia, MD
Posts: 528
My Ride: Many
Have you used the wheels before? What's the offset as compared to stock? If you have lower offset wheels (i.e. pushed out towards the fenders more) you have increased the scrub radius in your suspension which will cause tramlining. Also, certain tires are notorious for horrible tramlining. I had a set of Bridgestone RE760s that were about the worst I'd ever experienced in that regard.

I'd get the alignment checked out. Check also for loose wheel bearings or worn tie-rods or ball joints. Any of these things can cause dynamic toe and camber changes as you drive down the road which will cause the symptoms you're encountering.

John
__________________
John V
'02 330Ci - Megasquirt 3 tuned by PFTuning.com, M50 manifold, Kromer Kraft headers, Motons, widebody, etc.
SoloII///M is online now   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 02:18 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use