E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Suspension & Braking

Suspension & Braking
Have some questions about suspension or brake setups for your E46 BMW? Get all your answers here!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 01-14-2013, 11:06 AM   #1
daveion2002
Registered User
 
Join Date: Jun 2011
Location: utah
Posts: 115
My Ride: 2001 330i
Coil help :/

Put in new street edge coils in. The front is clunking though. so before I take it to a mechanic what could be wrong?
__________________
 photo f6c21330-3890-4688-91a2-dfeb05976de7.jpg
daveion2002 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 01-14-2013, 11:06 AM   #2
Mango
Grand Superpatriot Sport+
 
Mango's Avatar
 
Join Date: Mar 2006
Location: Southern California
Posts: 22,177
My Ride: M54B30
Quote:
Originally Posted by daveion2002 View Post
Put in new street edge coils in. The front is clunking though. so before I take it to a mechanic what could be wrong?
you put in new street edge coils.
__________________
A lifetime free of problems if you follow my guides
Cooling | Maintenance | Suspension | Vacuum | Supreme Reliability | Details

OVER A MILLION VIEWS
Mango is offline   Reply With Quote
Old 01-14-2013, 11:10 AM   #3
daveion2002
Registered User
 
Join Date: Jun 2011
Location: utah
Posts: 115
My Ride: 2001 330i
Quote:
Originally Posted by E46Mango View Post
you put in new street edge coils.
Ohh come on I'm sure I just ****ed up I've read a lot of people that have them and they are just fine
__________________
 photo f6c21330-3890-4688-91a2-dfeb05976de7.jpg
daveion2002 is offline   Reply With Quote
Old 01-14-2013, 11:26 AM   #4
RayPooley
Registered User
 
Join Date: Jul 2012
Location: Liverpool
Posts: 1,378
My Ride: 320i SE Coupe
Quote:
Originally Posted by daveion2002 View Post
Ohh come on I'm sure I just ****ed up I've read a lot of people that have them and they are just fine
Is it possible you might have damaged an FCAB during the process? Maybe one was ready to give up and, by removing the strut, it caused the rubber to come apart. Everything else on the strut tightened up properly?
RayPooley is offline   Reply With Quote
Old 01-14-2013, 11:30 AM   #5
daveion2002
Registered User
 
Join Date: Jun 2011
Location: utah
Posts: 115
My Ride: 2001 330i
Quote:
Originally Posted by RayPooley View Post
Is it possible you might have damaged an FCAB during the process? Maybe one was ready to give up and, by removing the strut, it caused the rubber to come apart. Everything else on the strut tightened up properly?
I don't think so... They are brand new. Yeah every thing is tightened down to the right torque specs. Would an alinement fix it maybe?
__________________
 photo f6c21330-3890-4688-91a2-dfeb05976de7.jpg
daveion2002 is offline   Reply With Quote
Old 01-14-2013, 11:32 AM   #6
WDE46
Registered User
 
Join Date: Sep 2012
Location: Virgo Supercluster
Posts: 8,005
My Ride: 2004 330Ci OBM
Check the top nut on the strut mounts. That one is difficult and could have loosened once the suspension had weight on it. Also, look at the connection of the strut to the steering knuckle. Make sure it is settled all the way down and any slots are aligned properly.
WDE46 is offline   Reply With Quote
Old 01-14-2013, 11:36 AM   #7
Mango
Grand Superpatriot Sport+
 
Mango's Avatar
 
Join Date: Mar 2006
Location: Southern California
Posts: 22,177
My Ride: M54B30
I don't like giving advice on bad parts because i feel like i'm condoning it. but it's probably a loose end link or bearing/plates.
__________________
A lifetime free of problems if you follow my guides
Cooling | Maintenance | Suspension | Vacuum | Supreme Reliability | Details

OVER A MILLION VIEWS
Mango is offline   Reply With Quote
Old 01-14-2013, 12:00 PM   #8
RayPooley
Registered User
 
Join Date: Jul 2012
Location: Liverpool
Posts: 1,378
My Ride: 320i SE Coupe
Quote:
Originally Posted by daveion2002 View Post
I don't think so... They are brand new. Yeah every thing is tightened down to the right torque specs. Would an alinement fix it maybe?
Last time I changed struts it was stock for stock so no need to touch steering geometry. Don't know enough about your new coils. Its quite a simple job really. What is it? Three bottom bolts and three nuts at the top? I can't really think of where you could go wrong. Get it up on axle stands and move the wheels left and right by hand see if anything moves that shouldn't. Sorry dude. That's all I got.
RayPooley is offline   Reply With Quote
Old 01-14-2013, 12:37 PM   #9
daveion2002
Registered User
 
Join Date: Jun 2011
Location: utah
Posts: 115
My Ride: 2001 330i
Quote:
Originally Posted by E46Mango View Post
I don't like giving advice on bad parts because i feel like i'm condoning it. but it's probably a loose end link or bearing/plates.
yeah I know i went cheap but I could have done worse and gone with Race lands!
__________________
 photo f6c21330-3890-4688-91a2-dfeb05976de7.jpg
daveion2002 is offline   Reply With Quote
Old 01-14-2013, 12:40 PM   #10
daveion2002
Registered User
 
Join Date: Jun 2011
Location: utah
Posts: 115
My Ride: 2001 330i
Ill check those nuts and make sure every thing is tight. I was just looking at my job and it looks like the left strut is turned a little to the right (sway bar mount is turned) when the roters/ wheels are facing strait forward. Could this be the problem?
__________________
 photo f6c21330-3890-4688-91a2-dfeb05976de7.jpg

Last edited by daveion2002; 01-14-2013 at 12:42 PM.
daveion2002 is offline   Reply With Quote
Old 01-14-2013, 12:47 PM   #11
Mango
Grand Superpatriot Sport+
 
Mango's Avatar
 
Join Date: Mar 2006
Location: Southern California
Posts: 22,177
My Ride: M54B30
Quote:
Originally Posted by daveion2002 View Post
yeah I know i went cheap but I could have done worse and gone with Race lands!
how much were they if you don't mind me asking?
__________________
A lifetime free of problems if you follow my guides
Cooling | Maintenance | Suspension | Vacuum | Supreme Reliability | Details

OVER A MILLION VIEWS
Mango is offline   Reply With Quote
Old 01-14-2013, 12:48 PM   #12
Mango
Grand Superpatriot Sport+
 
Mango's Avatar
 
Join Date: Mar 2006
Location: Southern California
Posts: 22,177
My Ride: M54B30
Quote:
Originally Posted by daveion2002 View Post
Ill check those nuts and make sure every thing is tight. I was just looking at my job and it looks like the left strut is turned a little to the right (sway bar mount is turned) when the roters/ wheels are facing strait forward. Could this be the problem?
Even if its not, make sure everything is perfectly angled. always start with a proper install
__________________
A lifetime free of problems if you follow my guides
Cooling | Maintenance | Suspension | Vacuum | Supreme Reliability | Details

OVER A MILLION VIEWS
Mango is offline   Reply With Quote
Old 01-14-2013, 12:49 PM   #13
Zell
Registered User
 
Zell's Avatar
 
Join Date: Jun 2009
Location: Such City
Posts: 5,399
My Ride: '02 Dogemobile Shibe
Quote:
Originally Posted by daveion2002 View Post
yeah I know i went cheap but I could have done worse and gone with Race lands!
lolracelands
__________________
Quote:
Originally Posted by Act of God View Post
Carbon dioxide is not a "chemical"
Quote:
Originally Posted by l0e3o7 View Post
Just keep your lil boy zell on a leash; a proud self proclaimed TROLL
Zell is offline   Reply With Quote
Old 01-14-2013, 02:22 PM   #14
daveion2002
Registered User
 
Join Date: Jun 2011
Location: utah
Posts: 115
My Ride: 2001 330i
Quote:
Originally Posted by E46Mango View Post
how much were they if you don't mind me asking?
Don't mind at all. It was 395 with free shipping. It came with shortened sway bar links also.
__________________
 photo f6c21330-3890-4688-91a2-dfeb05976de7.jpg
daveion2002 is offline   Reply With Quote
Old 01-15-2013, 10:44 AM   #15
daveion2002
Registered User
 
Join Date: Jun 2011
Location: utah
Posts: 115
My Ride: 2001 330i
So the spring noise went away is that good or bad?
__________________
 photo f6c21330-3890-4688-91a2-dfeb05976de7.jpg
daveion2002 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 08:50 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use