E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Suspension & Braking Forum by BimmerWorld

Suspension & Braking Forum by BimmerWorld
Have some questions about suspension or brake setups for your E46 BMW? Get all your answers here!
Sponsored by BimmerWorld

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 01-14-2013, 02:15 PM   #21
Jesse M
Registered User
 
Join Date: Oct 2010
Location: East Greenwich, RI
Posts: 457
My Ride: 05' ZHP
Why are you missing the nut for your sway bar end link?

Edit: Nevermind. Looks like it was gone, on my cell.
__________________

Last edited by Jesse M; 01-14-2013 at 02:16 PM.
Jesse M is offline   Reply With Quote
Old 01-14-2013, 02:34 PM   #22
3coupe
Registered User
 
Join Date: Nov 2007
Location: CA
Posts: 305
My Ride: 330Ci
Sounds like your strut mount is bad from the video.

http://forum.e46fanatics.com/showthr...ate+ship+creak


Edit: I should add I got a very similar noise when I put on my H&R coilovers and it went away completely with new strut mounts.

Last edited by 3coupe; 01-14-2013 at 02:36 PM.
3coupe is offline   Reply With Quote
Old 01-15-2013, 09:49 AM   #23
23dilbert
Registered User
 
Join Date: Aug 2012
Location: Grand Cayman
Posts: 124
My Ride: 2000 BMW 323I (RHD)
So basically it looks like I need to change the strut mounts

Last edited by 23dilbert; 01-15-2013 at 01:50 PM.
23dilbert is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 02:59 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use