E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 12-08-2012, 11:38 PM   #1
mcaltinsoy
Registered User
 
Join Date: Apr 2012
Location: Minnesota
Posts: 55
My Ride: 04 330ci
Power steering hose leak. any ideas?

Hey everyone. I have an 04 330ci A/T with 86K . So i replaced my power steering pump about 5 months ago with a pump that i bought on ebay for $125 from Deutsche parts.
Couple days ago I saw power steering fluid on the floor in my garage. I checked it and the lower hose(when you look from the bottom) was loose! So i thought it came loose after 5 months and I retightened it. Leak was not as heavy but it still was leaking.. So Has anyone of you have had a problem with that hose?long hose i believe it is also connected to the rack. I know that i didn't cross threaded the pump. So i'm wondering if it is the hose or the pump again is the problem?
mcaltinsoy is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 12-09-2012, 01:39 AM   #2
Ruthlessone3k
Registered User
 
Join Date: Dec 2012
Location: Germany
Posts: 128
My Ride: 323i
This write up should answer all your questions.

http://forum.e46fanatics.com/showthread.php?t=882732
Ruthlessone3k is offline   Reply With Quote
Old 12-09-2012, 01:45 AM   #3
peytonracer4
:D
 
peytonracer4's Avatar
 
Join Date: Jan 2010
Location: Valparaiso, IN
Posts: 6,377
My Ride: '00 328i
Is the high pressure hose the one you're talking about? The one that runs the length of the rack and then back? The outside feels cloth like.
__________________
choose to click or forever hold your peace ;)
peytonracer4 is online now   Reply With Quote
Old 12-09-2012, 12:15 PM   #4
repoman89
Registered User
 
Join Date: Sep 2012
Location: Somerville MA
Posts: 43
My Ride: 2003 330i Sedan
Which pump type - LF20 or 30?

I have a similar problem with my replacement LF20. The leak for me is a combination of first forgetting to replace the high pressure hose o-ring and second the hose just coming loose over time, even if it's very tight. I got the suggestion in my thread to put loc-tite on the threads next time I tighten it - just trying to find some time to do that at this point since the leak is not bad at the moment.
repoman89 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 08:19 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use