E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 01-02-2013, 12:28 PM   #1
IchLiebeAutos
Registered User
 
Join Date: Mar 2012
Location: California
Posts: 38
My Ride: 2001 330i
E46 seemed to shut down while driving. why?

I was coasting down I-5 last night coming back from a trip and I shifted into neutral to coast down a mountain summit. I went back into drive and all of a sudden I got a red battery light, red oil light, my rpm's dropped to zero, the car stayed at speed, my gas pedal didn't work, and my breaks were almost non-existant. I got it to stop at level ground, turned off the car, started it back up and everything was fine. I was low on fuel (8th of a tank left) but this has never happened before. Any ideas as to why this happened? I've heard of problems with low gas before. After I filled her up, no more problems ensued.

It was also about 20 degrees outside, not sure if that has anything to do with it.

2001 330i 135k mi. This was at the end of a long holiday road trip.
IchLiebeAutos is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 01-02-2013, 12:32 PM   #2
delmarco
Registered User
 
Join Date: Nov 2008
Location: Westchester, NY
Posts: 6,287
My Ride: 2001 330i
Send a message via ICQ to delmarco Send a message via Yahoo to delmarco
alternator or battery is dying.

Cold Weather = battery/alternator death and engine oil leaking/pumping issues

Hot Weather = engine cooling issues/fuel issues/air intake issues.

That is my general rule of thumb.
__________________




VISIT MY GARAGE TO SEE ALL MY MODS:

http://directory.e46fanatics.com/use...rMod&UcId=7917

Last edited by delmarco; 01-02-2013 at 12:33 PM.
delmarco is offline   Reply With Quote
Old 01-02-2013, 12:37 PM   #3
Zell
Registered User
 
Zell's Avatar
 
Join Date: Jun 2009
Location: Such City
Posts: 5,643
My Ride: '02 Dogemobile Shibe
Quote:
Originally Posted by IchLiebeAutos View Post
I've heard of problems with low gas before.
You'll kill your fuel pump pretty early if you go too low too often. When the gas light turns on, you should fill it up as soon as possible.
__________________
Zell is online now   Reply With Quote
Old 01-02-2013, 12:37 PM   #4
IchLiebeAutos
Registered User
 
Join Date: Mar 2012
Location: California
Posts: 38
My Ride: 2001 330i
Thanks delmarco, I think it might be the alternator since I replaced my battery not 2 months ago. I'll look into the pumping issues as well.

ps. thanks for your mod videos on youtube. Your DIY vid's and write-ups are very helpful.

Last edited by IchLiebeAutos; 01-02-2013 at 12:38 PM.
IchLiebeAutos is offline   Reply With Quote
Old 01-02-2013, 12:39 PM   #5
IchLiebeAutos
Registered User
 
Join Date: Mar 2012
Location: California
Posts: 38
My Ride: 2001 330i
Ya, the light wasn't on yet, but it was close. I will be more diligent in the future.
IchLiebeAutos is offline   Reply With Quote
Old 01-02-2013, 01:44 PM   #6
RayPooley
Registered User
 
Join Date: Jul 2012
Location: Liverpool
Posts: 1,435
My Ride: 320i SE Coupe
Quote:
Originally Posted by IchLiebeAutos View Post
I was coasting down I-5 last night coming back from a trip and I shifted into neutral to coast down a mountain summit. I went back into drive and all of a sudden I got a red battery light, red oil light, my rpm's dropped to zero, the car stayed at speed, my gas pedal didn't work, and my breaks were almost non-existant. I got it to stop at level ground, turned off the car, started it back up and everything was fine. I was low on fuel (8th of a tank left) but this has never happened before. Any ideas as to why this happened? I've heard of problems with low gas before. After I filled her up, no more problems ensued.

It was also about 20 degrees outside, not sure if that has anything to do with it.

2001 330i 135k mi. This was at the end of a long holiday road trip.

This started happening to me a couple of months ago. First time no fault code. Second time I got a crankshaft sensor fault code. Replaced it. Not happened since.
RayPooley is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 11:34 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use