E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > E46 Xi Forum

E46 Xi Forum
The E46 XI was produced from 01-05 in sedan and touring body styles. Powered by either a 2.5L inline 6 in the 325xi or a 3.0L inline 6 330xi. Discuss all thing about BMW AWD E46 'Xi' here.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 12-16-2012, 12:20 PM   #1
Rockhopper
Registered User
 
Join Date: Dec 2012
Location: Uk
Posts: 8
My Ride: E46 330 ci m sport
Engine light

Hi, I'm driving a e46 330ci. My engine light came on and it started to idle a little rough. I checked the breather pipes and found them clogged up with gunk so I changed the ccv and flushed all the pipes out with a air gun and inspected them for splits etc and replaced 1 of them.
Since doing this the car idles bang on but it's performance and fuel economy is very poor. The engine emmision light is still on?
Is the car in some sort of limp mode? Does it need reset which will hopefully improve performance and fuel ?

Thanks for your time and I appreciate any advice and help :-)
Rockhopper is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 12-16-2012, 04:35 PM   #2
adrian8507
Registered User
 
Join Date: Jun 2012
Location: New York
Posts: 85
My Ride: E46 325xi 2002
Replace your oxigen sensors bro thats whats going on right they are not reading how much oxigen is coming in or out .so is letting bypass all the gas and its not rendering fuel .hope it helped.

Sent from my SPH-D710BST using Bimmer App
adrian8507 is offline   Reply With Quote
Old 12-16-2012, 06:26 PM   #3
Rockhopper
Registered User
 
Join Date: Dec 2012
Location: Uk
Posts: 8
My Ride: E46 330 ci m sport
Are the sensors the same? Isn't there two of them. It's only at low revs there's no power

Thanks again
Rockhopper is offline   Reply With Quote
Old 12-16-2012, 06:28 PM   #4
Rockhopper
Registered User
 
Join Date: Dec 2012
Location: Uk
Posts: 8
My Ride: E46 330 ci m sport
Should say it does smell really rich now that I think about it
Rockhopper is offline   Reply With Quote
Old 12-16-2012, 08:29 PM   #5
adrian8507
Registered User
 
Join Date: Jun 2012
Location: New York
Posts: 85
My Ride: E46 325xi 2002
Yeah there are two of them reolace them both for bettet emissions
Sent from my SPH-D710BST using Bimmer App
adrian8507 is offline   Reply With Quote
Old 12-17-2012, 08:28 AM   #6
bmwbob89
Registered User
 
Join Date: Jun 2012
Location: Newburyport Ma,
Posts: 624
My Ride: M-5 325 X3 528 740
Get the codes read out before you spend any money guessing what parts are needed.
bmwbob89 is offline   Reply With Quote
Old 12-17-2012, 09:55 AM   #7
SamDoe1
Registered User
 
Join Date: Oct 2010
Location: Minnesnowta
Posts: 3,577
My Ride: Clubs baby seals
Quote:
Originally Posted by bmwbob89 View Post
Get the codes read out before you spend any money guessing what parts are needed.
^ This.

Ignore posts 2-5 before you get the codes read, that will tell you what's truely wrong. Most auto parts stores will do this for free.
SamDoe1 is offline   Reply With Quote
Old 12-17-2012, 10:40 AM   #8
Rockhopper
Registered User
 
Join Date: Dec 2012
Location: Uk
Posts: 8
My Ride: E46 330 ci m sport
Bought a code reader today. Should be delivered for Wednesday . Thanks for the above advice. Will put the codes up on here for you all to look over and give me the best way to go with it. If it doesn't rain it pours though as I had a blow out on the rear today. Bridgestone tyre aswell with 6mm tread. Inner side wall has a 2" gash in it
Rockhopper is offline   Reply With Quote
Old 12-20-2012, 11:03 AM   #9
Rockhopper
Registered User
 
Join Date: Dec 2012
Location: Uk
Posts: 8
My Ride: E46 330 ci m sport


Intake camshaft sensor?

Thanks guys
Rockhopper is offline   Reply With Quote
Old 12-20-2012, 04:47 PM   #10
SamDoe1
Registered User
 
Join Date: Oct 2010
Location: Minnesnowta
Posts: 3,577
My Ride: Clubs baby seals
Quote:
Originally Posted by Rockhopper View Post
Intake camshaft sensor?

Thanks guys
Bingo, good luck!
SamDoe1 is offline   Reply With Quote
Old 12-21-2012, 09:31 AM   #11
Rockhopper
Registered User
 
Join Date: Dec 2012
Location: Uk
Posts: 8
My Ride: E46 330 ci m sport
All done and running a dream thanks
Rockhopper is offline   Reply With Quote
Old 12-22-2012, 01:52 AM   #12
Iggy27
Registered User
 
Join Date: Nov 2012
Location: Inkom
Posts: 521
My Ride: 2003 330xi
Or the idle control valve could be playing a little role in problems.
Iggy27 is offline   Reply With Quote
Old 12-27-2012, 05:15 PM   #13
hockey_fan
Registered User
 
Join Date: Aug 2007
Location: Calgary, Alberta
Posts: 13
My Ride: 2000 323i
I haven't had any rough idle or stating problems (knock on wood!!) but I am getting the same code..camshaft position sensor. Are there two different sensors? I have seen the sensor shown with a long wire attached to it...and another one with just a plastic looking head. Is this the same sensor or are there actually two to replace. This is a 2000 323i 2.5L
hockey_fan is offline   Reply With Quote
Old 12-27-2012, 05:19 PM   #14
Rockhopper
Registered User
 
Join Date: Dec 2012
Location: Uk
Posts: 8
My Ride: E46 330 ci m sport
Hi. For me it was the intake camshaft sensor. The one below the breather pipe for the ccv. Yes it has a long wire. Remove the cylindrical vanos thing to gain access. Night and day after that matey :-)
Rockhopper is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 08:58 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use