E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > BAVSOUND Mobile Electronics Forum

BAVSOUND Mobile Electronics Forum
Have all your A/V and electronics questions answered here. Ipods, A/V, Radar Detectors Oh My!
Sponsored by BAVSOUND

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 04-02-2017, 02:50 PM   #1
mechanical_handjob
Registered User
 
Join Date: Apr 2017
Location: georgia
Posts: 3
My Ride: BMW E46 330Ci 5MT
only bass is working (Harman Kardon)

hello, I searched on everywhere and did not find any case similar to mine, closest case was in here and in this subcategory so am am posting here, hope am correct its my first activity on this forum.

I have E46 330Ci with Harman Kardon (2001 year)

before I crushed it pretty badly, Audio system was working like clock and sounded like rattle (which I fixed before crash (rear deck rattling)), it sounded very good and clean...car did get strong hit on rear right and front left side, front left rim was crashed, rear right metal was smashed. right side door was removed(so all cables as well) to repair it, after repair it was assembled and installed on car again. after some time it was fully repaired mechanically, but airbag light is ON and DSC is always OFF (I did not done any electrical diagnostic, wheels need to be aligned).....
now when am playing any sound (FM radio or CD) only rear deck bass is working, it sounds very good but it is only bass...none of door speakers or rear speakers is working...

I tryed, dis-reconnect battery, dis-reconnect HK amp, in Business CD unit all adjustments are correct, I know there is front and back sound travel
tweaks

one more note, my trim has Sound Enhance button which was working perfectly and now it is not even lights (green light in button, side by side DSC button) it has no reaction when I pressing

am in painc already, any ideas what it can be? HEEEEEEAAAALP
mechanical_handjob is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 04-03-2017, 06:55 PM   #2
randy72877
Registered User
 
Join Date: Apr 2015
Location: Chicago
Posts: 319
My Ride: 01 330 sport 5m sil/
The 6x9 subs have a separate amp mounted to the speaker housing under the rear shelf. Sounds like the main hk amp is not working. Check power and ground to the amp. Could be wiring harness damage from the accident. Check the fuse for the amplifier.

Sent from my SAMSUNG-SM-G870A using Tapatalk
randy72877 is offline   Reply With Quote
Old 04-23-2017, 12:03 PM   #3
mechanical_handjob
Registered User
 
Join Date: Apr 2017
Location: georgia
Posts: 3
My Ride: BMW E46 330Ci 5MT
Dissembled my current unit and find out Rust, Oxygenation and more sh*ty stuff....bought replacement for AMP and all working perfect now

Images
https://ibb.co/eJFQVk
https://ibb.co/jTfEO5
https://ibb.co/gmJqwQ
https://ibb.co/gKTZO5

Last edited by mechanical_handjob; 04-23-2017 at 12:04 PM.
mechanical_handjob is offline   Reply With Quote
Old 04-23-2017, 03:08 PM   #4
nealfromnz
Registered User
 
Join Date: Jan 2016
Location: New Zealand
Posts: 173
My Ride: 2002 e46
Wow

Might pay to check the roof drain tube as the source of water . It travels directly above the amp.
nealfromnz is offline   Reply With Quote
Old 04-23-2017, 06:21 PM   #5
randy72877
Registered User
 
Join Date: Apr 2015
Location: Chicago
Posts: 319
My Ride: 01 330 sport 5m sil/
Quote:
Originally Posted by nealfromnz View Post
Wow

Might pay to check the roof drain tube as the source of water . It travels directly above the amp.
This is good advice. That is definitely water damage. If you don't find the source of the water your new amp will look the same way soon.

Sent from my SAMSUNG-SM-G870A using Tapatalk
randy72877 is offline   Reply With Quote
Old 04-24-2017, 11:00 AM   #6
mechanical_handjob
Registered User
 
Join Date: Apr 2017
Location: georgia
Posts: 3
My Ride: BMW E46 330Ci 5MT
Quote:
Originally Posted by randy72877 View Post
This is good advice. That is definitely water damage. If you don't find the source of the water your new amp will look the same way soon.
Yes it is good advice, but in my case its not true. I find out why it was damaged....it was water Yes, but not from roof. when my car was in repair shop they removed left side tail light to repair metal and repaint, as I was told now, guy who did paint job he was spraying water all over the car without sealing any holes like tail light, water was like pool under the HK unit...back than when I noticed water it was already almost dry and I did what I could. and I had no idea that HK unit has holes under. They "repaired" one thing and damaged another, typical job by locals in my area sadly

but now it is diagnosed and everything sounds as it should

Last edited by mechanical_handjob; 04-24-2017 at 11:00 AM.
mechanical_handjob is offline   Reply With Quote
Reply

Tags
not working, speakers hk

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 01:32 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
(c) 1999 - 2016 performanceIX Inc - privacy policy - terms of use