E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > BMW Regional Forums > Regional Forums > Australia

Australia
Check out other E46Fanatics members rides in the Enthusist Directory!

If you don't have your garage setup, sign up today HERE

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 01-14-2013, 06:28 AM   #21
trive2
Registered User
 
Join Date: Sep 2011
Location: Brisbane
Posts: 1,100
My Ride: 1989 BMW 535i
Quote:
Originally Posted by M3N7AL View Post
Got a call from the workshop today about the car as it's being serviced there and they found out why the car was heating up.

Water pump was stuffed. It's being replaced under warranty along with the belts. Now i know why i've been hearing a slight whine lately. Could this have cause the car to lose power aswell?
Point made. Glad you caught it!!!
__________________

Last edited by trive2; 01-14-2013 at 06:30 AM.
trive2 is offline   Reply With Quote
Old 01-14-2013, 06:39 AM   #22
M3N7AL
Registered User
 
Join Date: Feb 2012
Location: Australia
Posts: 509
My Ride: E46 M3
Hahahaha thanks

I'm glad i had it all checked. Have you had the same problem?
M3N7AL is offline   Reply With Quote
Old 01-14-2013, 04:30 PM   #23
trive2
Registered User
 
Join Date: Sep 2011
Location: Brisbane
Posts: 1,100
My Ride: 1989 BMW 535i
Ive had about 8 BMW's and every single one has suffered cooling problems soon after purchase (admittedly, mostly shitboxes!) I was unlucky enough to blow the head on one before I caught it. I'm just a crazy firm believer in cooling system overhauls. Other than crash damage, cooling failures seems to be the only other way a BMW gets written off.
__________________

Last edited by trive2; 01-14-2013 at 04:31 PM.
trive2 is offline   Reply With Quote
Old 01-14-2013, 05:19 PM   #24
M3N7AL
Registered User
 
Join Date: Feb 2012
Location: Australia
Posts: 509
My Ride: E46 M3
Wow.. Thanks heaps for the info.
M3N7AL is offline   Reply With Quote
Old 01-23-2013, 11:23 PM   #25
draks006
Registered User
 
Join Date: Apr 2012
Location: Melbourne Australia
Posts: 16
My Ride: M3 Convertible 2003
Quote:
Originally Posted by M3N7AL View Post
I then noticed the Oil Temp & Water Temp issue to happen again today, it was about 37 degrees celsius, i had the aircon blaring and was driving for a while, then the SMG light came on and stayed on.
I have the same car and the same thing happened to me on the other day while it was 40+deg outside. I was in stop-and-go traffic with the air-con on. When I finally came to a stop, after 1hr driving, the SMG light came on and stayed on. Lucky I had just reached my destination when the light came on. It went out after around 2 hours and hasn't come on since.

If the car is getting really hot I just shut down the air-con for a while trying to keep the temp needle in the middle. Haven't tried the mod yet.

Cheers
__________________
draks006 is offline   Reply With Quote
Old 01-24-2013, 12:25 AM   #26
M3N7AL
Registered User
 
Join Date: Feb 2012
Location: Australia
Posts: 509
My Ride: E46 M3
Yeah you have to be careful. My issue was the water pump, that's been changed now.
M3N7AL is offline   Reply With Quote
Old 01-24-2013, 04:16 AM   #27
DesiredM
Registered User
 
Join Date: Sep 2012
Location: Australia
Posts: 519
My Ride: E46 M3
Haven't had any smg light come on in mine, I drove mine spirited in the 40 plus weather we had in sydney last week for a few hours. The temp needle was just a touch over 100(probably 110) but that's all that happened for me.
DesiredM is offline   Reply With Quote
Old 01-24-2013, 04:57 AM   #28
abbas_m3
Registered User
 
Join Date: Jan 2012
Location: Sydney
Posts: 201
My Ride: bmw m3
When it gets hot, my smg will start flashing. Very rarly but does happen in heat.

Sent from my GT-I9300T using Bimmer App
abbas_m3 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 01:07 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use