E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Lighting Forum

Lighting Forum
Angel Eyes, DDEs, lighted rings, Clear Turn Signals, LEDs, Xenon, HID, or Bi-Xenon. If it lights up and you want to discuss it, post here!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 01-15-2013, 08:48 AM   #1
ragtop69
Registered User
 
Join Date: Mar 2012
Location: Maryland
Posts: 43
My Ride: 2004 bmw 330 conv.
Headlight problem 2004 adaptive

I have a 2004 330 convertible and the other day when I was driving, the passenger headlight got bright for a few seconds, then went out and i got the light out indicator on the dash. I switched the headlight off and then back on and it came on for a few minutes but then went out again and has been out ever since. I assumed it was the bulb and bought 2 new Philips OEM bulbs. I replaced the bulb and it still did not work so I tried the other new bulb and it did not work either. I tried swapping the ignitor (the square box that attaches to the back of the bulb with a 3 pin connector going to it) from the drivers headlight to the passenger headlight and vice versa. The passenger bulb still did not light and the drivers light did light so the ignitor appears to be good. I have done a bunch of forum searching and many people mention changing/swapping the ballast but I can't find any info on where the ballast is (if there is one) on a car with the adaptive xenons and realoem does not list a ballast as far as I can find. Does anyone know where the ballast would be and how to swap it on a car with the adaptive headlights so I can see if that is the problem. If anyone has any other ideas on what I can try to fix this problem, I would appreciate it.

Thanks
ragtop69 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 01-15-2013, 02:55 PM   #2
777eThOd*
Registered User
 
Join Date: Jun 2011
Location: Houston, TX
Posts: 1,151
My Ride: spins too much
If you take out both your headlights underneath is the ballast of the headlights and theres just 3 screw and just swap them out, also check for shorts inside the box. My Ballast just went out not that long ago in my car as well and its an 04 too. It cost me a little more than $300 new but don't have anymore issues.. Good luck!
__________________

2007 BMW 335i FBO 6MT - Current
2013 Nissan Nismo 370Z - Current
2004 Non-M Facelift Coupe - SOLD
2006 BMW M3 - SOLD
777eThOd* is offline   Reply With Quote
Old 01-15-2013, 05:34 PM   #3
ragtop69
Registered User
 
Join Date: Mar 2012
Location: Maryland
Posts: 43
My Ride: 2004 bmw 330 conv.
Thanks for the info. Did you swap them left and right to verify the ballast was bad or did you just replace it. Thanks
ragtop69 is offline   Reply With Quote
Old 01-15-2013, 05:38 PM   #4
777eThOd*
Registered User
 
Join Date: Jun 2011
Location: Houston, TX
Posts: 1,151
My Ride: spins too much
Quote:
Originally Posted by ragtop69 View Post
Thanks for the info. Did you swap them left and right to verify the ballast was bad or did you just replace it. Thanks
Yeah, sorry I forgot to write that, the night it blew up, I carry about 4 spare HID D2S bulbs just in case(dont ask lol) And I pulled over in a gas station and swapped them out and nothing, then I swapped out the 55w module(red boxy thing) and nothing. So then when I got home I swapped out the ballast from side to side and boom, there it was.
__________________

2007 BMW 335i FBO 6MT - Current
2013 Nissan Nismo 370Z - Current
2004 Non-M Facelift Coupe - SOLD
2006 BMW M3 - SOLD

Last edited by 777eThOd*; 01-15-2013 at 05:40 PM.
777eThOd* is offline   Reply With Quote
Old 01-17-2013, 09:09 AM   #5
ragtop69
Registered User
 
Join Date: Mar 2012
Location: Maryland
Posts: 43
My Ride: 2004 bmw 330 conv.
Update: I swapped the ballasts and it did not fix the problem. I took a closer look at the headlight assembly and found that the green wire going to the ignitor on the back of the bulb was broken just beyond the connector. I soldered it back together and now the light works fine. So apparently if you are having problems with your lights take a close look at those wires to see if they are broken
ragtop69 is offline   Reply With Quote
Old 01-17-2013, 08:14 PM   #6
B.I.G.blue
Registered User
 
Join Date: Dec 2009
Location: Puerto Rico
Posts: 77
My Ride: 325ci
I'm having the same problem with my passenger light (05' coupe) and I'm not totally certain if the module which is damaged is the ballast or the adaptive headlight controlling unit itself. This same thing happend a couple of months ago, took to the shop and the wires were all damaged, so they fixed them, but that didn't hold up for long and now I'm confused on which module to buy.
B.I.G.blue is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 05:01 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use