E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > ///M3 Forum

///M3 Forum
The BMW E46 ///M3 is the M version E46 and puts out an amazing 333 HP and 262 lb-ft of torque at stock specs! There are an amazing amount of modifications for both the coupe and convertible models so read up and get started modifying your cars today!

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 3 votes, 5.00 average. Display Modes
Old 06-05-2010, 08:30 PM   #1
BradleyStuart
Registered User
 
Join Date: May 2010
Location: Las Vegas, Nevada
Posts: 21
My Ride: 2003 M-3 Convertable
SMG Transmission Problems!!

I'm hoping somebody can help me with this; I've got a 2003 M-3, Convertable with a SMG trans. I've got several problems that have been driving me nutts for the past several months; 1. My car also stalls sometimes when I come to a stop for no apparent reason? 2. But that's far from the biggest problem I'm experiencing, the car started shifting irregularily three months ago. Took it to the local dealership. They replaced the entire trans twice (with used trans) and still had the same issue. After a couple of months of dicking around with it, they claim the SMG actuater is bad? They wanted $3,400 for a new actuater, plus another $1,500 to install it. Trying to save some $$, I purchased an almost new actuater from someone in this forum for $200. The dealer still wants $1,500 plus to install it? From what I've read on this forum, that's not likely the problem. Consequently, having zero confidence in the dealership, I told them to put the car back together and I went and got it. Once home, I used a OBD-II code reader and the code: P1756 (faulty SMG Sensor) So, I purchased a new SMG Sensor (the salmon colored one everyone is talking about on this forum) installed it, re-read the codes, which there were none, and the car worked fine. A couple of weeks later, I'm driving along in sport mode and the trans starts doing the same thing it did before. Fortunately, I got the car home, however, it would only shift into 1st gear, then to 5th gear on the eventful trip. Once I got it home, I read the codes again and got the same P1756 (faulty SMG Sensor)? I have zero confidence in the local dealership to remidy this problem without it costing me 10 grand, so, does anyone have any suggestions? I'd give anything to have my car back!
BradleyStuart is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 06-05-2010, 08:39 PM   #2
Beamn46
Registered User
 
Join Date: Jul 2007
Location: Renton,Wa
Posts: 2,262
My Ride: 02 M3 SMG CB/CINN
Send a message via AIM to Beamn46 Send a message via MSN to Beamn46
Quote:
Originally Posted by BradleyStuart View Post
I'm hoping somebody can help me with this; I've got a 2003 M-3, Convertable with a SMG trans. I've got several problems that have been driving me nutts for the past several months; 1. My car also stalls sometimes when I come to a stop for no apparent reason? 2. But that's far from the biggest problem I'm experiencing, the car started shifting irregularily three months ago. Took it to the local dealership. They replaced the entire trans twice (with used trans) and still had the same issue. After a couple of months of dicking around with it, they claim the SMG actuater is bad? They wanted $3,400 for a new actuater, plus another $1,500 to install it. Trying to save some $$, I purchased an almost new actuater from someone in this forum for $200. The dealer still wants $1,500 plus to install it? From what I've read on this forum, that's not likely the problem. Consequently, having zero confidence in the dealership, I told them to put the car back together and I went and got it. Once home, I used a OBD-II code reader and the code: P1756 (faulty SMG Sensor) So, I purchased a new SMG Sensor (the salmon colored one everyone is talking about on this forum) installed it, re-read the codes, which there were none, and the car worked fine. A couple of weeks later, I'm driving along in sport mode and the trans starts doing the same thing it did before. Fortunately, I got the car home, however, it would only shift into 1st gear, then to 5th gear on the eventful trip. Once I got it home, I read the codes again and got the same P1756 (faulty SMG Sensor)? I have zero confidence in the local dealership to remidy this problem without it costing me 10 grand, so, does anyone have any suggestions? I'd give anything to have my car back!
buy another relay. very possible the one you bought is faulty..shitty but it happens
Beamn46 is offline   Reply With Quote
Old 06-05-2010, 08:44 PM   #3
BradleyStuart
Registered User
 
Join Date: May 2010
Location: Las Vegas, Nevada
Posts: 21
My Ride: 2003 M-3 Convertable
Already ordered another one. Thanks for the suggestion. I appreciated it.
BradleyStuart is offline   Reply With Quote
Old 06-05-2010, 10:45 PM   #4
IFX
Registered User
 
Join Date: Jan 2009
Location: Very South
Posts: 1,344
My Ride: AW //M
Question.

What exactly happens when the SMG "stalls"
The dealer replaced the whole tranny, and it's still acting up, can't you take it back to them and demand they fix it?
__________________
IFX is offline   Reply With Quote
Old 06-05-2010, 11:34 PM   #5
BradleyStuart
Registered User
 
Join Date: May 2010
Location: Las Vegas, Nevada
Posts: 21
My Ride: 2003 M-3 Convertable
I tried, it was supposed to be covered under a drivetrain warranty that I purchased from Zurich. According to Zurich, the SMG System is not part of the drivetrain? It's part of something, just not the drivetrain! Scammers!

Anyway, it feels like there is a clutch slipping in the trans? The motor rev's and the trans does not "catch" accordingly. It's like your'e feathering the clutch, without having a clutch? However, when I stop the car, it feels like the trans is hooked up to much, e.g., the car will still move unless I apply brakes? Then the car will sometimes die. Could this get any stranger?
BradleyStuart is offline   Reply With Quote
Old 06-05-2010, 11:36 PM   #6
IFX
Registered User
 
Join Date: Jan 2009
Location: Very South
Posts: 1,344
My Ride: AW //M
To be honest, I'm dumbfounded on both.

Try the relay as beam said, check m3f SMG troubleshooting too
__________________
IFX is offline   Reply With Quote
Old 06-06-2010, 02:37 AM   #7
0-60motorsports
Registered User
 
Join Date: Sep 2003
Location: Kingdom of Bahrain
Posts: 2,326
My Ride: E30 325ic & E46 M3
Send a message via MSN to 0-60motorsports Send a message via Yahoo to 0-60motorsports
One thing i dont understand is that I never hear any of us here in the Middle-East having issues of this sort with SMG! I have never heard of a PUMP failure either!
__________________
EURO 04 M3: GC Coils, Eibach Sways, PF RTABs, RE RCAs, INTRAVEE II, Black Roundels, ///MFEST Badges, Depo's, VCSL Bumper + Race Lip + CF Trunk + CF Rear Diffusor + CSL center console, DIETZ TV in Motion, SS Stepped Headers, SS Catless S & Res X-pipe, SS Race, Z8 Starter Button, Lamin-X, OEM CSL Steering + CSL interior, OEM CSL Intake, EVOLVE Alpha-N Tune, BBS CH's, FX-R 3.0's, ST40's, DINAN Rear Strut Brace, BW Oil Cooler, 3.91 gears
0-60motorsports is online now   Reply With Quote
Old 06-06-2010, 05:27 PM   #8
BradleyStuart
Registered User
 
Join Date: May 2010
Location: Las Vegas, Nevada
Posts: 21
My Ride: 2003 M-3 Convertable
That's probably because there is some differences between U.S. sold M-3's and those sold outside of the U.S. Since I started searching for a solution, I came accross numerous forum's that refer to M-3's being re-called outside of the U.S. for SMG II upgrades. I have yet to find any reference to a similar recall in the U.S. At this point, I'm seriously considering giving the car back to the financing company. Considering there appears little to no chance of ever getting the thing fixed properly. The whole situation makes me sick! I finally acquire the financial means to buy my "dream car" and it turns out to be a never ending nightmare.

Last edited by BradleyStuart; 06-06-2010 at 11:40 PM.
BradleyStuart is offline   Reply With Quote
Old 06-06-2010, 05:32 PM   #9
0-60motorsports
Registered User
 
Join Date: Sep 2003
Location: Kingdom of Bahrain
Posts: 2,326
My Ride: E30 325ic & E46 M3
Send a message via MSN to 0-60motorsports Send a message via Yahoo to 0-60motorsports
Also there is one actual case of subframe damage on one of myfr einds car where it completely collapsed and also one of a E46 328ci. Thats all i've heard off so far, i am sure there might be 2 more cars though. I am reinforcing my car in the next 2 weeks just to be sure but i have no cracks so far.
__________________
EURO 04 M3: GC Coils, Eibach Sways, PF RTABs, RE RCAs, INTRAVEE II, Black Roundels, ///MFEST Badges, Depo's, VCSL Bumper + Race Lip + CF Trunk + CF Rear Diffusor + CSL center console, DIETZ TV in Motion, SS Stepped Headers, SS Catless S & Res X-pipe, SS Race, Z8 Starter Button, Lamin-X, OEM CSL Steering + CSL interior, OEM CSL Intake, EVOLVE Alpha-N Tune, BBS CH's, FX-R 3.0's, ST40's, DINAN Rear Strut Brace, BW Oil Cooler, 3.91 gears
0-60motorsports is online now   Reply With Quote
Old 07-02-2010, 03:51 PM   #10
nocab72
Registered User
 
Join Date: Jun 2009
Location: NoVA
Posts: 17
My Ride: '03 E46 M3
Samon colored piece you replaced is a relay, not a sensor. To me your issue sounds like the SMG GEAR SELECTION SENSOR, I can't be 100% as I don't know that 1756 code.

Had almost identical behavior with one of my '03 M3 SMG cars. Turned out to be my Gear Selection Sensor going bad, I wasn't getting an SMG sensor code though, autologic was giving errors "failed shift" or something similiar.

The Gear Position Sensor is located near the back of the transmission above the drive shaft

PN: 23412229792
#2 in the below diagram
http://www.realoem.com/bmw/showparts...98&hg=23&fg=10

Part is ~$400, and a couple hours labor to replace. After replacing mine and recalibrating with autologic car shifts better than it ever did now.

--

Car stalling at idle is mostly likely MAF (Mass AirFlow Sensor) dirty or going bad - $250.
__________________

Last edited by nocab72; 07-02-2010 at 03:53 PM. Reason: added stalling suggestion
nocab72 is offline   Reply With Quote
Old 07-02-2010, 06:59 PM   #11
IFX
Registered User
 
Join Date: Jan 2009
Location: Very South
Posts: 1,344
My Ride: AW //M
nocab, did you do do the gear sensor yourself?
__________________
IFX is offline   Reply With Quote
Old 07-02-2010, 07:31 PM   #12
nocab72
Registered User
 
Join Date: Jun 2009
Location: NoVA
Posts: 17
My Ride: '03 E46 M3
Quote:
Originally Posted by IFX View Post
nocab, did you do do the gear sensor yourself?
No, but I hear it is DIY possible. Remove portion of exhaust and drop drive shaft down out of the way and it isn't too impossible to get to.

You will need an autologic or similar to recalibrate the SMG system after swapping the sensor.

Since I have two cars exactly the same (my track car and the track car my girlfriend drives) when I was having SMG issues with my car I just dropped them both off at RRT Racing (BMW Race Shop) and gave the shop a list of components to start swapping from her car to mine until my SMG worked right again. Paying for labor in this case was less than buying a bunch of new parts to figure out which one fixed the issue and I was on a tight timeline with track events every weekend that month.

Kyle
__________________
nocab72 is offline   Reply With Quote
Old 07-03-2010, 01:53 AM   #13
BradleyStuart
Registered User
 
Join Date: May 2010
Location: Las Vegas, Nevada
Posts: 21
My Ride: 2003 M-3 Convertable
Nocab:
Thanks for the suggestion, I'm going to try to replace the compression spring on the shift arm 1st, per a recommendation from a BMW Shop owner? If that does'nt work, the shift selector will assuradly be the next part I replace.

This fix is getting old, I'm getting tired of trying everything to fix this car!
BradleyStuart is offline   Reply With Quote
Old 01-06-2012, 12:10 AM   #14
chinodesignsnyc
Registered User
 
Join Date: Feb 2011
Location: New Jersey
Posts: 65
My Ride: 2002 BMW 325i Xi
Quote:
Originally Posted by BradleyStuart View Post
Nocab:
Thanks for the suggestion, I'm going to try to replace the compression spring on the shift arm 1st, per a recommendation from a BMW Shop owner? If that does'nt work, the shift selector will assuradly be the next part I replace.

This fix is getting old, I'm getting tired of trying everything to fix this car!
I have the same exact problem. Good thing I just bought the car from a used car dealership and the owner of the dealer brought it to a place in queens where they apparently are fully equipped and specialize in M's. Anyways today I called asked so whats the verdict? He said they needed to replace the compression springs on the gear box, also they needed to clear the memory of the computer which was sending a false signal of a bad "relay". Also since the springs were broken the computer kept throwing a code saying the "salmon color relay" was no good. The indicator with the exclamation point with a circle gear also randomly popped up when driving. I get the car back tomorrow lets see what happens. But just wanted to let you know. I only had the car for a day and I was frustrated....I can't imagine how you feel by now. But if he doesn't fix the problem I threatened to pull out of the deal. I'm also considering purchasing warranty coverage on the vehicle....I suggest that for a better piece of mind. I'll keep you updated on the fix....hopefully this will help others that are having the same issue. Peace.
__________________
Photobucket
chinodesignsnyc is offline   Reply With Quote
Old 03-14-2013, 04:22 PM   #15
porschephile
Registered User
 
Join Date: Mar 2013
Location: Brooklyn, NY
Posts: 3
My Ride: 2004 E46 M3
What was the name of the place in Queens? I may need to have them look at my car...
porschephile is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 11:07 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use