E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > DIY: Do It Yourself

DIY: Do It Yourself
Post here to share or improve your wrench turning skills! All BMW E46 DIY tips, tales, and projects discussed inside. Learn to work on your car and know the right BMW parts you will need!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 02-10-2013, 03:36 PM   #1
straight_beamin
Registered User
 
Join Date: Apr 2010
Location: niagara falls
Posts: 797
My Ride: 2000 bmw 323i
Speedometer maxes out when i turn car on

Hi, today i noticed when i turned on my car the speedometer shot up to 250km/hr and just stayed maxed out. The rpms and the temperature and gas gauge work properly but the speed and the mpg needles do not. Ive tried the cluster reset and the battery disconnect with no luck.also checked fuses 10,34,and 43 Another problem on the never ending list
__________________

Last edited by straight_beamin; 02-10-2013 at 03:40 PM.
straight_beamin is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 02-10-2013, 03:38 PM   #2
straight_beamin
Registered User
 
Join Date: Apr 2010
Location: niagara falls
Posts: 797
My Ride: 2000 bmw 323i
This is what happens when i turn car on or into position 2 (accessory). When i turn it off it goes back down to zero
Attached Thumbnails
Click image for larger version

Name:	ImageUploadedByBimmerApp1360528647.425859.jpg
Views:	124
Size:	79.1 KB
ID:	490161  
__________________
straight_beamin is offline   Reply With Quote
Old 02-10-2013, 03:42 PM   #3
stevenluczynski
Registered User
 
Join Date: Oct 2010
Location: orlando
Posts: 1,410
My Ride: Is Steel Blue<3
Looking at the non oem background, it's most likely a messed up motor or mid aligned needle.
__________________
stevenluczynski is offline   Reply With Quote
Old 02-10-2013, 03:55 PM   #4
Charmervin
Registered User
 
Join Date: Oct 2012
Location: Phoenix
Posts: 28
My Ride: 2001 325ci
Check to make sure battery is good...
Charmervin is offline   Reply With Quote
Old 02-10-2013, 04:06 PM   #5
straight_beamin
Registered User
 
Join Date: Apr 2010
Location: niagara falls
Posts: 797
My Ride: 2000 bmw 323i
Actually ive noticed that the battery light also stays on... Think it is the battery
__________________
straight_beamin is offline   Reply With Quote
Old 02-10-2013, 04:07 PM   #6
straight_beamin
Registered User
 
Join Date: Apr 2010
Location: niagara falls
Posts: 797
My Ride: 2000 bmw 323i
Quote:
Originally Posted by stevenluczynski View Post
Looking at the non oem background, it's most likely a messed up motor or mid aligned needle.
Ive had the m3 style cluster in there for 3 years with no problems. Could it just one day do this lol?
__________________
straight_beamin is offline   Reply With Quote
Old 02-10-2013, 05:04 PM   #7
straight_beamin
Registered User
 
Join Date: Apr 2010
Location: niagara falls
Posts: 797
My Ride: 2000 bmw 323i
just checked again while driving, battery light is on! thoughts?
__________________
straight_beamin is offline   Reply With Quote
Old 02-10-2013, 05:08 PM   #8
tks
Registered User
 
Join Date: May 2010
Location: Online
Posts: 838
My Ride: slower than yours
Battery light on.

Go to test 9 in OBC give us results with car on / off


12.5-14.0 car running
12.0-12.6 car off

at least iirc those are normal numbers.

if while running, numbers dont match up, alternator is poo-ed out.
tks is offline   Reply With Quote
Old 02-10-2013, 05:15 PM   #9
straight_beamin
Registered User
 
Join Date: Apr 2010
Location: niagara falls
Posts: 797
My Ride: 2000 bmw 323i
ok will post back shortly, would the alternator cause weird issues with speedo and/or cluster? also noticed the digital part with the mileage and clock is flickering faintly
__________________

Last edited by straight_beamin; 02-10-2013 at 05:17 PM.
straight_beamin is offline   Reply With Quote
Old 02-10-2013, 06:39 PM   #10
straight_beamin
Registered User
 
Join Date: Apr 2010
Location: niagara falls
Posts: 797
My Ride: 2000 bmw 323i
12.1-12.3 volts off
11.3 steady while running
__________________
straight_beamin is offline   Reply With Quote
Old 02-10-2013, 06:56 PM   #11
tks
Registered User
 
Join Date: May 2010
Location: Online
Posts: 838
My Ride: slower than yours
that 11.3 is probably going to diminish... does it ever go higher?

I wouldn't rule out alternator ad a problem but being that the car is already NOT being charged, that is another problem that could affect your current one.

Same as before, see if you can pull up OBC 9.0 =

Get current reading with car running.

Then go to hood, find alternator, unplug sensor part, then go back to OBC see if it changes.

If your is already at 11.3 v while running, your alternator already isn't charging though so yeah.. that's your first problem!
tks is offline   Reply With Quote
Old 02-10-2013, 07:24 PM   #12
straight_beamin
Registered User
 
Join Date: Apr 2010
Location: niagara falls
Posts: 797
My Ride: 2000 bmw 323i
I dont see where the wire is to unplug, safe to keep driving to work?
__________________

Last edited by straight_beamin; 02-10-2013 at 07:25 PM.
straight_beamin is offline   Reply With Quote
Old 02-10-2013, 07:26 PM   #13
2000beamer
Registered User
 
Join Date: Dec 2012
Location: SoFlo
Posts: 531
My Ride: 2000 323i
You have a faulty rear right brake light as well.
__________________
[/SIGPIC]
2000beamer is offline   Reply With Quote
Old 02-10-2013, 07:37 PM   #14
straight_beamin
Registered User
 
Join Date: Apr 2010
Location: niagara falls
Posts: 797
My Ride: 2000 bmw 323i
Nah its just from the led tails lol
__________________
straight_beamin is offline   Reply With Quote
Old 02-11-2013, 01:02 AM   #15
fth001
Registered User
 
Join Date: Jun 2012
Location: Honolulu
Posts: 175
My Ride: 325i, e36m3, s13
Voltage should be in the 13's when the car is running. A quick and easy alternator check is to start the car and then pull the ground off the battery. If the car stays running, the alt is working, if it dies the alt is bad. These cars start acting really weird when there is a voltage problem so the battery should be checked out also.
fth001 is offline   Reply With Quote
Old 02-11-2013, 04:40 AM   #16
straight_beamin
Registered User
 
Join Date: Apr 2010
Location: niagara falls
Posts: 797
My Ride: 2000 bmw 323i
Ya checked this morning im at 10.7 volts when running.
__________________

Last edited by straight_beamin; 02-11-2013 at 04:42 AM.
straight_beamin is offline   Reply With Quote
Old 02-11-2013, 06:17 AM   #17
straight_beamin
Registered User
 
Join Date: Apr 2010
Location: niagara falls
Posts: 797
My Ride: 2000 bmw 323i
Should i replace the alternator?
__________________
straight_beamin is offline   Reply With Quote
Old 02-11-2013, 10:26 AM   #18
tks
Registered User
 
Join Date: May 2010
Location: Online
Posts: 838
My Ride: slower than yours
Yes.

Don't try driving the car because your battery will be next to die too!

Make sure you get it fully charged before you hook up the new alternator so you don't fry it!
tks is offline   Reply With Quote
Old 02-11-2013, 11:46 AM   #19
Ballstowalls
Registered User
 
Join Date: Feb 2012
Location: LA
Posts: 409
My Ride: 05 e46 m3 vert
Slow down haha
Ballstowalls is offline   Reply With Quote
Old 02-11-2013, 12:19 PM   #20
straight_beamin
Registered User
 
Join Date: Apr 2010
Location: niagara falls
Posts: 797
My Ride: 2000 bmw 323i
Quote:
Originally Posted by ruskisky View Post
Yes.

Don't try driving the car because your battery will be next to die too!

Make sure you get it fully charged before you hook up the new alternator so you don't fry it!
installing the new alternator now, will report back. thanks a million
__________________
straight_beamin is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 06:43 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use