E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > New Member Introductions

New Member Introductions
New members check-in, introduce yourselves, and post a picture of your BMW here!

Reply
 
Thread Tools Search this Thread Display Modes
Old 02-11-2013, 07:30 PM   #1
Champ81
Registered User
 
Join Date: Feb 2013
Location: Featherstone
Posts: 5
My Ride: Bmw 320i e46
Hello to all u bmw nuts!!!

Hi there everybody just thought I'd introduce myself to all on this site!!!! My name is Neil and live in Wakefield West Yorkshire England! I'm currently on my 10th bmw,,, having owned a e30 325i cabbie,,then a e39 520i then a 520i auto,various e46,s ie 323i,,, 325ci,,,330ci,,,and a e36 m3,,, I now have a bmw 320i in alpine white,,had this car a while now,,,and iv had a few problems with it,,,,,,,,,but overall I'm greatly happy with this car,but it has got issues,,,,,,,,,the engine warning light came on a few weeks ago whilst I was driving on the m62 going home after a drive to Bradford pootling along at 50mph with the cruise control on!!! So I have no idea why it came on then,,,but it did!!!! Called the aa (it's free to me as my Missis has it as part ov her upgraded bank account) they diagnosed 3fault codes comming from the ecu one ov them being my mass air flow sensor,,,, anybody out there had similar issues? Can help me out with a cheap repair? As money is a serious issue to me at the moment having lost my job in dec 2012!!! Ur advice would be appreciated alot!!! THANKYOU
Champ81 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 03-02-2013, 03:23 AM   #2
rg1bmw
Registered User
 
Join Date: Aug 2006
Location: USA
Posts: 1,464
My Ride: 2002 Infiniti Q45
Welcome
__________________

2002 BMW 530i

Black Leather/5 Speed/Sport Package
rg1bmw is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 08:34 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use