E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Driveline, Engine & DME Tuning

Driveline, Engine & DME Tuning
Talk about driveline improvements, NA tuning and DME tuning your E46 BMW here. This includes diffs, intakes, exhausts, chips, software and OBD tuning.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 02-14-2013, 12:37 PM   #1
tabor
Registered User
 
Join Date: Jan 2012
Location: virginia
Posts: 42
My Ride: 2000 323ci
Dsc light issue.

Hey guys. I have looked around for this issue but it seems like every post has other issues...my car runs fine, but my dsc light stays on. When the car is started I can toggle dsc on/off just fine. After I hit 45mph or so it come on as if I turned it off and the light will not go off. I tested to see if dsc was really off and it is. Sooo..my dsc is not working and unable to be turned on over 45mph. Any ideas on this?

Sent from my SCH-R530U using Bimmer App
__________________
Yumm!!
tabor is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 02-15-2013, 07:17 AM   #2
tabor
Registered User
 
Join Date: Jan 2012
Location: virginia
Posts: 42
My Ride: 2000 323ci
anyone before I go to stealership?

Sent from my SCH-R530U using Bimmer App
__________________
Yumm!!
tabor is offline   Reply With Quote
Old 02-15-2013, 08:20 AM   #3
HiHoBrian
Registered User
 
Join Date: Jul 2011
Location: Connecticut
Posts: 1,113
My Ride: 05 M3
You would need to borrow or buy a PA Soft 1.4 scanner and check the fault codes. You could have a faulty speed sensor,or mismatched tires,or any number of issues. The best way to diagnose it is with diagnostics. If you or anyone you know does not have the diagnostics,then it sounds like you will have to pay $$$ to get it checked out.

sent from my ATARI sc1224
__________________
HiHoBrian is offline   Reply With Quote
Old 02-15-2013, 09:04 AM   #4
tabor
Registered User
 
Join Date: Jan 2012
Location: virginia
Posts: 42
My Ride: 2000 323ci
Crap..... $$$ it is then lol... thank you

Sent from my SCH-R530U using Bimmer App
__________________
Yumm!!
tabor is offline   Reply With Quote
Old 02-15-2013, 03:14 PM   #5
vitalik-seattle
Registered User
 
Join Date: Aug 2007
Location: Seattle WA
Posts: 42
My Ride: 2004 M3
If you in Seattle area I can check it out for free. I have BMW specific software but deff sounds like a faulty speed sensor. Try cleaning it
__________________
My freedom is on 2 wheels =)
vitalik-seattle is offline   Reply With Quote
Old 02-16-2013, 06:45 AM   #6
tabor
Registered User
 
Join Date: Jan 2012
Location: virginia
Posts: 42
My Ride: 2000 323ci
Thanks for the offer but I live in VA. The south western portion.

Sent from my SCH-R530U using Bimmer App
__________________
Yumm!!
tabor is offline   Reply With Quote
Old 02-17-2013, 02:34 PM   #7
2KBMW
Registered User
 
Join Date: Mar 2003
Location: Austin, TX
Posts: 463
My Ride: Black E46 Sedan
Send a message via Yahoo to 2KBMW
I have the same problem. the DSC light shows up and stays on sometimes (my tires are getting old though; it might be it)
__________________
2KBMW is offline   Reply With Quote
Old 02-17-2013, 06:27 PM   #8
Repincali
Registered User
 
Join Date: Dec 2012
Location: Cali
Posts: 9
My Ride: 2001 325i
I have the opposite issue. No matter how long I hold the DSC button, no light comes on. I'm not sure if its working or not.
Repincali is offline   Reply With Quote
Old 02-17-2013, 07:27 PM   #9
tabor
Registered User
 
Join Date: Jan 2012
Location: virginia
Posts: 42
My Ride: 2000 323ci
Im running two diff. Tire sizes right now...245/55 18 in rear, and 245/45 18 in front.(yes i like meaty tires) I put my style 44's back on an issue went away...so I dunno if it's a faulty sensor but thats whats going on with me.

Sent from my SCH-R530U using Bimmer App
__________________
Yumm!!
tabor is offline   Reply With Quote
Old 02-20-2013, 05:36 PM   #10
2KBMW
Registered User
 
Join Date: Mar 2003
Location: Austin, TX
Posts: 463
My Ride: Black E46 Sedan
Send a message via Yahoo to 2KBMW
Quote:
Originally Posted by tabor View Post
Im running two diff. Tire sizes right now...245/55 18 in rear, and 245/45 18 in front.(yes i like meaty tires) I put my style 44's back on an issue went away...so I dunno if it's a faulty sensor but thats whats going on with me.

Sent from my SCH-R530U using Bimmer App
I believe this could be it...my tires are old as fvk lol
__________________
2KBMW is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Censor is OFF





All times are GMT -5. The time now is 07:09 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use