E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Lighting Forum

Lighting Forum
Angel Eyes, DDEs, lighted rings, Clear Turn Signals, LEDs, Xenon, HID, or Bi-Xenon. If it lights up and you want to discuss it, post here!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 02-23-2013, 05:25 PM   #1
GATORSHOES2
Registered User
 
Join Date: Jun 2012
Location: US
Posts: 200
My Ride: 2002 BMW 325i
Eagle Eyes quality as of 2013?

So the only reason I have put off getting EEs for my car is the threads people have posted about some of the LEDs or a row of them not powering. Most of these issues are 2010-2012 but mainly 2010. Is there anyone who could chime in on the quality or problems as of now? I saw a thread recently but his was DOA. If it arrives dead I can get a replacement, unlike in half a year if something goes out.
__________________
GATORSHOES2 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 02-23-2013, 05:30 PM   #2
Solidjake
Zero. Oil. Leaks.
 
Solidjake's Avatar
 
Join Date: May 2008
Location: NYC
Posts: 22,211
My Ride: 2002 330i
No idea at all on how they are now.
Solidjake is offline   Reply With Quote
Old 02-23-2013, 07:22 PM   #3
GATORSHOES2
Registered User
 
Join Date: Jun 2012
Location: US
Posts: 200
My Ride: 2002 BMW 325i
Quote:
Originally Posted by Solidjake View Post
No idea at all on how they are now.
Oh? Ok.. Thanks.. o_O

Going by your signature you have some. Where did you get yours and are they lasting?
__________________
GATORSHOES2 is offline   Reply With Quote
Old 02-24-2013, 03:24 AM   #4
Solidjake
Zero. Oil. Leaks.
 
Solidjake's Avatar
 
Join Date: May 2008
Location: NYC
Posts: 22,211
My Ride: 2002 330i
Mine are 4 years old

No issues with them besides the lights pulsing when it's extremely cold.
Solidjake is offline   Reply With Quote
Old 02-24-2013, 05:26 PM   #5
GATORSHOES2
Registered User
 
Join Date: Jun 2012
Location: US
Posts: 200
My Ride: 2002 BMW 325i
Quote:
Originally Posted by Solidjake View Post
Mine are 4 years old

No issues with them besides the lights pulsing when it's extremely cold.
Besides customer service, is there a particular difference between khoaltys and umnitzas? I think I'm going to be ordering from khoalty. I mean they are both EEs..?
__________________
GATORSHOES2 is offline   Reply With Quote
Old 02-24-2013, 05:30 PM   #6
trentcdrums
Registered User
 
Join Date: Jul 2012
Location: Illinois
Posts: 2,014
My Ride: BMW 323i Sedan
I still have mine after 5
Months and love them.
__________________

trentcdrums is offline   Reply With Quote
Old 02-24-2013, 05:49 PM   #7
GATORSHOES2
Registered User
 
Join Date: Jun 2012
Location: US
Posts: 200
My Ride: 2002 BMW 325i
Quote:
Originally Posted by trentcdrums View Post
I still have mine after 5
Months and love them.
Who did you get yours from?
__________________
GATORSHOES2 is offline   Reply With Quote
Old 02-24-2013, 06:14 PM   #8
Solidjake
Zero. Oil. Leaks.
 
Solidjake's Avatar
 
Join Date: May 2008
Location: NYC
Posts: 22,211
My Ride: 2002 330i
They're the same regardless of vendor, just search around to see who has better customer service if/when they fail.
Solidjake is offline   Reply With Quote
Old 02-24-2013, 06:15 PM   #9
JZambrano7
Registered User
 
Join Date: Feb 2011
Location: Corona,NY
Posts: 1,182
My Ride: 2003 325xi
For some reason mine keep showing the rear error on the dash board
__________________

-JZ7-
JZambrano7 is offline   Reply With Quote
Old 02-24-2013, 06:16 PM   #10
Solidjake
Zero. Oil. Leaks.
 
Solidjake's Avatar
 
Join Date: May 2008
Location: NYC
Posts: 22,211
My Ride: 2002 330i
^ Check your wiring
Solidjake is offline   Reply With Quote
Old 02-24-2013, 06:29 PM   #11
trentcdrums
Registered User
 
Join Date: Jul 2012
Location: Illinois
Posts: 2,014
My Ride: BMW 323i Sedan
Quote:
Originally Posted by JZambrano7 View Post
For some reason mine keep showing the rear error on the dash board
Mine to. It's a ground issue. Just turn the lights on and the lights leave.
__________________

trentcdrums is offline   Reply With Quote
Old 02-24-2013, 06:35 PM   #12
JZambrano7
Registered User
 
Join Date: Feb 2011
Location: Corona,NY
Posts: 1,182
My Ride: 2003 325xi
Even when the lights are on I have that problem. For some reason the PO had soldered the wires to the lights so I had to do the same when installing the EE. Since I did that my tails light up weird when braking. The left side works fine but the right doesn't light up as strong.
__________________

-JZ7-
JZambrano7 is offline   Reply With Quote
Old 02-24-2013, 06:40 PM   #13
GATORSHOES2
Registered User
 
Join Date: Jun 2012
Location: US
Posts: 200
My Ride: 2002 BMW 325i
Quote:
Originally Posted by JZambrano7 View Post
Even when the lights are on I have that problem. For some reason the PO had soldered the wires to the lights so I had to do the same when installing the EE. Since I did that my tails light up weird when braking. The left side works fine but the right doesn't light up as strong.
Post pictures of whats going on.
When I bought my car the PO didn't fix the metled harness so I had to do that myself. The "updated" EEs arent suppose to give the light error.
__________________
GATORSHOES2 is offline   Reply With Quote
Old 02-24-2013, 06:45 PM   #14
JZambrano7
Registered User
 
Join Date: Feb 2011
Location: Corona,NY
Posts: 1,182
My Ride: 2003 325xi
Ill take pictures tomorrow I never asked anyone because I didn't think anyone had the same problem. I learned to live with my tail lights not working the way it should.
__________________

-JZ7-
JZambrano7 is offline   Reply With Quote
Old 02-24-2013, 10:26 PM   #15
GATORSHOES2
Registered User
 
Join Date: Jun 2012
Location: US
Posts: 200
My Ride: 2002 BMW 325i
Just ordered my EEs from khoalty. We will see how this goes.
__________________
GATORSHOES2 is offline   Reply With Quote
Old 02-24-2013, 10:53 PM   #16
trentcdrums
Registered User
 
Join Date: Jul 2012
Location: Illinois
Posts: 2,014
My Ride: BMW 323i Sedan
Ordered mine from khoalty and I like.
__________________

trentcdrums is offline   Reply With Quote
Old 02-27-2013, 04:01 PM   #17
Riverbmr3
Registered User
 
Join Date: May 2004
Location: H-town
Posts: 4,011
My Ride: slow 3
my EE led tails died after three years
Riverbmr3 is offline   Reply With Quote
Old 02-27-2013, 04:24 PM   #18
///Mostarac
Registered User
 
///Mostarac's Avatar
 
Join Date: Jun 2010
Location: Bosnia-Hercegovina, New Jersey
Posts: 4,964
My Ride: SiennaE46 & Cbr600rr
my tails threw codes after about a little less than a year. khoalty wanted me to pay shipping to thailand to have them fixed. Great customer service.
__________________
PARTING OUT MY CAR!!!!!! CLICK HERE
Eurowerkz | East Coast
-Benny
///Mostarac is offline   Reply With Quote
Old 02-27-2013, 04:39 PM   #19
Riverbmr3
Registered User
 
Join Date: May 2004
Location: H-town
Posts: 4,011
My Ride: slow 3
Quote:
Originally Posted by ///Mostarac View Post
my tails threw codes after about a little less than a year. khoalty wanted me to pay shipping to thailand to have them fixed. Great customer service.
Riverbmr3 is offline   Reply With Quote
Old 02-27-2013, 06:38 PM   #20
GATORSHOES2
Registered User
 
Join Date: Jun 2012
Location: US
Posts: 200
My Ride: 2002 BMW 325i
Quote:
Originally Posted by pinoybmr3 View Post
my EE led tails died after three years
Quote:
Originally Posted by ///Mostarac View Post
my tails threw codes after about a little less than a year. khoalty wanted me to pay shipping to thailand to have them fixed. Great customer service.
You would think they would have you ship them the bad pair, and they ship you out replacements. I ordered from them before with no problems, but that doesn't mean I won't in the future..
Y U guys no chime in before I order? Oh well. I will report back on day 1 of install...
__________________
GATORSHOES2 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 12:03 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use