E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 5 votes, 5.00 average. Display Modes
Old 08-04-2014, 06:21 AM   #21
James Buntline
Registered User
 
Join Date: Aug 2014
Location: Sweden
Posts: 2
My Ride: BMW 540
Ok, I will do the cluster check but first I have to take out the cluster to repair the pixels, maybe I can check the bulb during that operation?. I dont think its the bulbs because I bought this car one week ago and Im sure (almost) that they both were working at that time.
In the left field with CEL light an EML light the light for battery and oil still works during ignition.

It makes me a little bit schizo that I am not sure if these two lights worked when buying the car, concerning the other warnings as airbag I am 100 proof sure.
James Buntline is offline   Reply With Quote
Old 08-04-2014, 08:40 AM   #22
jfoj
Registered User
 
Join Date: Nov 2009
Location: Fairfax, VA USA
Posts: 15,396
My Ride: 330CiC, M5, X5
Quote:
Originally Posted by James Buntline View Post
Ok, I will do the cluster check but first I have to take out the cluster to repair the pixels, maybe I can check the bulb during that operation?. I dont think its the bulbs because I bought this car one week ago and Im sure (almost) that they both were working at that time.
In the left field with CEL light an EML light the light for battery and oil still works during ignition.

It makes me a little bit schizo that I am not sure if these two lights worked when buying the car, concerning the other warnings as airbag I am 100 proof sure.
Not aware that the E46 has issues wit the pixels in the cluster like the E39.

But if you take the cluster out, check for tape or damage to the LED's around the warning light area.
__________________
Solve your misfires, lean codes, rough idle - http://forum.e46fanatics.com/showthread.php?t=897616

Fuel pump failures - http://forum.e46fanatics.com/showthread.php?t=929501

Temp Info - http://forum.e46fanatics.com/showthread.php?t=964491

Hidden OBC Menu - Check Voltage, Temp, Fuel Level - http://forum.e46fanatics.com/showthread.php?t=239619

E46/E39 GM5 Door Lock Info - www.bmwgm5.com

Lower hose temp switch O-ring - BMW #13621743299
jfoj is offline   Reply With Quote
Old 08-04-2014, 10:57 AM   #23
annnnt1
Registered User
 
Join Date: May 2014
Posts: 56
Lol ur car Hates u! That's why it hisses at u


Sent from BimmerApp mobile app
annnnt1 is offline   Reply With Quote
Old 08-04-2014, 11:35 AM   #24
robin325ci
Registered User
 
Join Date: Feb 2006
Location: Manila, Philippines
Posts: 500
My Ride: Helrot 325Ci
OP you have a european spec car. Mine is Euro spec as well, and I've never seen the EML light come on. Even on my friend's '02 318i the EML light did not come on when we unplugged the MAF.
__________________
robin325ci is offline   Reply With Quote
Old 08-04-2014, 09:02 PM   #25
Sicily1918
There I was, Sicily, 1918..
 
Sicily1918's Avatar
 
Join Date: Sep 2003
Location: Los Angeles
Posts: 1,682
My Ride: 1995 E36/2003 E46
Quote:
Originally Posted by robin325ci View Post
OP you have a european spec car. Mine is Euro spec as well, and I've never seen the EML light come on. Even on my friend's '02 318i the EML light did not come on when we unplugged the MAF.
Yeah, I was gonna suggest that -- under bright light, I can see on my cluster things that could never light up, like Convertible Top (I have a coupe) or TPMs (optional in '03).
Sicily1918 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 04:26 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use