E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > ///M3 Forum

///M3 Forum
The BMW E46 ///M3 is the M version E46 and puts out an amazing 333 HP and 262 lb-ft of torque at stock specs! There are an amazing amount of modifications for both the coupe and convertible models so read up and get started modifying your cars today!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 03-13-2013, 01:46 PM   #1
Qban32
Registered User
 
Join Date: Mar 2011
Location: Charlotte, NC
Posts: 15
My Ride: 03.5 M3
Radio has power but does not come on NEED HELP

I have a 2003.5 m3 with the harmon kardon sound. I was on a 600 mile trip when my radio said PHONE on the screen (non navi) and then the radio portion of the screen shut off. When I have the interior lights on all the buttons and dials light up but the radio will not come on and I cannot play anything. I checked the fuse box in the glove box as well as the back of the radio fuse. Could it be the amp fuse? I have not tried that yet but all the other fuses seem to be fine. Any help would be appreciated.
Qban32 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 03-24-2013, 12:01 AM   #2
GJ345
Registered User
 
Join Date: Dec 2011
Location: Cayman Islands
Posts: 38
My Ride: 04 Manual Euro M3
Amp

May be its the amp it self mines went out and had the same problem
GJ345 is offline   Reply With Quote
Old 03-24-2013, 03:28 AM   #3
Slyde
Registered User
 
Join Date: Jan 2010
Location: Seattle, WA, USA
Posts: 89
My Ride: 2001 M3 TiAg
der... never mind.
__________________

Last edited by Slyde; 03-24-2013 at 03:33 AM. Reason: oops
Slyde is offline   Reply With Quote
Reply

Tags
amp, fuse, radio, sound

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 07:16 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use