E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > E46 Convertible

E46 Convertible
The E46 vert forum. Talk about dropping your E46 top here.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 09-12-2016, 03:53 PM   #1
lgv10
Registered User
 
Join Date: Aug 2016
Location: florida
Posts: 25
My Ride: 2004 BMW 330ci
Convertible Top Control Unit

Hello,

Has anyone had a control unit for the convertible top fail? If so, how much was it to replace? Or, is there an alternative to getting the top to work? I am being charged $1500 to replace the unit because the buttons on the dash no longer communicate with this control unit. I can still lower the top with my remote but I can get the top to come up after that.

Incredibly frustrated since I have only owned the car for 3 months.

Any advice would be greatly appreciated!

Last edited by lgv10; 09-12-2016 at 03:54 PM.
lgv10 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 09-12-2016, 03:57 PM   #2
All2kool
Registered User
 
Join Date: Mar 2016
Location: Portland, OR
Posts: 557
My Ride: 2002 325Ci
Quote:
Originally Posted by lgv10 View Post
Hello,

Has anyone had a control unit for the convertible top fail? If so, how much was it to replace? Or, is there an alternative to getting the top to work? I am being charged $1500 to replace the unit because the buttons on the dash no longer communicate with this control unit. I can still lower the top with my remote but I can get the top to come up after that.

Incredibly frustrated since I have only owned the car for 3 months.

Any advice would be greatly appreciated!
I've read more than one post here about failed CVM's. As for buying one from a dealer, you can get a good used working unit off EBay for under $50. I seem to recall that the CVM is standard for all E46 cars.

Last edited by All2kool; 09-12-2016 at 04:00 PM.
All2kool is offline   Reply With Quote
Old 09-12-2016, 04:03 PM   #3
lgv10
Registered User
 
Join Date: Aug 2016
Location: florida
Posts: 25
My Ride: 2004 BMW 330ci
I thought it was the CVM also and I can get one new for $345. However, the mechanic is referring to a "Control Unit" that has a different part number (54347025592). The CVM's part number is different.

I think the part he refers to is the HYDRAULIC VALVE BLOCK AKA CONTROL UNIT BMW P/N 54347025592.
lgv10 is offline   Reply With Quote
Old 09-12-2016, 04:16 PM   #4
All2kool
Registered User
 
Join Date: Mar 2016
Location: Portland, OR
Posts: 557
My Ride: 2002 325Ci
Quote:
Originally Posted by lgv10 View Post
I thought it was the CVM also and I can get one new for $345. However, the mechanic is referring to a "Control Unit" that has a different part number (54347025592). The CVM's part number is different.

I think the part he refers to is the HYDRAULIC VALVE BLOCK AKA CONTROL UNIT BMW P/N 54347025592.
I do believe your mechanic is referring to the CVM. The CVM is a $1500 part from the dealer but as I said, a good used one is less than $50.

See this link at RealOEM.com: http://www.realoem.com/bmw/enUS/show...76#54347025592

Last edited by All2kool; 09-12-2016 at 04:18 PM.
All2kool is offline   Reply With Quote
Old 09-12-2016, 04:22 PM   #5
lgv10
Registered User
 
Join Date: Aug 2016
Location: florida
Posts: 25
My Ride: 2004 BMW 330ci
Well I just figured it out. My mechanic was charging me $1500 for CVM which I can purchase from FCP Euro for $314.99. What he did was give the part number for the Valve Block/Control which is $1500. He was trying to do a switch and bait. When I confronted him with it, he admitted that he gave me the wrong part number and instead said that it wasn't the Valve Block/Control unit, but instead it was the CVM which is a heck of lot cheaper. I will start looking for another mechanic!
lgv10 is offline   Reply With Quote
Old 09-12-2016, 04:24 PM   #6
All2kool
Registered User
 
Join Date: Mar 2016
Location: Portland, OR
Posts: 557
My Ride: 2002 325Ci
Quote:
Originally Posted by lgv10 View Post
Well I just figured it out. My mechanic was charging me $1500 for CVM which I can purchase from FCP Euro for $314.99. What he did was give the part number for the Valve Block/Control which is $1500. He was trying to do a switch and bait. When I confronted him with it, he admitted that he gave me the wrong part number and instead said that it wasn't the Valve Block/Control unit, but instead it was the CVM which is a heck of lot cheaper. I will start looking for another mechanic!
I think the clue here was that the hydraulics were working partially. A hydraulic failure would generally be total. If you need a to replace the CVM, EBay is your friend. See my previous post. I would spend $38 on EBay for a used part before spending $315 for a new part, even though $315 for a new CVM is a great deal.

Last edited by All2kool; 09-12-2016 at 04:25 PM.
All2kool is offline   Reply With Quote
Old 09-12-2016, 04:29 PM   #7
lgv10
Registered User
 
Join Date: Aug 2016
Location: florida
Posts: 25
My Ride: 2004 BMW 330ci
I agree with you. However, will the used part need to be reprogrammed or is it plug and play?
lgv10 is offline   Reply With Quote
Old 09-12-2016, 04:32 PM   #8
All2kool
Registered User
 
Join Date: Mar 2016
Location: Portland, OR
Posts: 557
My Ride: 2002 325Ci
Quote:
Originally Posted by lgv10 View Post
I agree with you. However, will the used part need to be reprogrammed or is it plug and play?
Plug-N-Play.
All2kool is offline   Reply With Quote
Old 09-12-2016, 04:34 PM   #9
lgv10
Registered User
 
Join Date: Aug 2016
Location: florida
Posts: 25
My Ride: 2004 BMW 330ci
Really, he told me it would have to be reprogrammed for my car.
lgv10 is offline   Reply With Quote
Old 09-12-2016, 05:09 PM   #10
All2kool
Registered User
 
Join Date: Mar 2016
Location: Portland, OR
Posts: 557
My Ride: 2002 325Ci
Quote:
Originally Posted by lgv10 View Post
Really, he told me it would have to be reprogrammed for my car.
There was another user here not too long ago that just installed a used replacement and his top started working again. He made no mention of having it programmed. I think if it comes from a US car you are fine. Don't take my word for it but as you mentioned already, your mechanic isn't always right. I would call the dealer and get a price quote and ask them if programming is required while I was at it.
All2kool is offline   Reply With Quote
Old 09-12-2016, 06:05 PM   #11
lgv10
Registered User
 
Join Date: Aug 2016
Location: florida
Posts: 25
My Ride: 2004 BMW 330ci
Cool. Well thanks for responding back with that information. I appreciate it!
lgv10 is offline   Reply With Quote
Old 09-12-2016, 06:57 PM   #12
lgv10
Registered User
 
Join Date: Aug 2016
Location: florida
Posts: 25
My Ride: 2004 BMW 330ci
I am going to buy one of the used units on Ebay and try it. It's easy enough to get to and plug it in. I will post back with the results.
lgv10 is offline   Reply With Quote
Old 09-13-2016, 05:20 PM   #13
cxoakes
Registered User
 
Join Date: Sep 2014
Location: Cincinnati
Posts: 72
My Ride: 2002 330ci vert
I just had to plug and play when I replaced my CVM, no programming needed. I got it from ebay for $50, works great now!

Sent from my Z958 using Tapatalk
cxoakes is offline   Reply With Quote
Old 09-14-2016, 09:18 AM   #14
lgv10
Registered User
 
Join Date: Aug 2016
Location: florida
Posts: 25
My Ride: 2004 BMW 330ci
Can you tell what problem(s) you had with your top that you had to replace the CVM?

Thanks in advance!
lgv10 is offline   Reply With Quote
Old 09-14-2016, 10:01 AM   #15
cxoakes
Registered User
 
Join Date: Sep 2014
Location: Cincinnati
Posts: 72
My Ride: 2002 330ci vert
Just stopped working one day when I was closing the top. Wouldn't do anything when I pressed the buttons, no lights flashing, nothing.

Sent from my Z958 using Tapatalk
cxoakes is offline   Reply With Quote
Old 09-14-2016, 10:04 AM   #16
lgv10
Registered User
 
Join Date: Aug 2016
Location: florida
Posts: 25
My Ride: 2004 BMW 330ci
Oh, okay. Cool! Pretty much the same situation I have. Thank you very much for sharing your success! I hope to have the same. I will post it when I do mine.

Thanks again!!!
lgv10 is offline   Reply With Quote
Old 09-24-2016, 02:49 PM   #17
lgv10
Registered User
 
Join Date: Aug 2016
Location: florida
Posts: 25
My Ride: 2004 BMW 330ci
Well, I ordered a used CVM ($59.00) on Ebay and am waiting for it to arrive to install it and see if it fixes my convertible top.

I will post back with my results.
lgv10 is offline   Reply With Quote
Old 09-27-2016, 08:22 PM   #18
Archbid
Registered User
 
Join Date: Jun 2013
Location: Marin, CA
Posts: 951
My Ride: 2003 330cic
I replaced mine a year ago after replacing the harness and having the pump rebuilt. It works now!
Archbid is offline   Reply With Quote
Old 09-28-2016, 09:30 AM   #19
lgv10
Registered User
 
Join Date: Aug 2016
Location: florida
Posts: 25
My Ride: 2004 BMW 330ci
Did you have a problem with the control unit? If so, what were the symptoms?

Thanks for sharing your experience!

I hope to be installing mine by the end of the week. Keeping my fingers crossed...
lgv10 is offline   Reply With Quote
Old 09-28-2016, 09:50 AM   #20
Archbid
Registered User
 
Join Date: Jun 2013
Location: Marin, CA
Posts: 951
My Ride: 2003 330cic
Quote:
Originally Posted by lgv10 View Post
Did you have a problem with the control unit? If so, what were the symptoms?

Thanks for sharing your experience!

I hope to be installing mine by the end of the week. Keeping my fingers crossed...
My saga is http://forum.e46fanatics.com/showthr...520&highlight=

On rereading it, it appears that one issue was that the GM wasn't reading windows down, so the CVM stalled. I am not experienced enough to diagnose this kind of problem.
Archbid is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 02:22 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
(c) 1999 - 2016 performanceIX Inc - privacy policy - terms of use