E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Forced Induction Forum Sponsored by Active Autowerke

Forced Induction Forum Sponsored by Active Autowerke
Discuss supercharging, turbocharging and even nitrous and water injection here.
Sponsored by Active Autowerke

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 03-18-2013, 08:11 PM   #1
daewon774
Registered User
 
Join Date: May 2011
Location: Boston
Posts: 141
My Ride: 2002 330xi
Exclamation Stuttering when WOT, AA stage 1

I having an issue with my e46 330. I have a stage 1 AA kit installed. I was getting a ICV mechanically stuck open from the ECU, and then got it replaced. The car now drives fine under light to medium throttle, but when at wide open I'm getting issues.
  • When at WOT at around 2800 RPM and after, the car stutters. It goes through the revs, but you can feel the motor stutter, and the exhaust sound is not 'even'. There's a big change in the way the motor behaves and sounds. If I let off, the car drives fine from light to medium throttle.
  • Also, if I do two or more runs at WOT, the car then stutters constantly even at light and medium throttle. When I key off for ten seconds and then key on, the car will act fine from light to medium throttle again.

Any ideas on how to diagnose and see what the issue might be?
__________________
2002 E46 330xi
Active Autowerke Stage I Supercharger
Magnaflow 11378 exhaust
Bilstein shocks/struts + H&R springs
Style 71s
Soon to be installed Bimmerbrakes headers + LC1...


daewon774 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 03-18-2013, 08:41 PM   #2
TrippinBimmer
Registered User
 
Join Date: Jan 2008
Location: Ridgeland, MS
Posts: 5,385
My Ride: ZHP Custom Stage 3.5
Send a message via AIM to TrippinBimmer Send a message via Yahoo to TrippinBimmer
Test all ur injectors. I assume this happen under load?
TrippinBimmer is offline   Reply With Quote
Old 03-18-2013, 08:44 PM   #3
daewon774
Registered User
 
Join Date: May 2011
Location: Boston
Posts: 141
My Ride: 2002 330xi
Quote:
Originally Posted by TrippinBimmer View Post
Test all ur injectors. I assume this happen under load?
Exactly, all under load.

Mind if I ask what the procedure is to test injectors? What do you mean? Flow?
__________________
2002 E46 330xi
Active Autowerke Stage I Supercharger
Magnaflow 11378 exhaust
Bilstein shocks/struts + H&R springs
Style 71s
Soon to be installed Bimmerbrakes headers + LC1...


daewon774 is offline   Reply With Quote
Old 03-18-2013, 09:09 PM   #4
TrippinBimmer
Registered User
 
Join Date: Jan 2008
Location: Ridgeland, MS
Posts: 5,385
My Ride: ZHP Custom Stage 3.5
Send a message via AIM to TrippinBimmer Send a message via Yahoo to TrippinBimmer
Quote:
Originally Posted by daewon774 View Post
Exactly, all under load.

Mind if I ask what the procedure is to test injectors? What do you mean? Flow?
I use a 9v battery and make sure all noid opens. I had an issue with one of my injectors just failed on me. Then if they all open then do a flow test...
TrippinBimmer is offline   Reply With Quote
Old 03-19-2013, 09:15 AM   #5
daewon774
Registered User
 
Join Date: May 2011
Location: Boston
Posts: 141
My Ride: 2002 330xi
Quote:
Originally Posted by TrippinBimmer View Post
I use a 9v battery and make sure all noid opens. I had an issue with one of my injectors just failed on me. Then if they all open then do a flow test...
Thanks again for the reply. When you mean 9v battery, you mean a standard 9v rectangular battery like these?
__________________
2002 E46 330xi
Active Autowerke Stage I Supercharger
Magnaflow 11378 exhaust
Bilstein shocks/struts + H&R springs
Style 71s
Soon to be installed Bimmerbrakes headers + LC1...


daewon774 is offline   Reply With Quote
Old 03-19-2013, 09:30 AM   #6
Viral@ActiveAutowerke
Sponsor
 
Viral@ActiveAutowerke's Avatar
 
Join Date: Nov 2008
Location: Miami, Florida
Posts: 1,178
My Ride: E46 M3
Quote:
Originally Posted by daewon774 View Post
I having an issue with my e46 330. I have a stage 1 AA kit installed. I was getting a ICV mechanically stuck open from the ECU, and then got it replaced. The car now drives fine under light to medium throttle, but when at wide open I'm getting issues.
  • When at WOT at around 2800 RPM and after, the car stutters. It goes through the revs, but you can feel the motor stutter, and the exhaust sound is not 'even'. There's a big change in the way the motor behaves and sounds. If I let off, the car drives fine from light to medium throttle.
  • Also, if I do two or more runs at WOT, the car then stutters constantly even at light and medium throttle. When I key off for ten seconds and then key on, the car will act fine from light to medium throttle again.

Any ideas on how to diagnose and see what the issue might be?
Please give us a call that way we can help diagnose this issue and point you in the right direction.
__________________
Viral Vahia
Active Autowerke | 9940 SW 168 Terrace Miami, Florida 33157
www.activeautowerke.com | viral@activeautowerke.com
Phone: 305.233.9300 Ext. 232 | Fax: 305-253-8921
Viral@ActiveAutowerke is offline   Reply With Quote
Old 03-19-2013, 09:41 AM   #7
TrippinBimmer
Registered User
 
Join Date: Jan 2008
Location: Ridgeland, MS
Posts: 5,385
My Ride: ZHP Custom Stage 3.5
Send a message via AIM to TrippinBimmer Send a message via Yahoo to TrippinBimmer
Quote:
Originally Posted by daewon774 View Post
Thanks again for the reply. When you mean 9v battery, you mean a standard 9v rectangular battery like these?
Yep, injectors don't need to much voltage.

BTW: I would not drive the car until you know what's up. Probably have engine damage...

Last edited by TrippinBimmer; 03-19-2013 at 09:45 AM.
TrippinBimmer is offline   Reply With Quote
Old 03-19-2013, 10:16 AM   #8
SweTurbo
Big Pimpin'
 
Join Date: Nov 2008
Location: Europe
Posts: 2,899
My Ride: 323i -98
Quote:
Originally Posted by TrippinBimmer View Post
Yep, injectors don't need to much voltage.

BTW: I would not drive the car until you know what's up. Probably have engine damage...
This, what you're feeling is knocking.
SweTurbo is offline   Reply With Quote
Old 03-19-2013, 11:58 AM   #9
mike@maximumpsi
boost junky
 
Join Date: Dec 2010
Location: Linden, NJ
Posts: 563
My Ride: 02M3T, 97M3T
I would start by checking the codes for a misfire. It sounds ignition related since the issue goes away under light load. Make sure to have a good set of plugs installed and gapped correctly. If you have a weak coil it could have issues in boost. A simple way is if you are having cyl 3 misfire, swap coil # 3 and 4 and see if the misfire moves to cylinder #4.
__________________
02 M3 - Maximum PSI S2 turbo kit - 10.43@135.81, stock motor, stock ecu
97 M3 - Maximum PSI turbocharged - 8.94@164.33, stock ecu, first in the 9's, first in the 8's
Maximum PSI - Home of the quickest BMW's in the US
Click here for E46Fanatics 1/4 mile standings
Like us on facebook to follow our latest builds and upcoming events!
mike@maximumpsi is offline   Reply With Quote
Old 03-24-2013, 12:37 PM   #10
daewon774
Registered User
 
Join Date: May 2011
Location: Boston
Posts: 141
My Ride: 2002 330xi
I just wanted to post up my results in case anyone else runs I to a similar problem. I had a code F2 which is a misfire of cylinder 5

Swapped injectors with cylinders 5 and 6 = everything fine
Swapped coils = everything fine
Swapped spark plugs = problem followed the plugs!

I took a look at the plugs and there was a huge crack I didn't see whn I swapped the plugs. Got new plugs and everything is fine

Thanks everyone for all the comments and suggestions!
__________________
2002 E46 330xi
Active Autowerke Stage I Supercharger
Magnaflow 11378 exhaust
Bilstein shocks/struts + H&R springs
Style 71s
Soon to be installed Bimmerbrakes headers + LC1...


daewon774 is offline   Reply With Quote
Old 03-24-2013, 01:32 PM   #11
TrippinBimmer
Registered User
 
Join Date: Jan 2008
Location: Ridgeland, MS
Posts: 5,385
My Ride: ZHP Custom Stage 3.5
Send a message via AIM to TrippinBimmer Send a message via Yahoo to TrippinBimmer
Quote:
Originally Posted by daewon774 View Post
I just wanted to post up my results in case anyone else runs I to a similar problem. I had a code F2 which is a misfire of cylinder 5

Swapped injectors with cylinders 5 and 6 = everything fine
Swapped coils = everything fine
Swapped spark plugs = problem followed the plugs!

I took a look at the plugs and there was a huge crack I didn't see whn I swapped the plugs. Got new plugs and everything is fine

Thanks everyone for all the comments and suggestions!
Kewl beans
TrippinBimmer is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 05:50 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use