E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Forced Induction Forum Sponsored by Active Autowerke

Forced Induction Forum Sponsored by Active Autowerke
Discuss supercharging, turbocharging and even nitrous and water injection here.
Sponsored by Active Autowerke

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 04-28-2013, 12:24 PM   #21
LilFlip#2
Registered User
 
Join Date: Jan 2003
Location: Northridge
Posts: 1,104
My Ride: not a bimmer
I have contacted AA but it seems like they are blaming the the adaptations. I cleared the adaptations again and left a message for ZAK 4 days ago and haven't heard back from him.



Quote:
Originally Posted by lutzperformance View Post
Any update on this, as someone stated, AFR's on the dyno due read higher than that of a Wideband in the car, but these numbers are pretty far from normal, have you contacted anyone at AA prior to these postings?

-Andrew
__________________
2005 IB ZCP - AA 1.5 HKS - Work VSXX - 430 RWHP 91 Octane


LilFlip#2 is offline   Reply With Quote
Old 04-29-2013, 10:20 AM   #22
lutzperformance
Lutz Performance-FL BMW F/I
 
Join Date: Jan 2008
Location: Tampa, FL
Posts: 1,100
My Ride: 1995 BMW M3, 04 Z06
Send a message via AIM to lutzperformance
What did you use to clear adaptions? This most definitely cause an issue. Have you looked at your fuel system at all, how old is the stock in tank pump? Have you confirmed in-line pump is working without any issues as well?
lutzperformance is offline   Reply With Quote
Old 05-01-2013, 12:07 PM   #23
jonny_blaze
Registered User
 
Join Date: Jun 2010
Location: Mississauga
Posts: 80
My Ride: E46 M3 AA HKS S/C
Quote:
Originally Posted by LilFlip#2 View Post
I have contacted AA but it seems like they are blaming the the adaptations. I cleared the adaptations again and left a message for ZAK 4 days ago and haven't heard back from him.
Did you PM or call?

Send Zak an email or call directly for a fast response...I know the guy's crazy busy. Without having a proper tool to clear adaptations it will be a HUGE variable in your situation. Also did you ensure the FPR is set up correctly (I had to play around with it a bit). Have you verify the fuel system operation as recommended by Lutz? You can do this if you tap a fitting adapter to a gauge and monitor fuel pressure under load on the dyno. You can do this if you tap a fitting adapter to a gauge and monitor fuel pressure under load on the dyno.

If all that is good, make sure your pre cat oxygen sensors are not wearing out...sometimes the car's components are the real cause other than the kit or tune (big issue on the E9X M3). Running kit's of this level require optimum readings and operation of the factory electronics as well.

Hope this helps you ! Let us know how it goes.

Last edited by jonny_blaze; 05-01-2013 at 12:12 PM.
jonny_blaze is offline   Reply With Quote
Old 05-02-2013, 11:26 AM   #24
triksterut
Registered User
 
Join Date: May 2009
Location: Utah
Posts: 62
My Ride: 05 M3 Vert
Hey all,

Zak and I just got my Gen 7 Stage 2 tuned at a local dyno - I was also concerned that it was a bit lean (my only other real tuning experience is from an MR2 turbo). Zak says this is perfect. I'm still trying to work out a few lean spots with light throttle at 2300-3200 - but Zak has been great to work with. I was just hoping for a bit more "plug and play" See below dyno:

triksterut is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 06:11 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use