E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > BMW Regional Forums > Regional Forums > NY / NJ / CT

NY / NJ / CT
Have you seen another BMW while driving around in your area? Maybe you can find their car in the E46Fanatics Garage!
NY NJ CT

If you don't have your garage setup, sign up today HERE

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 04-10-2013, 08:37 AM   #1
ecwx215
Registered User
 
Join Date: Nov 2012
Location: Philadelphia
Posts: 9
My Ride: None
Anyone in the North Jersey (Parsippany/Lodi) that's mechanically inclined?

My rear LED taillight on my 2003.5 M3 is not working however the turn signals are. Seems to be a loose wire/connector or something because it works when it wants to (if I go over a bump it will flicker).

If anyone has any idea or has a shop I can stop by let me know!


Thanks!
ecwx215 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 04-10-2013, 08:42 AM   #2
audiquattrot
Registered User
 
Join Date: Aug 2009
Location: Staten Island, NY
Posts: 154
My Ride: 2005 M3, 1990 325iX
There should be a plug in the back of it make sure it's snug And tight. Easy as changing a light bulb
__________________
audiquattrot is offline   Reply With Quote
Old 04-10-2013, 09:09 AM   #3
ecwx215
Registered User
 
Join Date: Nov 2012
Location: Philadelphia
Posts: 9
My Ride: None
I checked both plugs they are good. There's small black box (looks like a battery?) not sure if it's dead or burnt out.
ecwx215 is offline   Reply With Quote
Old 04-10-2013, 07:21 PM   #4
04yfz
Registered User
 
Join Date: Nov 2005
Location: US
Posts: 1,383
My Ride: A car
Quote:
Originally Posted by ecwx215 View Post
I checked both plugs they are good. There's small black box (looks like a battery?) not sure if it's dead or burnt out.
You sure the lights are oem and not aftermarket? OEM lights shouldn't have a black box, aftermarket ones do.
__________________
Detailed Image Auto Detailing Supplies
[/CENTER]
04yfz is offline   Reply With Quote
Old 04-14-2013, 08:31 AM   #5
dmax
Registered User
 
dmax's Avatar
 
Join Date: Aug 2006
Location: NJ
Posts: 22,772
My Ride: '99 328i 1.04646 mu
Quote:
Originally Posted by ecwx215 View Post
My rear LED taillight on my 2003.5 M3 is not working however the turn signals are. Seems to be a loose wire/connector or something because it works when it wants to (if I go over a bump it will flicker).

If anyone has any idea or has a shop I can stop by let me know!


Thanks!
Try cleaning inside the socket and base of bulb...then...

Pull up gently on the lowest tab in the socket...just to bend it up to hold the bulb in better...that is, unless you have LEDs

There's a recall on some cars, where the dealer adds a ground...search 'taillight fix' though, that black box does make me think you have AM led lights installed.

But, being intermittent, it could just be a loose connection--check plug or the ground.
__________________


Performing at the Comedy Cove--595 Morris Ave. Springfield NJ reservations 973 376-3840

A recent set

dmax on the radio every Wednesday 7-9 p.m. NYC time. Call in! (661) 449-9340 watsonnwatson.com
dmax is offline   Reply With Quote
Old 04-22-2013, 06:25 PM   #6
ecwx215
Registered User
 
Join Date: Nov 2012
Location: Philadelphia
Posts: 9
My Ride: None
Anyone in the North Jersey (Parsippany/Lodi) that's mechanically inclined?

Click image for larger version

Name:	ImageUploadedByBimmerApp1366673017.390845.jpg
Views:	31
Size:	128.7 KB
ID:	501821

Not sure if this part is oem but this sucker here is the cause of the problem. One of the wires is loose (still havent figured out which one yet).

Any help/tips is appreciated!!


Sent from BimmerApp mobile app
ecwx215 is offline   Reply With Quote
Old 04-22-2013, 07:59 PM   #7
jerseyzillest
Registered User
 
Join Date: Sep 2011
Location: Jersey
Posts: 1,577
My Ride: 325 CI
Quote:
Originally Posted by ecwx215 View Post
Attachment 501821

Not sure if this part is oem but this sucker here is the cause of the problem. One of the wires is loose (still havent figured out which one yet).

Any help/tips is appreciated!!


Sent from BimmerApp mobile app
I had the same problem, I can fix it for you if you'd like pretty simple fix.
__________________
Photobucket


^Taken with iPhone^
:rofl:
jerseyzillest is offline   Reply With Quote
Old 04-22-2013, 10:12 PM   #8
ecwx215
Registered User
 
Join Date: Nov 2012
Location: Philadelphia
Posts: 9
My Ride: None
Anyone in the North Jersey (Parsippany/Lodi) that's mechanically inclined?

Where are you located in jersey? Ifnu can give me a step by step maybe i can try to do it myself


Sent from BimmerApp mobile app
ecwx215 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 02:24 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use