E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Forced Induction Forum Sponsored by Active Autowerke

Forced Induction Forum Sponsored by Active Autowerke
Discuss supercharging, turbocharging and even nitrous and water injection here.
Sponsored by Active Autowerke

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 3 votes, 5.00 average. Display Modes
Old 05-26-2013, 07:16 PM   #41
PEI330Ci
58mm of Bliss
 
PEI330Ci's Avatar
 
Join Date: Jul 2003
Location: PEI,Canada
Posts: 4,056
My Ride: 330i, 330Ci
Quote:
Originally Posted by Commanderwiggin View Post
It actually puts out about 25psi.
Huh?!!

Where is this reading being taken?
PEI330Ci is offline   Reply With Quote
Old 05-26-2013, 07:18 PM   #42
Commanderwiggin
Registered User
 
Join Date: Jun 2010
Location: Calgary, Canada
Posts: 3,870
My Ride: 900rwhp Turbo M3
Quote:
Originally Posted by PEI330Ci View Post
Huh?!!

Where is this reading being taken?
This was on a previous configuration where we were using a -6 return line (was waiting for the -8 to come in) and we only had the intank pump online. At the regulator read 25psi iirc. It was also a different regulator.
__________________

Last edited by Commanderwiggin; 05-26-2013 at 07:22 PM.
Commanderwiggin is online now   Reply With Quote
Old 06-01-2013, 04:20 AM   #43
GTXM3
Registered User
 
Join Date: May 2013
Location: SoCal
Posts: 7
My Ride: M3
Nice setup minus the walbro's... I've gone through too many of those.
GTXM3 is offline   Reply With Quote
Old 06-01-2013, 04:42 AM   #44
MarcusLSB
Registered User
 
Join Date: Aug 2010
Location: Bay Area
Posts: 4,366
My Ride: BMW's
Quote:
Originally Posted by GTXM3 View Post
Nice setup minus the walbro's... I've gone through too many of those.
Walbro 255's or the 400's, or both?
__________________


youtube.com/marcuslsb -- Check out photography by Gheybe!

New Build by Lab22

MarcusLSB is offline   Reply With Quote
Old 06-05-2013, 03:05 AM   #45
GTXM3
Registered User
 
Join Date: May 2013
Location: SoCal
Posts: 7
My Ride: M3
Quote:
Originally Posted by MarcusLSB View Post
Walbro 255's or the 400's, or both?
255's.
GTXM3 is offline   Reply With Quote
Old 06-17-2013, 12:00 AM   #46
lrinco01
Registered User
 
Join Date: Jan 2007
Location: Arlington,TX -- Afghanistan
Posts: 986
My Ride: 01HPF Stg2 M3, 11'X5
Send a message via Yahoo to lrinco01 Send a message via Skype™ to lrinco01
Niiiice!
__________________
Leonel Aka " Rico"
BMWCCA # 403748
01 BMW E46 M3 / 6 SPD / Tiag / Imola
HPF Stg.2 on the new Pt6766 Turbo/ Open Dump/ AA Lightweight flywheel/ Aggressive Tune good for 661 RWHP!

2012 X5D 3.5i - Family hauler
2000 323ci - work in progress - wife's D/D
2010 Toyota Tundra 5.7L LTD, Fully optioned up......soon TRD supercharged

FOR SALE:
http://www.m3post.com/forums/showthread.php?t=727953
lrinco01 is online now   Reply With Quote
Old 06-17-2013, 01:00 AM   #47
PEI330Ci
58mm of Bliss
 
PEI330Ci's Avatar
 
Join Date: Jul 2003
Location: PEI,Canada
Posts: 4,056
My Ride: 330i, 330Ci
Quote:
Originally Posted by Commanderwiggin View Post
This was on a previous configuration where we were using a -6 return line (was waiting for the -8 to come in) and we only had the intank pump online. At the regulator read 25psi iirc. It was also a different regulator.
FYI, I had a fuel pressure gauge mounted on the surge tank. I saw no movement with the pumps running, so I took it off. I was actually a little bit disappointed....
PEI330Ci is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 12:08 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use