E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Suspension & Braking Forum by BimmerWorld

Suspension & Braking Forum by BimmerWorld
Have some questions about suspension or brake setups for your E46 BMW? Get all your answers here!
Sponsored by BimmerWorld

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 05-28-2013, 11:12 AM   #1
cbuniva
Registered User
 
Join Date: Nov 2011
Location: High Bridge NJ
Posts: 8
My Ride: 2002 330XI
ABS Speed Sensor

I have a 2002 330XI and recently my DSC, brake and ABS warning lights came on and have remained on. I took the car to my local indie repair shop who scanned the car and said my right front ABS sensor was bad. i replaced that this weekend and have since driven the car about 30 miles. The lights are still on so my question is will they eventually turn off on their own or do I need to have the repair shop re-set the codes etc? Thanks for the help.
cbuniva is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 05-28-2013, 11:17 AM   #2
benzedid
Registered User
 
Join Date: Jan 2011
Location: East Coast, Mauritius
Posts: 391
My Ride: 2001 BMW E46 318i
Send a message via Skype™ to benzedid
You need to clear the codes.
__________________


benzedid is offline   Reply With Quote
Old 05-28-2013, 11:27 AM   #3
cbuniva
Registered User
 
Join Date: Nov 2011
Location: High Bridge NJ
Posts: 8
My Ride: 2002 330XI
Thanks for the help!
cbuniva is offline   Reply With Quote
Old 05-28-2013, 12:27 PM   #4
trj
Registered User
 
Join Date: Mar 2011
Location: Denver
Posts: 2,925
My Ride: 325Ci
Most of the times, if all three lights are ON(ABS, DSC and Brake) it is the sensor. You already changed the faulty one.

The lights should go away after a bit of driving(around 50 miles). No need to clear the codes.

However, these lights can be caused by a lot of other things.
Is your car aligned properly? I would get the alignment checked.
Is your car battery good? get the battery tested.
Is your wheel speed sensors in working order? Get them out and check it, clean it and put them back.
Is your steering angle sensor calibrated? Get an alignment and re-calibrate the steering angle sensor(LEW sensor).

Stop going to indy for checking the codes and buy a bmw scanner 1.4. That will pay for itself the first time you use it. Search for a thread on where to buy it and what you can do with it.
__________________

Last edited by trj; 05-28-2013 at 12:28 PM.
trj is offline   Reply With Quote
Old 05-28-2013, 12:42 PM   #5
cbuniva
Registered User
 
Join Date: Nov 2011
Location: High Bridge NJ
Posts: 8
My Ride: 2002 330XI
Thanks for the great information TRJ
cbuniva is offline   Reply With Quote
Old 07-03-2013, 04:15 PM   #6
MR2NoVA
Registered User
 
Join Date: Feb 2011
Location: NoVA
Posts: 49
My Ride: 2003 330i
bump

I've got the same issue after cleaning all 4 thoroughly... Any way to know without throwing more money at it?
MR2NoVA is offline   Reply With Quote
Old 07-03-2013, 04:17 PM   #7
benzedid
Registered User
 
Join Date: Jan 2011
Location: East Coast, Mauritius
Posts: 391
My Ride: 2001 BMW E46 318i
Send a message via Skype™ to benzedid
Did you try the things that trj mentioned?
__________________


benzedid is offline   Reply With Quote
Old 07-03-2013, 04:23 PM   #8
MR2NoVA
Registered User
 
Join Date: Feb 2011
Location: NoVA
Posts: 49
My Ride: 2003 330i
I haven't but wanted some input before I started to. Do the codes need to be cleared? OR should I begin checking things that TRJ mentioned.

@cbuniva, where are you on this issue?
MR2NoVA is offline   Reply With Quote
Old 07-08-2013, 09:18 AM   #9
cbuniva
Registered User
 
Join Date: Nov 2011
Location: High Bridge NJ
Posts: 8
My Ride: 2002 330XI
Turns out my issue was not the ABS speed sensor. One of the connector wires from the car had a hairline crack in it that just developed overtime. Repaired that and immediately the lights all went out and the car has been fine ever since.
cbuniva is offline   Reply With Quote
Old 07-09-2013, 09:48 PM   #10
ElVic
Registered User
 
Join Date: Jul 2013
Location: Texas
Posts: 62
My Ride: 02 bmw 330i
Re: ABS Speed Sensor

I have a 02 bmw 330i.
the following lights are on all the times.
parking brake, abs & dsc.. what do i need to do? clean all 4 sensors?
i recently repaired the ac by changing the blower resistor .

Sent from my ADR6425LVW using BimmerApp mobile app
ElVic is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 12:15 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use