E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Bavarian Soundwerks' Mobile Electronics Forum

Bavarian Soundwerks' Mobile Electronics Forum
Have all your A/V and electronics questions answered here. Ipods, A/V, Radar Detectors Oh My!
Sponsored by Bavarian Soundwerks

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 22 votes, 5.00 average.
Old 02-19-2014, 11:44 AM   #1181
blade0925
Registered User
 
Join Date: Sep 2013
Location: Stevens, PA
Posts: 16
My Ride: BMW 325i
After I press the reset button on my D5150U the screen went black and now it wont turn on at all. What did you guys tell me to do!! lol. Any suggestions?
blade0925 is offline   Reply With Quote
Old 02-19-2014, 11:46 AM   #1182
blade0925
Registered User
 
Join Date: Sep 2013
Location: Stevens, PA
Posts: 16
My Ride: BMW 325i
Where did you get the old D5150U software? I would like to reinstall this software until they come out with a fix.
blade0925 is offline   Reply With Quote
Old 02-19-2014, 07:12 PM   #1183
arvinny
Registered User
 
Join Date: Jan 2011
Location: Mineola, NY
Posts: 64
My Ride: 2003 330i sport pkge
I got the launch.exe in Chinese. I held the reset for 3 seconds and after that held the home button until the home screen came on. No error message since then



Sent from BimmerApp mobile app

Last edited by arvinny; 02-19-2014 at 07:15 PM.
arvinny is offline   Reply With Quote
Old 02-19-2014, 08:02 PM   #1184
wacuna
Registered User
 
Join Date: Jun 2007
Location: Auburn
Posts: 93
My Ride: BMW 323i
Quote:
Originally Posted by blade0925 View Post
After I press the reset button on my D5150U the screen went black and now it wont turn on at all. What did you guys tell me to do!! lol. Any suggestions?
Press it again... sometimes it get stuck...
wacuna is offline   Reply With Quote
Old 02-19-2014, 11:20 PM   #1185
trentcdrums
Registered User
 
Join Date: Jul 2012
Location: Illinois
Posts: 2,024
My Ride: BMW 323i Sedan
Hi trentcdrums,
Good day
I am sorry for the error code of your Eonon GM5150.
if you have tried disconnected the car battery and re-connected it again and reset the head unit but the error code still there.
I suggest you update the head unit with the following software. Thanks
http://www.sbo2.com/cs_serial//BMW_A...146-131209.rar
__________________

trentcdrums is offline   Reply With Quote
Old 02-20-2014, 11:07 AM   #1186
alameda61
Registered User
 
Join Date: Feb 2014
Location: Texas
Posts: 12
My Ride: 2004 325I
arvinny.......where is the reset button on the D5150...I have the same message.....can you help?

Thanks.




Quote:
Originally Posted by arvinny View Post
I got the launch.exe in Chinese. I held the reset for 3 seconds and after that held the home button until the home screen came on. No error message since then



Sent from BimmerApp mobile app
alameda61 is offline   Reply With Quote
Old 02-20-2014, 11:20 AM   #1187
alameda61
Registered User
 
Join Date: Feb 2014
Location: Texas
Posts: 12
My Ride: 2004 325I
I did that but no luck.......how long did you wait pressing the home button?
alameda61 is offline   Reply With Quote
Old 02-20-2014, 11:53 AM   #1188
arvinny
Registered User
 
Join Date: Jan 2011
Location: Mineola, NY
Posts: 64
My Ride: 2003 330i sport pkge
Right side on the left side of gps card


Sent from BimmerApp mobile app
arvinny is offline   Reply With Quote
Old 02-20-2014, 11:54 AM   #1189
arvinny
Registered User
 
Join Date: Jan 2011
Location: Mineola, NY
Posts: 64
My Ride: 2003 330i sport pkge
Try it again. It will reset


Sent from BimmerApp mobile app
arvinny is offline   Reply With Quote
Old 02-26-2014, 08:40 AM   #1190
E46iT
Registered User
 
Join Date: Jul 2003
Location: Toronto
Posts: 230
My Ride: 2004 325i Touring
is there a rear view camera function on this HU??
__________________
E46iT is offline   Reply With Quote
Old 03-14-2014, 07:51 PM   #1191
arvinny
Registered User
 
Join Date: Jan 2011
Location: Mineola, NY
Posts: 64
My Ride: 2003 330i sport pkge
Just ordered a Eonon D5150! (New version of Eonon D5113/Enco B146)

Quote:
Originally Posted by E46iT View Post
is there a rear view camera function on this HU??


Yes there is. I ordered one from eBay for $20.00 which fits in the license plate light opening and it works great.

Sent from iPhone 5s

Last edited by arvinny; 05-12-2014 at 06:26 AM.
arvinny is offline   Reply With Quote
Old 03-18-2014, 06:54 AM   #1192
timb551
Registered User
 
Join Date: Mar 2014
Location: Essex, UK
Posts: 1
My Ride: 320d Touring
I have now read the entire thread, took a while

I cannot see any confirmed mention of the install with the Harmon Karden option.

does it make a difference?

regards

tim
timb551 is offline   Reply With Quote
Old 03-18-2014, 10:18 AM   #1193
SheckMastaFlex
Registered User
 
Join Date: Oct 2013
Location: North Carolina
Posts: 29
My Ride: 2004 E46 M3 Vert
Quote:
Originally Posted by trentcdrums View Post
Hi trentcdrums,
Good day
I am sorry for the error code of your Eonon GM5150.
if you have tried disconnected the car battery and re-connected it again and reset the head unit but the error code still there.
I suggest you update the head unit with the following software. Thanks
http://www.sbo2.com/cs_serial//BMW_A...146-131209.rar
Has anyone tried this version out yet? I get the "launch.exe" error every morning, but turning it off and letting it reset usually fixes it. It's not a huge deal, but it would be nice not to have to mess with it.

Thanks!
SheckMastaFlex is offline   Reply With Quote
Old 03-18-2014, 04:38 PM   #1194
WOLFN8TR
OEM ///Member
 
WOLFN8TR's Avatar
 
Join Date: Jul 2011
Location: Las Vegas
Posts: 443
My Ride: 05 330CI ZHP
Quote:
Originally Posted by timb551 View Post
I have now read the entire thread, took a while

I cannot see any confirmed mention of the install with the Harmon Karden option. Does it make a difference?
Yes I did and it's a nice upgrade, system sounds much better.

Quote:
Originally Posted by SheckMastaFlex View Post
Has anyone tried this version out yet? I get the "launch.exe" error every morning, but turning it off and letting it reset usually fixes it. It's not a huge deal, but it would be nice not to have to mess with it.
That is the firmware I'm running an NO Launch.exe errors.

"Firmware updates"
There are two different ones to choose from:

This is the one my GM5150 is running, the firmware it came with.
BMW_APP_TW_4049-405F-0709-L146-131209

This is the latest firmware Carlos sent me to address the Launch.exe error.
BMW_APP_TW_4049-405F-0709-L146-140219
Quote:
Originally Posted by northwestsupra View Post
Firmware updates

Instructions:
1. Copy the folder of files to the SD card.
2. Turned key to position one and turned on head unit
3. Inserted SD card and left the Eonon head unit on.
Turned key off, waited 10 seconds, turned key back to position one and head unit powered back on and read the SD card.
4. It goes through about four steps, then restarts, please calibrate the touch screen per the instructions.
5. Remove the SD card and hit reset. If you forget to take out the SD card, it reloads again.

"More Detailed"

1.Copy the NWD_703 folder in the firmware update to your GPS SD card (make a backup of your current GPS software and maps) So now the only thing on you SD card should be the NWD_703 folder.
2. Turn unit on without sd card till it fully boots (dont worry if you are getting a launch.exe error right after starting your unit, this doesnt seem to effect it)
3. Turn the unit off but turning your key to the off position for 10 seconds
4. Place your sd card into the gps card slot and turn the key to the acc position. You should see a Eonon logo and the unit should start auto updating itself.
5. Once completed the unit will have you re-calibrate
6. After calibration go to settings and select the option just under GPS and select your language (settings wont look set until you hit the home button)
7. After confirming you have the correct language set, then turn your key to the off position again and take out the sd card (if you forget it will just do the process all over again)
8. Turn key back to the acc position and let the unit start fully.
9. Once the unit has started, find a sharp object and hit the restart button above the GPS card slot to further confirm no issues.
10. Load all your GPS software back onto the sd card and remove the NWD_703 folder.

Last edited by WOLFN8TR; 03-18-2014 at 04:58 PM.
WOLFN8TR is offline   Reply With Quote
Old 03-19-2014, 09:44 AM   #1195
SheckMastaFlex
Registered User
 
Join Date: Oct 2013
Location: North Carolina
Posts: 29
My Ride: 2004 E46 M3 Vert
Thanks, WOLF!!! I was just getting ready to start searching for instructions on how to upgrade. This morning, I had to reset my unit about 30 times before the Launch.exe error went away.
SheckMastaFlex is offline   Reply With Quote
Old 03-19-2014, 06:52 PM   #1196
WOLFN8TR
OEM ///Member
 
WOLFN8TR's Avatar
 
Join Date: Jul 2011
Location: Las Vegas
Posts: 443
My Ride: 05 330CI ZHP
Welcome...
WOLFN8TR is offline   Reply With Quote
Old 03-20-2014, 06:10 AM   #1197
mile_end
Registered User
 
Join Date: Jan 2014
Location: Poland
Posts: 4
My Ride: e46
touchscreen of my eonon is completly dead or is living on his own now....

******** width="640" height="360" src="//www.youtube.com/embed/8KrvbzDeO2E?rel=0" frameborder="0" allowfullscreen>*********>

but I got good contact with Carlos, and today send it back to Hong kong, waiting for the repair
mile_end is offline   Reply With Quote
Old 03-21-2014, 12:17 AM   #1198
EononCarDVD
Sponsor
 
EononCarDVD's Avatar
 
Join Date: Aug 2013
Location: HK
Posts: 878
My Ride: BMW E46
Quote:
Originally Posted by mile_end View Post
touchscreen of my eonon is completly dead or is living on his own now....

******** width="640" height="360" src="//www.youtube.com/embed/8KrvbzDeO2E?rel=0" frameborder="0" allowfullscreen>*********>

but I got good contact with Carlos, and today send it back to Hong kong, waiting for the repair
Hi mile_end, don't worry, we will help you out.
__________________
Great Eonon Car Audio. Wishing roads were longer! http://www.eonon.com

Welcome to check our GM5150 Opel Car GPS with Unique Screen Mirroring feature & D5150!

8 Rounds of Group Buy has been arranged till now! PM me anytime if you'd like to join and save!

Check the awesome Reviews & Installation Guide from our fan here here!


Last edited by EononCarDVD; 03-21-2014 at 12:18 AM.
EononCarDVD is offline   Reply With Quote
Old 03-21-2014, 09:58 AM   #1199
IggyBcool
Registered User
 
Join Date: Mar 2013
Location: Cleveland, TN
Posts: 3
My Ride: 03 Carbon M3
I'm not sure what I did/didn't do, but I can not gain access to the steering wheel buttons on my unit. When I go to the car tab on the HU, its ghosted and wont let me click on anything.
IggyBcool is offline   Reply With Quote
Old 03-23-2014, 08:29 PM   #1200
Rezist09
Registered User
 
Join Date: Aug 2012
Location: Lancaster
Posts: 277
My Ride: 325i sedan
where to get primo 2.4 download???
Rezist09 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 10:09 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use