E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Bavarian Soundwerks' Mobile Electronics Forum

Bavarian Soundwerks' Mobile Electronics Forum
Have all your A/V and electronics questions answered here. Ipods, A/V, Radar Detectors Oh My!
Sponsored by Bavarian Soundwerks

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 5 votes, 5.00 average.
Old 06-21-2013, 11:19 AM   #161
esberelias
Registered User
 
Join Date: Dec 2012
Location: Edmonton, AB
Posts: 236
My Ride: '03 325i
Quote:
Originally Posted by Mightymorff View Post
Does the original BMW CD changer work with this unit?
no. no place to plug in the CD changer.
__________________

Check out my ride
esberelias is offline   Reply With Quote
Old 06-21-2013, 03:41 PM   #162
asdetail
Registered User
 
Join Date: Dec 2012
Location: brisbane australia
Posts: 229
My Ride: 2002 325ci coupe
has anybody managed to extract a helpful response from eonon about the issues with the d5150???,here is what I received when asking for help with the auto dimming and random boot issues....

Quote:
Thanks a lot for your email and kind patience.
I would like to tell you that D5113's illumination wire is orange,
please connect it to the positive pole of your headlight. Then it will
be OK.

Please have a try now

If you have any question, please feel free to contact us.

Best regards
Susan from eonon
now they do not respond at all,imho,i think we are all on our own with these units and should not expect any support from these people,they may yet prove me wrong,but somehow I don't think so!.
footnote:
they cant even get the model number right!:

Last edited by asdetail; 06-21-2013 at 03:43 PM.
asdetail is offline   Reply With Quote
Old 06-21-2013, 03:53 PM   #163
eljay
Registered User
 
Join Date: May 2010
Location: NS
Posts: 72
My Ride: ///M
Yes, don't expect any support with these units, just a bunch of half-responses with smilies and emoticons in them. If great support is required, then you'll have to go with Dynavin.
But we'll do our best to help each other with these cheap units through these threads.
eljay is offline   Reply With Quote
Old 06-21-2013, 04:34 PM   #164
Scooby24
Registered User
 
Join Date: Dec 2007
Location: Overland Park, KS
Posts: 371
My Ride: '03 330i ZHP Sedan
Really confused by the red straps on the unit that stated transit screws must be removed. I'm assuming the screws holding on the red straps? Then it says the attached mylar labels must be placed over the screw openings to retain warranty? What mylar labels? Nothing was included....
__________________
Scooby24 is offline   Reply With Quote
Old 06-21-2013, 04:40 PM   #165
esberelias
Registered User
 
Join Date: Dec 2012
Location: Edmonton, AB
Posts: 236
My Ride: '03 325i
I've been turning off my deck before I turn off the car and than when I turn my car on again, I turn on the deck and its been resuming... Give it a try...

so your deck doesn't dim at all??
__________________

Check out my ride
esberelias is offline   Reply With Quote
Old 06-21-2013, 04:42 PM   #166
esberelias
Registered User
 
Join Date: Dec 2012
Location: Edmonton, AB
Posts: 236
My Ride: '03 325i
Quote:
Originally Posted by Scooby24 View Post
Really confused by the red straps on the unit that stated transit screws must be removed. I'm assuming the screws holding on the red straps? Then it says the attached mylar labels must be placed over the screw openings to retain warranty? What mylar labels? Nothing was included....

yes, take the two screws out holding the red straps... they are there so in transit, the deck doesn't bent in on the CD rom part of the deck

I think what they ment over the Mylar labels in the one on the back of the deck.

probably just a typo... you don't need to cover the holes with anything
__________________

Check out my ride
esberelias is offline   Reply With Quote
Old 06-21-2013, 06:03 PM   #167
tnhl1989
Registered User
 
Join Date: Jan 2010
Location: Hadley, MA
Posts: 440
My Ride: 02 330xi(RIP),03 ZHP
Send a message via Skype™ to tnhl1989
Just ordered a Eonon D5150! (New version of Eonon D5113/Enco B146)

For auto dimming I notice that on the harness its missing pin #13 which is for illumination. I added that and splice it into the orange wire. Now the screen dims with the retrofitted auto dimmer.

Pin setup

Added wire

Spliced together


Video
from Tony Lam on Vimeo.


Last edited by tnhl1989; 06-21-2013 at 06:39 PM.
tnhl1989 is offline   Reply With Quote
Old 06-21-2013, 07:41 PM   #168
Scooby24
Registered User
 
Join Date: Dec 2007
Location: Overland Park, KS
Posts: 371
My Ride: '03 330i ZHP Sedan
Did your guys' harness for the vehicle have two bottom connectors plugged into the radio? The eonon harness clearly doesn't, sooo...what do they go to? Am I hosed, need an adapter?
__________________
Scooby24 is offline   Reply With Quote
Old 06-21-2013, 08:29 PM   #169
asdetail
Registered User
 
Join Date: Dec 2012
Location: brisbane australia
Posts: 229
My Ride: 2002 325ci coupe
Quote:
Originally Posted by tnhl1989 View Post
For auto dimming I notice that on the harness its missing pin #13 which is for illumination. I added that and splice it into the orange wire. Now the screen dims with the retrofitted auto dimmer.

Pin setup

Added wire

Spliced together


Video
from Tony Lam on Vimeo.

very good call! I wasn't game to try that,but now that you have done it successfully I did too and it works!,thankyou,however I wonder why they connected the orange wire to the canbus adaptor?,methinks they don't test these things before going to market.
asdetail is offline   Reply With Quote
Old 06-21-2013, 08:32 PM   #170
asdetail
Registered User
 
Join Date: Dec 2012
Location: brisbane australia
Posts: 229
My Ride: 2002 325ci coupe
Quote:
Originally Posted by Scooby24 View Post
Did your guys' harness for the vehicle have two bottom connectors plugged into the radio? The eonon harness clearly doesn't, sooo...what do they go to? Am I hosed, need an adapter?
for cd changer,now redundant

Last edited by asdetail; 06-21-2013 at 08:48 PM. Reason: typo
asdetail is offline   Reply With Quote
Old 06-21-2013, 08:45 PM   #171
freaked
Registered User
 
Join Date: Jun 2013
Location: Newcastle
Posts: 9
My Ride: BMW E46 330i
Just ordered a Eonon D5150! (New version of Eonon D5113/Enco B146)

Quote:
Originally Posted by esberelias View Post
there is video and a full written review in this thread... get to read'n
true that!


Sent from BimmerApp mobile app
__________________
-----------------------
-2001 E46 330i
-1997 E36 318is
-1993 E36 318i
freaked is offline   Reply With Quote
Old 06-21-2013, 08:52 PM   #172
asdetail
Registered User
 
Join Date: Dec 2012
Location: brisbane australia
Posts: 229
My Ride: 2002 325ci coupe
this thread is providing support for d5150 owners that eonon should be providing,maybe all the helpful people on this thread should send eonon a bill for all the help provided,because they(eonon) certainly are not
asdetail is offline   Reply With Quote
Old 06-21-2013, 10:40 PM   #173
Scooby24
Registered User
 
Join Date: Dec 2007
Location: Overland Park, KS
Posts: 371
My Ride: '03 330i ZHP Sedan
How in the hell did you guys get this to sit flush with the antenna adapter installed? I just couldn't do it. All other wiring got pushed to the driver's side, not up or down and it slides back perfect. Put the antenna cable in and it's too long, hits the back and simply will not go in.

Not even a chance with the Ipod cable. It's even longer. What the hell?!

Little disappointed with the bluetooth functionality, it pulls my full contact list including work contacts, not just my phone's address book, so it's pretty useless. The CANBUS thing is really annoying. Hope they find a way to fix this.

So, I'm in need of an antenna cable and ipod cable with shorter or angled fittings. Where can I find these?
__________________
Scooby24 is offline   Reply With Quote
Old 06-21-2013, 11:12 PM   #174
asdetail
Registered User
 
Join Date: Dec 2012
Location: brisbane australia
Posts: 229
My Ride: 2002 325ci coupe
Quote:
Originally Posted by Scooby24 View Post
How in the hell did you guys get this to sit flush with the antenna adapter installed? I just couldn't do it. All other wiring got pushed to the driver's side, not up or down and it slides back perfect. Put the antenna cable in and it's too long, hits the back and simply will not go in.

Not even a chance with the Ipod cable. It's even longer. What the hell?!

Little disappointed with the bluetooth functionality, it pulls my full contact list including work contacts, not just my phone's address book, so it's pretty useless. The CANBUS thing is really annoying. Hope they find a way to fix this.

So, I'm in need of an antenna cable and ipod cable with shorter or angled fittings. Where can I find these?
I didn't have that problem,possibly because my car is right hand drive.
asdetail is offline   Reply With Quote
Old 06-22-2013, 12:23 AM   #175
tnhl1989
Registered User
 
Join Date: Jan 2010
Location: Hadley, MA
Posts: 440
My Ride: 02 330xi(RIP),03 ZHP
Send a message via Skype™ to tnhl1989
Just ordered a Eonon D5150! (New version of Eonon D5113/Enco B146)

Good luck.


Sent from BimmerApp mobile app
tnhl1989 is offline   Reply With Quote
Old 06-22-2013, 12:41 AM   #176
Scooby24
Registered User
 
Join Date: Dec 2007
Location: Overland Park, KS
Posts: 371
My Ride: '03 330i ZHP Sedan
Well, got it.

I had to trim the butts of the connectors for both. Just took a hack saw to about 1/3 of the antenna's end and used wire cutters to get more precise around the wire to keep from clipping it. Took off about 1/2 of the Ipod connector, got down to exposed wire so I wrapped the wire around the side to make it small and snug and wrapped the hell out of it with electrical tape and fished the wire through a small hole in the glove box. It's snug as a bug now and all the features work. Definitely more modding than I expected having to fix a wire harness and trim two connectors they supplied. I definitely think they designed it for right hand drive. The angle of the clearance is more on the passenger side which is where the longer connectors were.

Overall, would I do it again? For 366 shipped...you bet.
__________________
Scooby24 is offline   Reply With Quote
Old 06-22-2013, 01:41 AM   #177
esberelias
Registered User
 
Join Date: Dec 2012
Location: Edmonton, AB
Posts: 236
My Ride: '03 325i
Quote:
Originally Posted by Scooby24 View Post
Well, got it.

I had to trim the butts of the connectors for both. Just took a hack saw to about 1/3 of the antenna's end and used wire cutters to get more precise around the wire to keep from clipping it. Took off about 1/2 of the Ipod connector, got down to exposed wire so I wrapped the wire around the side to make it small and snug and wrapped the hell out of it with electrical tape and fished the wire through a small hole in the glove box. It's snug as a bug now and all the features work. Definitely more modding than I expected having to fix a wire harness and trim two connectors they supplied. I definitely think they designed it for right hand drive. The angle of the clearance is more on the passenger side which is where the longer connectors were.

Overall, would I do it again? For 366 shipped...you bet.
Yeah I had to do the same thing even from the D5113... I took off the rubber shielding off the antanna head and it could bent more...

I reused it on my D5150 and it fit like a glove The RCA's attached is good but a lot harder to work with now.

on the D5113 it was a plug in harness type and after installing my camera and getting to behind the deck..I realized the harness wasn't plugged in and I had thrown out my box Contacted eonon and they actually sent me a replacement free of charge! I've had my share of luck with them.
__________________

Check out my ride

Last edited by esberelias; 06-22-2013 at 01:41 AM.
esberelias is offline   Reply With Quote
Old 06-22-2013, 01:48 AM   #178
asdetail
Registered User
 
Join Date: Dec 2012
Location: brisbane australia
Posts: 229
My Ride: 2002 325ci coupe
Re: Just ordered a Eonon D5150! (New version of Eonon D5113/Enco B146)

Good that you got it sorted scooby,now if we could just get the random start screen problem fixed,not holding my breath for that one

Sent from my HUAWEI U9510 using BimmerApp mobile app
asdetail is offline   Reply With Quote
Old 06-22-2013, 02:15 AM   #179
esberelias
Registered User
 
Join Date: Dec 2012
Location: Edmonton, AB
Posts: 236
My Ride: '03 325i
I just read on bimmerforums a user right a post that reads "I wired in a DEI 528T relay between the head unit and the CanBus. It has an adjustable timer from 0-60 seconds. Now the CanBus powers up after the unit keeping the unit as it was set on power down. Cheap fix for keeping your wheel controls."

I've PM'd him, and he's gotten to me since.. He will eventually write a DIY and once I have that I'll link it to you here...
__________________

Check out my ride
esberelias is offline   Reply With Quote
Old 06-22-2013, 03:02 AM   #180
knightrider5000
Registered User
 
Join Date: Jun 2013
Location: los gatos, ca
Posts: 62
My Ride: 1999 BMW 323i 4 door
Send a message via Yahoo to knightrider5000
Just got a bmw 323i so my first upgrade was this D5150 nav system. I hope it works out good for me. I wish someone sold the sd cards preprogramed with igo with us maps so I don't have to figure it out myself. We need a vide from start to finish on how to install everything correctly so many bugs needed to be worked out.
knightrider5000 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 03:43 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use