E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 06-10-2013, 08:29 PM   #21
Jsmk23
Registered User
 
Join Date: Aug 2011
Location: Palm Springs, CA
Posts: 197
My Ride: 02 325i-JapanRot Red
E46 stalls and no power

I just changed the fuel filter and it's still the same.
Fuel pump sounds like its working.

I noticed that when I try to accelerate there's not power whatsoever.


Sent from BimmerApp mobile app
Jsmk23 is online now   Reply With Quote
Old 06-20-2013, 11:51 PM   #22
Jsmk23
Registered User
 
Join Date: Aug 2011
Location: Palm Springs, CA
Posts: 197
My Ride: 02 325i-JapanRot Red
E46 stalls and no power

Anyone?


Sent from BimmerApp mobile app
Jsmk23 is online now   Reply With Quote
Old 06-20-2013, 11:58 PM   #23
dznuts007
Registered User
 
Join Date: May 2006
Location: Orange County
Posts: 471
My Ride: 2001 325i Sedan
Have you tested your fuel pressure and get fuel trim readings?

Also, what other things have you tried fixing/replacing?
dznuts007 is offline   Reply With Quote
Old 06-21-2013, 08:40 AM   #24
Jsmk23
Registered User
 
Join Date: Aug 2011
Location: Palm Springs, CA
Posts: 197
My Ride: 02 325i-JapanRot Red
E46 stalls and no power

Quote:
Originally Posted by dznuts007 View Post
Have you tested your fuel pressure and get fuel trim readings?

Also, what other things have you tried fixing/replacing?
No how would I do that?

I just replaced the fuel filter with the fuel pressure.

Its weird, when I was gonna change the FF, I unplugged the FP fuse so I won't spill alot of gas.

After it was changed, I started it back up and it stopped idling rough for a couple weeks and just last night it started again.

What are some other options?


Sent from BimmerApp mobile app
Jsmk23 is online now   Reply With Quote
Old 06-21-2013, 09:27 AM   #25
B3ZKONTROLU
Registered User
 
Join Date: Aug 2009
Location: New York/Toronto
Posts: 64
My Ride: 03 325i and 04 545i
Had the same issue, I swapped out my fuel filter, it helped temporarily, but then began stalling again. Swapped out Fuel Pump, and BAM back to perfection! Fuel pump for sure!

Last edited by B3ZKONTROLU; 06-21-2013 at 09:29 AM.
B3ZKONTROLU is offline   Reply With Quote
Old 06-21-2013, 09:43 AM   #26
trentcdrums
Registered User
 
Join Date: Jul 2012
Location: Illinois
Posts: 2,022
My Ride: BMW 323i Sedan
E46 stalls and no power

Change coils! Got mine brand new for 156 shipped off amazon.


Sent from BimmerApp mobile app
__________________

trentcdrums is offline   Reply With Quote
Old 06-21-2013, 10:40 AM   #27
dznuts007
Registered User
 
Join Date: May 2006
Location: Orange County
Posts: 471
My Ride: 2001 325i Sedan
Quote:
Originally Posted by dznuts007 View Post
$85 is a pretty good price for a fuel pump. It's a Uro brand though and I think most members would recommend the Siemens fuel pump. It's about double the cost, but I think $150 is still pretty good compared to the $325+ list price. Either way a new fuel pump and fuel filter would be recommended as preventative maintenance so that you don't get stranded somewhere.

, autohausaz.com and bmaautoparts.com are some of the sites I like to use. Prices are good and parts arrive quickly.

You can rent a fuel pressure tester at Autozone for free to see if that's one of your issues.

Also make sure you check out jfoj's links and suggestions. They really helped out when my smog tests failed twice...those damn new STAR testing requirements!
^^^ "You can rent a fuel pressure tester at Autozone for free to see if that's one of your issues."

After you rent it, there are some videos on Youtube that show you exactly how to do it or you can Google "E46 test fuel pressure". Really easy and getting the results will tell get you some good info as to whether or not your fuel filter and fuel pump are the possible culprits. Also make sure you read up on Jfof's links. He has the #'s you're going to want to see.
dznuts007 is offline   Reply With Quote
Old 06-21-2013, 02:04 PM   #28
Jsmk23
Registered User
 
Join Date: Aug 2011
Location: Palm Springs, CA
Posts: 197
My Ride: 02 325i-JapanRot Red
E46 stalls and no power

Quote:
Originally Posted by trentcdrums View Post
Change coils! Got mine brand new for 156 shipped off amazon.


Sent from BimmerApp mobile app
I was guessing it might be my spark plugs/coils.

Should I do that or the FP?


Sent from BimmerApp mobile app
Jsmk23 is online now   Reply With Quote
Old 06-21-2013, 02:16 PM   #29
David McMahon
Registered User
 
Join Date: Feb 2013
Location: Suffolk, UK
Posts: 1,380
My Ride: 15/Dec/98 E46 328i
All above seems to point to FP, and your one seems to be "due" to go @110k

I'd change it now, clear codes and *touch wood* all will be well.
David McMahon is offline   Reply With Quote
Old 06-21-2013, 02:42 PM   #30
Jsmk23
Registered User
 
Join Date: Aug 2011
Location: Palm Springs, CA
Posts: 197
My Ride: 02 325i-JapanRot Red
E46 stalls and no power

Quote:
Originally Posted by David McMahon View Post
All above seems to point to FP, and your one seems to be "due" to go @110k

I'd change it now, clear codes and *touch wood* all will be well.
Thanks.

Would a bad FP set off all the misfiring codes?


Sent from BimmerApp mobile app
Jsmk23 is online now   Reply With Quote
Old 06-21-2013, 02:48 PM   #31
David McMahon
Registered User
 
Join Date: Feb 2013
Location: Suffolk, UK
Posts: 1,380
My Ride: 15/Dec/98 E46 328i
Quote:
Originally Posted by Jsmk23 View Post
Thanks.

Would a bad FP set off all the misfiring codes?


Sent from BimmerApp mobile app
Not sure, I'd clear codes (but keep note of them) after getting a new FP, I'd argue that getting one is a good PM move anyway.
David McMahon is offline   Reply With Quote
Old 06-21-2013, 04:34 PM   #32
dznuts007
Registered User
 
Join Date: May 2006
Location: Orange County
Posts: 471
My Ride: 2001 325i Sedan
I think bad fuel pump might cause low fuel pressure and/or volume and contribute to the "running lean" code.

Testing your fuel pressure can possibly help determine if the fuel pump is going bad or is bad. Again, read jfoj's links. They are very informative and has all the information you're asking. It's written quite well to where non-mechanics (such as me) can understand it and benefit from it.

Just like recommended above, wouldn't be a bad idea to change out your fuel pump. Your car is an '02 and the pump can give out any day now, or it can still keep working. Just not optimally. These repairs/replacements you're doing will not be in vain since you're replacing wear and tear parts. I've been doing alot of DIY's and replacing hoses, boots, valves, sensors, etc and my car feels like it's running great!
dznuts007 is offline   Reply With Quote
Old 06-21-2013, 08:06 PM   #33
Jsmk23
Registered User
 
Join Date: Aug 2011
Location: Palm Springs, CA
Posts: 197
My Ride: 02 325i-JapanRot Red
Thanks.

When i got my fuel filter there was a choice of 2 different kinds, one with the fuel pressure regulator and on without. I had to get the one with the regulator


Now with the FP, is there only one type to get?

Also any good websites/brands you reccommend?

Thanks.
Jsmk23 is online now   Reply With Quote
Old 06-21-2013, 08:19 PM   #34
David McMahon
Registered User
 
Join Date: Feb 2013
Location: Suffolk, UK
Posts: 1,380
My Ride: 15/Dec/98 E46 328i
Quote:
Originally Posted by Jsmk23 View Post
Thanks.

When i got my fuel filter there was a choice of 2 different kinds, one with the fuel pressure regulator and on without. I had to get the one with the regulator


Now with the FP, is there only one type to get?

Also any good websites/brands you reccommend?

Thanks.
There are lots on the site, most important thing is to get the correct type, I believe there are at least three types.

M52, M54 and M56, the M56 being very unusual

Goto Realoem.com to find your correct FP, have the last 7 digits handy, I'm sad enough to remember mine!
David McMahon is offline   Reply With Quote
Old 06-21-2013, 08:46 PM   #35
dznuts007
Registered User
 
Join Date: May 2006
Location: Orange County
Posts: 471
My Ride: 2001 325i Sedan
Cant go wrong with the Siemens pump
dznuts007 is offline   Reply With Quote
Old 07-17-2013, 10:58 AM   #36
Jsmk23
Registered User
 
Join Date: Aug 2011
Location: Palm Springs, CA
Posts: 197
My Ride: 02 325i-JapanRot Red
E46 stalls and no power

Bump


Sent from BimmerApp mobile app
Jsmk23 is online now   Reply With Quote
Old 07-17-2013, 11:37 AM   #37
dgknight
Registered User
 
Join Date: Dec 2009
Location: Bay Area, CA
Posts: 184
My Ride: 02 325xi 5sp 120k
Best price I found for oem pump was bmaparts.com. And 5% off that with code specE30.

Fault codes will be reported whenever a sensor detects out of range parameters. Low fuel pressure can cause misfires and thus misfire and lean trim codes, but there is not a 1:1 mapping of codes to failed parts which is why you are getting multiple answers. If you can do more diagnosis as suggested, you can narrow down the possibilities. When my fp died at about 115k it just shut off - no codes. It first did it at 110k and AAA whacked my fuel tank with a mallet and it restarted. I assumed it was the fuel filter, changed that and it bought me 5k miles and then I got deserted 300 miles from home with no warning. Another mallet tap got me home - lucky.

It sucks throwing parts at something, but your fp is definitely around failure time anyway, so if you swap it you are not 'wasting' money even if it is not the issue - it will be an issue soon.

Plugs are due at 100k so if they have never been swapped do those too. Pushing the plug change will put strain on the coils, and those are expensive if they let go.

Last edited by dgknight; 07-17-2013 at 11:40 AM.
dgknight is offline   Reply With Quote
Old 07-17-2013, 11:37 AM   #38
David McMahon
Registered User
 
Join Date: Feb 2013
Location: Suffolk, UK
Posts: 1,380
My Ride: 15/Dec/98 E46 328i
Quote:
Originally Posted by Jsmk23 View Post
Bump


Sent from BimmerApp mobile app
Changed FP yet?
David McMahon is offline   Reply With Quote
Old 07-17-2013, 04:12 PM   #39
Jsmk23
Registered User
 
Join Date: Aug 2011
Location: Palm Springs, CA
Posts: 197
My Ride: 02 325i-JapanRot Red
E46 stalls and no power

Have not changed FP yet, I don't mind changing it but it sounds like its working.

Has not died on me (not yet hopefully).
It starts up fine, but noticed not lately it starts to idles rough right away before it would never, just a few weeks once at a time.

And the last 2 days it's been doing it once its warmed up.


Sent from BimmerApp mobile app
Jsmk23 is online now   Reply With Quote
Old 07-17-2013, 05:36 PM   #40
David McMahon
Registered User
 
Join Date: Feb 2013
Location: Suffolk, UK
Posts: 1,380
My Ride: 15/Dec/98 E46 328i
Quote:
Originally Posted by Jsmk23 View Post
Have not changed FP yet, I don't mind changing it but it sounds like its working.

Has not died on me (not yet hopefully).
It starts up fine, but noticed not lately it starts to idles rough right away before it would never, just a few weeks once at a time.

And the last 2 days it's been doing it once its warmed up.


Sent from BimmerApp mobile app
FP might help, is due anyway.

I would reset and charge battery overnight.
David McMahon is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 05:22 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use