E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 07-18-2013, 12:35 AM   #41
Jsmk23
Registered User
 
Join Date: Aug 2011
Location: Palm Springs, CA
Posts: 197
My Ride: 02 325i-JapanRot Red
I just bought my FP, gonna put it in this weekend, This better be it lol
Jsmk23 is offline   Reply With Quote
Old 07-18-2013, 12:38 AM   #42
dznuts007
Registered User
 
Join Date: May 2006
Location: Orange County
Posts: 471
My Ride: 2001 325i Sedan
Hahah, hope so too. If not, at least have peace of mind that you have a new fuel pump. Getting stranded on the road sucks
dznuts007 is offline   Reply With Quote
Old 07-18-2013, 12:43 AM   #43
Jsmk23
Registered User
 
Join Date: Aug 2011
Location: Palm Springs, CA
Posts: 197
My Ride: 02 325i-JapanRot Red
Quote:
Originally Posted by dznuts007 View Post
Hahah, hope so too. If not, at least have peace of mind that you have a new fuel pump. Getting stranded on the road sucks
Yeah thats why I'm being positive about this lol
Jsmk23 is offline   Reply With Quote
Old 07-20-2013, 03:04 AM   #44
Jsmk23
Registered User
 
Join Date: Aug 2011
Location: Palm Springs, CA
Posts: 197
My Ride: 02 325i-JapanRot Red
Just swapped the fuel pump, power is back, but still have a rough idle, but not too much.
Jsmk23 is offline   Reply With Quote
Old 08-13-2013, 10:52 PM   #45
Jsmk23
Registered User
 
Join Date: Aug 2011
Location: Palm Springs, CA
Posts: 197
My Ride: 02 325i-JapanRot Red
E46 stalls and no power

Sorry to bug you guys again.
But it just happened to me again.

I've changed fuel filter, fuel pump, spark plugs and clean the MAF in that order.

I also noticed that when unplug the fuel pump fuse and plug it back in, the car runs normal again.
So it buys me time but it'll come back weeks later.

Any help?


Sent from BimmerApp mobile app

Last edited by Jsmk23; 08-14-2013 at 12:07 AM.
Jsmk23 is offline   Reply With Quote
Old 08-14-2013, 11:06 AM   #46
Jsmk23
Registered User
 
Join Date: Aug 2011
Location: Palm Springs, CA
Posts: 197
My Ride: 02 325i-JapanRot Red
E46 stalls and no power

Bump


Sent from BimmerApp mobile app
Jsmk23 is offline   Reply With Quote
Old 08-14-2013, 08:24 PM   #47
Jsmk23
Registered User
 
Join Date: Aug 2011
Location: Palm Springs, CA
Posts: 197
My Ride: 02 325i-JapanRot Red
Jsmk23 is offline   Reply With Quote
Old 08-21-2013, 10:04 PM   #48
Jsmk23
Registered User
 
Join Date: Aug 2011
Location: Palm Springs, CA
Posts: 197
My Ride: 02 325i-JapanRot Red
E46 stalls and no power

Also, I noticed my o2 sensor light came on. P0155

And when I looked in the engine to check it out I seen that some oil (maybe coming from the VCG) is on the sensor.
I know it's gonna need to be replaced but what could happen to this?


Idk if its a coincidence or maybe it's suppose to but my car tends to idle rough and such when I get close to 1/4 level of fuel or less.

Does it have to do with anything?


Sent from BimmerApp mobile app
Jsmk23 is offline   Reply With Quote
Old 08-21-2013, 10:25 PM   #49
scarede46er
Registered User
 
Join Date: Aug 2012
Location: Clemson, SC
Posts: 1,258
My Ride: 2001 BMW 325i ZSP
Fuel pump if it gets bad with 1/4 tank of petrol.
scarede46er is offline   Reply With Quote
Old 08-21-2013, 10:52 PM   #50
Jsmk23
Registered User
 
Join Date: Aug 2011
Location: Palm Springs, CA
Posts: 197
My Ride: 02 325i-JapanRot Red
Quote:
Originally Posted by scarede46er View Post
Fuel pump if it gets bad with 1/4 tank of petrol.
already replaced fuel pump.
Jsmk23 is offline   Reply With Quote
Old 08-22-2013, 04:46 AM   #51
BMANN405
Registered User
 
Join Date: May 2012
Location: Taunton, MA
Posts: 152
My Ride: 2002 325ci
E46 stalls and no power

Change VCG and pre cat o2 sensors. U can probably get away with not changing post cat sensors as they rarely go bad and are far more difficult to change. While you are in there check vacuum hoses for breaks and cracks. Take a good look at your intake boot as well. Could be dried out or cracked. Good luck!


Sent from BimmerApp mobile app
BMANN405 is offline   Reply With Quote
Old 08-22-2013, 09:06 AM   #52
dabu320i
Registered User
 
Join Date: Aug 2013
Location: Australia
Posts: 11
My Ride: 2001 BMW 320i sedan
E46 stalls and no power

Hey there Jsmk23. From your description of ur problem it sounds like I have the exact same issue with mine. It doesn't happen all the time but when it does it usually happens at first start up if I wait too long before driving. I usually have to drive it straight away, but even that sometimes doesn't work. it idles funny (shakes) and it stalled on me a few times before (embarrassing). No power when i accelerate. When this happens, I pull over and turn the car off for a few seconds to a minute then start it back up and that fixes it for me. I have taken it to a mechanic before and they rekon it might need new coils and plugs. I'll get around to doing that once I get enough money but for now, turning the car off for a few seconds to a minute works like a charm!


Sent from BimmerApp mobile app
dabu320i is offline   Reply With Quote
Old 08-22-2013, 10:49 AM   #53
BMANN405
Registered User
 
Join Date: May 2012
Location: Taunton, MA
Posts: 152
My Ride: 2002 325ci
E46 stalls and no power

There u go. With that amount of mileage if u haven't done plugs and coils now would b a good time. B easy to do when u r in there doing VCG. If u have the money and don't mind doing some PM that is.


Sent from BimmerApp mobile app
BMANN405 is offline   Reply With Quote
Old 08-22-2013, 02:55 PM   #54
Jsmk23
Registered User
 
Join Date: Aug 2011
Location: Palm Springs, CA
Posts: 197
My Ride: 02 325i-JapanRot Red
E46 stalls and no power

Just took it to a Indy BMW shop.
Hope to get what the problem is instead of shooting in the dark as I been doing.

Hopefully it's nothing too serious and costly $$$$.


Sent from BimmerApp mobile app
Jsmk23 is offline   Reply With Quote
Old 08-22-2013, 03:56 PM   #55
davidt443
Registered User
 
Join Date: Mar 2010
Location: Louisiana
Posts: 100
My Ride: 2001 325i
If the idle problem and sluggish problem still persist, unplug the MAF sensor connector, and try running it and see if it fixes the idle, you will set a code by doing this but it is just a test. Thats what i found in my case, replaced fuel pump fuel filter even though they were good, and then found out it that the MAF was bad the whole time, good luck
davidt443 is offline   Reply With Quote
Old 08-22-2013, 04:13 PM   #56
dabu320i
Registered User
 
Join Date: Aug 2013
Location: Australia
Posts: 11
My Ride: 2001 BMW 320i sedan
E46 stalls and no power

let us know how u go I'd love to get mine fixed too


Sent from BimmerApp mobile app
dabu320i is offline   Reply With Quote
Old 08-22-2013, 04:21 PM   #57
piaa_ump
Registered User
 
Join Date: May 2010
Location: W.Pa
Posts: 64
My Ride: 2000 328CI
anyone suggest replacing the camshaft positioning sensor?..........when mine went bad, the symptoms were rough idle and stalling and reduced power.....not sure if the OP threw that code or not.......but easy fix......
piaa_ump is offline   Reply With Quote
Old 08-22-2013, 07:02 PM   #58
Jsmk23
Registered User
 
Join Date: Aug 2011
Location: Palm Springs, CA
Posts: 197
My Ride: 02 325i-JapanRot Red
E46 stalls and no power

Just got the results.
They told me it was the fuel tank breather valve and a bad SAP.

Is this right?


Sent from BimmerApp mobile app
Jsmk23 is offline   Reply With Quote
Old 08-22-2013, 07:18 PM   #59
BMANN405
Registered User
 
Join Date: May 2012
Location: Taunton, MA
Posts: 152
My Ride: 2002 325ci
E46 stalls and no power

Not sure about "fuel tank breather valve" maybe they mean evap canister? A bad SAP pump will have absolutely no affect on how the car runs or idles tho. It only works for the first 90 to 120 seconds after a cold start. My SAP relay was bad and pump wasn't even running. I didn't find out until inspection time when I had one "not ready" MA allows one system not ready so still passed but decided to see if I could fix it myself. Had no idea relay was bad and system wasn't working cuz car was running fine and I didn't know that system existed in these cars until doing some research on this forum.
Pump looks easy to replace but I believe it's a bit expensive. Around 340 if I remember correctly. Let them change out other part but I would wait on SAP Pump and perhaps DIY


Sent from BimmerApp mobile app
BMANN405 is offline   Reply With Quote
Old 08-22-2013, 07:27 PM   #60
BMANN405
Registered User
 
Join Date: May 2012
Location: Taunton, MA
Posts: 152
My Ride: 2002 325ci
E46 stalls and no power

My bad. There is a Fuel Tank Breather Valve on these cars located between throttle body and charcoal canister. Looks like easy part to replace. ECS Tuning has it for 73.00 and it will give a CEL when it goes bad.


Sent from BimmerApp mobile app
BMANN405 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 11:35 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use