E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > DIY: Do It Yourself

DIY: Do It Yourself
Post here to share or improve your wrench turning skills! All BMW E46 DIY tips, tales, and projects discussed inside. Learn to work on your car and know the right BMW parts you will need!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 07-04-2013, 09:23 PM   #1
weskroesbergen
Registered User
 
Join Date: Apr 2013
Location: Mississauga
Posts: 22
My Ride: 2002 BMW 320i
E46 Fuel Consumption Issue

Recently I'd accidentally topped up the fuel with 87 grade, so about half and half 91/87. The CEL came on halfway through that tank, INPA showing that Probe 3 not reaching rich voltage. The next tank of gas I noticed that at low speeds the fuel consumption meter would bounce up to the top really quickly at low speeds & RPM, and take a while to back off to what is normal. That behavior was not present at highway speeds though. I also noticed that at times the exhaust would smell like sulfur at low speeds/idle.

I put in a bottle of injector cleaner, and immediately the performance seemed to increase. The CEL stayed on, but I didn't notice much of a sulfur smell anymore. The gas mileage also increase about 40-50km/tank. I also put in a bottle of cataclean, hoping that might clean up the cat converter if it was clogged.

Yesterday I filled up with 91 gas at Esso, and today the sulfur smell is back, as well as the old fuel consumption meter bouncing up and taking a while to back off.

I'm replacing the O2 sensor tomorrow (I replaced the other post-cat sensor a few months ago), and I'm replacing all the spark plugs. I'm wondering if there's something else I should be looking at? Is there something heat/vacuum related? Could it be the fuel injectors? I have a hard time seeing that cat converter as being the cause... the fuel mileage is great, and it had improved a bit after the injector cleaner. I'm hoping the condition of the spark plugs will give me more insight tomorrow.

Anyone have any suggestions?
weskroesbergen is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 07-07-2013, 11:41 AM   #2
weskroesbergen
Registered User
 
Join Date: Apr 2013
Location: Mississauga
Posts: 22
My Ride: 2002 BMW 320i
Just an update: I replaced the O2 sensor... the old one was seized and covered with soot, so I suspect it had never been changed (bought the car used a few months ago). This resolved the CEL issue.

I also changed the spark plugs and reset the adaptations. All 6 plugs were fouled, but relatively clean of residue. Cylinder 4 had a little bit of oil lumpy residue on the tips, and all of them seemed to have a little bit of oil on the threads. They also all had burn marks toward the bottom of the porcelain, which makes me suspect they were original plugs. I will be replacing my Vanos seals and VCG in a few weeks, hopefully that resolves the oil residue issue.

The car seems to be performing much better at low RPMs. I'm assuming that this is because of the adaptation reset, and/or the spark plug change. The exhaust also doesn't smell as strongly of sulfur, though that could just be placebo effect. I'll have to see how it performs over the next 500k or so to confirm the issue is definitely gone.

Last edited by weskroesbergen; 07-07-2013 at 11:44 AM.
weskroesbergen is offline   Reply With Quote
Old 07-07-2013, 12:11 PM   #3
drift.mechanic
Registered User
 
Join Date: May 2012
Location: Montreal, Qc
Posts: 312
My Ride: E46 323i
E46 Fuel Consumption Issue

The sulfer smell is generated by one of two things:
- Cheap gas
- Dying catalytic converter cell.

It takes roughly 3 tank fulls to flush inferior gas out (from personal experience with customer cars).

Your best bet is to continue to use 91 fuel, octane boost and injector cleaner all at once for the next 3 fill ups. Always fill to top and run it until the gas light comes on.

The best fuel injector cleaner is TKO (Total Kombustion Overhaul) and the best octane booster is STP Octane boost with MMT (which I used with Nitro-Meth with great results).

You're going to clear the codes at least 1 more time by the end of the 3 tanks. After them, fuel consumption, O2 values, power and smell should be normal.

Adaptation reset is also heavily suggested after the car stops coding. You'll have the best possible chance at getting perfectly smooth idle, best fuel consumption, best ignition map for power, etc

Good luck


Sent from BimmerApp mobile app

Last edited by drift.mechanic; 07-08-2013 at 12:50 AM.
drift.mechanic is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 06:15 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use