E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > E46 Xi Forum

E46 Xi Forum
The E46 XI was produced from 01-05 in sedan and touring body styles. Powered by either a 2.5L inline 6 in the 325xi or a 3.0L inline 6 330xi. Discuss all thing about BMW AWD E46 'Xi' here.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 07-18-2013, 02:27 PM   #1
Stugtz325xi
Registered User
 
Join Date: Jul 2013
Location: Chicago
Posts: 11
My Ride: 2003 325xi
Idle dropping Randomly, Anyone???

Hey all. I've got a question. New to the forum, and I've got a 2003 325xi, 123k miles on it..

Problem I'm having is that when the car is idling (Park, Drive, Reverse, dosen't matter) the RPM's drop suddenly about 200 RPM's for about a half second and jump back to normal range.

When its cold.. Does it about 10 - 15 times a min.. When its warmed up.. maybe 1-2 min.

I've read things aboyut Vanos Seals, and the ICV maybe dirty.

Anyone experience this or have any ideas??

Thanks for the help!! Its really annoying.
Stugtz325xi is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 07-18-2013, 02:53 PM   #2
dgknight
Registered User
 
Join Date: Dec 2009
Location: Bay Area, CA
Posts: 184
My Ride: 02 325xi 5sp 120k
Could DISA valve also cause this? You might try searching or posting in the main E46 forum as there is more traffic there and it will be the same for AWD or RWD cars.
dgknight is offline   Reply With Quote
Old 07-18-2013, 03:38 PM   #3
swordsman11868
Registered User
 
Join Date: Aug 2006
Location: Las Vegas
Posts: 598
My Ride: 2003 325i
Idle dropping Randomly, Anyone???

Mine did this (but not quite down that low) until I replaced the intake cam position sensor.

The idle is back to normal now.

Search for CPS issues to see if your symptoms match.

-Dan


Sent from BimmerApp mobile app
__________________
Crusaders - killing Takfiris since 1096 A.D.
swordsman11868 is offline   Reply With Quote
Old 07-18-2013, 04:40 PM   #4
Stugtz325xi
Registered User
 
Join Date: Jul 2013
Location: Chicago
Posts: 11
My Ride: 2003 325xi
Quote:
Originally Posted by swordsman11868 View Post
Mine did this (but not quite down that low) until I replaced the intake cam position sensor.

The idle is back to normal now.

Search for CPS issues to see if your symptoms match.

-Dan


Sent from BimmerApp mobile app
Did your car throw a CEL??
Stugtz325xi is offline   Reply With Quote
Old 07-18-2013, 04:52 PM   #5
Big Rick
Registered User
 
Join Date: Nov 2011
Location: 12 acres on the river
Posts: 1,528
My Ride: 325Xi
Check for codes...

I am not expert but I would think it could be;
Dirty ICV
Bad DISA
CPS
Fuel pump starting to go bad
__________________
NWS and Advertising Removed.

Quote:
Originally Posted by choxor View Post
You don't outgrow stupid.
Big Rick is offline   Reply With Quote
Old 07-18-2013, 05:17 PM   #6
Stugtz325xi
Registered User
 
Join Date: Jul 2013
Location: Chicago
Posts: 11
My Ride: 2003 325xi
No CEL or Code of any kind. Wish there was, I'd have a direction to look.
Stugtz325xi is offline   Reply With Quote
Old 07-18-2013, 06:28 PM   #7
e46alfonso
Registered User
 
Join Date: Aug 2011
Location: ct
Posts: 484
My Ride: 330xi, focus st
it could be many things, pre-cat sensors is another one even though there are no codes.
Remove the intake boots and look for cracks, clean ICV, replace disa seal, clean maf, clean electrical connectors. I would replace the cat sensors at this mileage.
e46alfonso is offline   Reply With Quote
Old 07-18-2013, 08:08 PM   #8
Kubica
Registered User
 
Join Date: Apr 2008
Location: Boston
Posts: 4,487
My Ride: 2003 325xi
Most likely a minor issue:

Check intake boots
Shell 93 + a bottle of techron
Clean ICV
Inspect DISA and CCV

If none of that works go out and wail on the motor and see if that helps. My idle gets a little jumpy if I sit in a lot of traffic.
Kubica is offline   Reply With Quote
Old 07-18-2013, 08:54 PM   #9
swordsman11868
Registered User
 
Join Date: Aug 2006
Location: Las Vegas
Posts: 598
My Ride: 2003 325i
Idle dropping Randomly, Anyone???

Quote:
Originally Posted by Stugtz325xi View Post
Did your car throw a CEL??
No code, ever. Just the common prob of no power until the revs got to 2800 rpm.

Would also happen after fairly long drives - 30+ mins. Actually stalled a few times probably due to heat soak of the sensor.

Hth

Dan


Sent from BimmerApp mobile app
__________________
Crusaders - killing Takfiris since 1096 A.D.
swordsman11868 is offline   Reply With Quote
Old 07-18-2013, 08:58 PM   #10
CharlzO
Registered User
 
Join Date: Feb 2012
Location: Upstate NY
Posts: 646
My Ride: 2000 328ci
Mine has done that in the past. However, I can't remember any time it's done it in the last few weeks since changing my cam sensor. So it may be a coincidence, or that might have been my culprit. Mine would throw a code for it every so often though, so I at least had something to go with.
CharlzO is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 05:46 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use