E46Fanatics - View Single Post - 98 Z3 No start issues.
View Single Post
Old 12-20-2017, 09:23 AM   #1
ImAnXfile
Registered User
 
Join Date: Dec 2017
Location: Ohio
Posts: 2
My Ride: 330i
98 Z3 No start issues.

I picked up great looking 98 Z3 BMW for a great price. I actually traded a Snap On toolbox for it. I got it on the presumption that it needed a DME. No big deal, Ill order a virginized DME, install it, crank it over The EWS will align and drive the wheels off of it. The DME was laying in the passenger seat when I got it. so for craps and giggles I reinstalled it and hooked up the battery. It cranked but wouldn't fire. I hooked my Snap on Solus edge scanner to it, the only code I got was a 108 continuous voltage/power. Figuring that was due to hooking and unhooking the battery I cleared it. No new codes return. In the data screen I can see the TPS operating along with various other checks. I can turn on the fuel pump with the scanner, But it does show the fuel pump as being off in the freeze frame data, and the relay does not engage with the key. The ignition does seem a little buggy. When I cycle the key a few times the dash lights come on most of the time but, once in awhile only about half of them come on. I am second guessing the guy I got it from on the DME diagnosis. But am wondering if there could be a problem with the EWS, or even ignition switch? From what Ive read a bad EWS will cause a no start condition but would crank. When the key is switched on would the fuel pump relay engage with a bad or mismatched EWS?
ImAnXfile is offline   Reply With Quote