E46Fanatics - View Single Post - DIY E46 Media Centre: MP3, videos, Digital Radio, Digital TV?
View Single Post
Old 02-17-2016, 02:16 AM   #980
TheDeathSpirit
Registered User
 
Join Date: Nov 2012
Location: Toulouse, France
Posts: 20
My Ride: 330d ph2 sedan
Quote:
Originally Posted by spudooli View Post
Summer disappeared here for the last 3 days with persistent rain, so I've spent the time working on an updated skin that fits my screen better.

It's here if you want some of it - https://github.com/spudooli/skin.mimic - hit the download zip button and put it into your add-ons directory. All kudos to bryanbrazil of course for a great original skin that was so easy to hack about with for a low res screen.

It's based on a much later version of Mimic (2.3) which is best for Kodi Isengard. I think it's best with the vertical menu and I've only updated the text sizes for Roboto so you'll need to set both on the Skin Settings page. Given I don't intend to ever watch movies in my car I've also only updated the music related screens.

I've removed a bunch of superfluous stuff (like star ratings, artist names in some places, album year, genre and artist bios etc) that don't fit in small resolution screens. Font sizes have been bumped to make reading it all easier. All the other screens I've left alone as it makes configuring everything easier in the house on the big screen easier if they still exist.

Right now I'm monkeying with a home screen now playing widget.

And if you don't own an E39, you can change the background image. It's called default_bg.jpg in the backgrounds directory/
Hi ! I've tried to use your skin (thanks for your job), but I have a lot (really, a LOT) of visual glitches, and kodi becomes unusable. I am currently using and old beta of the last kodi, maybe that's the reason. I'll let you know what happens with an up to date version.

Quote:
Originally Posted by lobocobra View Post
Hi TheDeathSpirit
I fix my problem as follows and it works now.

What I did wrong:
I created the pibus-event.sh file in windows and copied it to the raspberry with scp. During this process the LineFeed is replaced by "^M" at the end of each line and therefore the commands were not executed under Linux

To check if you have the same issue:
1) Login with SSH on raspi
2) vi /storage/pibus-event.sh
3) control if each linefeed is correct (if the script is exactly correct)
=> thus I can confirm that on reverse gear the sound is now lowered (the error was once again 30cm in front of the screen)
Hi !
Thanks for your help and answer.

I've checked the file with nano directly over SSH, and the file was correct. I've tried with and without the -r flag... and still nothing happens (except the black -because no camera connected yet- screen).

Maybe the reason is that I have a PiBus v3 and not v4 ? Pete should have the answer.
TheDeathSpirit is offline   Reply With Quote