3 of My Passenger Door Cannot Unlock! - E46Fanatics E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 08-25-2010, 09:32 PM   #1
Dan99
Registered User
 
Join Date: Nov 2007
Location: Omaha-Nebraska
Posts: 3,078
My Ride: 2001 330xi
3 of My Passenger Door Cannot Unlock!

Basically only my driver side door work only with the key turning the keyhole. Other than that none of my passenger door can unlock themselves. However, my trunk works just fine. I've tried the reprogram technique but it doesn't work. I believe it's the gm5 module, so can anyone confirm this for me?

Thanks,

Dan
__________________
Dan99 is offline   Reply With Quote
Old 08-25-2010, 10:48 PM   #2
Dan99
Registered User
 
Join Date: Nov 2007
Location: Omaha-Nebraska
Posts: 3,078
My Ride: 2001 330xi
__________________
Dan99 is offline   Reply With Quote
Old 08-25-2010, 11:02 PM   #3
bheidelburg
Registered User
 
Join Date: Dec 2008
Location: Denver
Posts: 125
My Ride: 2000 323i
I have the exact opposite. I can hear the actuator on the first click and nothing. Second click and the other three door locks pop up. I am thinking mine is just a bad actuator in the driver's door. I would think you are on the right track with yours though.... Mine works fine in the morning on all doors when it is nice and cool and has been sitting in the garage overnight. It stops working after sitting in the sun all day at work.
bheidelburg is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-25-2010, 11:34 PM   #4
Dan99
Registered User
 
Join Date: Nov 2007
Location: Omaha-Nebraska
Posts: 3,078
My Ride: 2001 330xi
Quote:
Originally Posted by bheidelburg View Post
I have the exact opposite. I can hear the actuator on the first click and nothing. Second click and the other three door locks pop up. I am thinking mine is just a bad actuator in the driver's door. I would think you are on the right track with yours though.... Mine works fine in the morning on all doors when it is nice and cool and has been sitting in the garage overnight. It stops working after sitting in the sun all day at work.
Sounds like you need the gm5 treatment because of how your lock mechanism depends on the temperature....?

http://www.bmwgm5.com/
__________________
Dan99 is offline   Reply With Quote
Old 09-02-2010, 06:41 AM   #5
jfoj
OEM ///Member
 
Join Date: Nov 2009
Location: Fairfax, VA USA
Posts: 28,888
My Ride: 330CiC, M5, X5, E93
Have a 2001 325xi Touring with similar problems.

Intermittently only the drivers door unlocks with the keyfob, appears the rear hatch may unlock with the driver door?

Then the 2nd push of the keyfob, nothing, the other 3 doors remain locked.

But the real clincher is the car has the auto door lock feature enabled, if I have passengers in the car, drive it and the doors auto lock, many times when I stop, the passengers cannot open the doors, they have to crawl out via the drivers door!!

Assume it may be a GM5 relay issue?

Any other ideas?
jfoj is offline   Reply With Quote
Old 09-02-2010, 07:04 AM   #6
EJL486
Registered User
 
Join Date: Nov 2009
Location: Greenville/Spartanburg, SC
Posts: 364
My Ride: E46, E34
sounds like a GM5 issue. I had the same, sent my GM5 to scott @ www.bmwgm5.com - I couldnt be happier with the result. had my GM5 back in a few days and no longer suffer the embarrassment of having friends crawl in and out through the windows. Its been about a year since I had the work done and the door locks work perfectly, every time.
__________________

2003 325i 5MT Pics of Car
1995 530i 5MT
1986 535i 5MT sold
http://www.bmwusfactory.com
http://www.thebmwpartstore.com
PSN: EJL486 - Actively Playing: GT5, Battlefield 3, Madden '12
EJL486 is offline   Reply With Quote
Old 09-02-2010, 08:23 AM   #7
delmarco
Registered User
 
Join Date: Nov 2008
Location: Westchester, NY
Posts: 6,342
My Ride: 335i xDrive Deep Sea
Year: 2011
Model: 335i
Transmission: Steptronic
Send a message via ICQ to delmarco Send a message via Yahoo to delmarco
I am having a similar issue but it just seems to be a sticking problem and the doors eventually unlock. It is also not all the time. Sometimes maybe once a month I have to repeat the lock/unlock cycle on the keyfob or just click unlock about 3-4 more times after the driver door unlocks to get the passenger doors unlocked. However the doors all unlock fine from the main button in the console. It only sticks with the keyfob.
__________________
delmarco is offline   Reply With Quote
Old 09-02-2010, 08:34 AM   #8
firefirefire90
Banned
 
Join Date: Apr 2009
Location: loves FUPA
Posts: 6,751
My Ride: suce ma bite
Send a message via AIM to firefirefire90
does your center unlock button still unlock all the doors, or is this strictly related to your keyfob?
firefirefire90 is offline   Reply With Quote
Old 09-02-2010, 09:45 AM   #9
jfoj
OEM ///Member
 
Join Date: Nov 2009
Location: Fairfax, VA USA
Posts: 28,888
My Ride: 330CiC, M5, X5, E93
Central console lock button will still not unlock the doors either when you first get in the car, or after you drive to your destination and the Auto Lock feature has locked you in your car!!!!

The problem is intermittent and seems to happen when the car has been out in the sun or during warmer weather?

I am leaning on the GM5 relay problem, however, it was unclear if the double unlocking problem was GM5 related/controlled.

Delmarco, what is the condition of your car battery, I had problems with unlocking with my Vert when I had a bad cell in the car battery. There was no reserve capacity in the battery, so the initial unlock would be fine, however, the 2nd unlock was intermittent. The strange thing was the car seemed to start fine until a few weeks later when one day the car started really hard, cranked slow, I knew the battery was toast. Since changing the battery, no more unlock issue with the passenger door from the keyfob.
jfoj is offline   Reply With Quote
Old 09-02-2010, 12:06 PM   #10
scottjoh
Modded ///Member
 
Join Date: Aug 2008
Location: Torrance, CA
Posts: 3,265
My Ride: '99 323i & '02 540i
Quote:
Originally Posted by delmarco View Post
I am having a similar issue but it just seems to be a sticking problem and the doors eventually unlock. It is also not all the time. Sometimes maybe once a month I have to repeat the lock/unlock cycle on the keyfob or just click unlock about 3-4 more times after the driver door unlocks to get the passenger doors unlocked. However the doors all unlock fine from the main button in the console. It only sticks with the keyfob.
Sticking problem with multiple doors at the same time! It's the GM5 door lock relays.

>It only sticks with the key fob.
Yeah, because the problem is with the door lock relays that control the double locking motors. The central locking button does not lock and unlock the double locks. Only the key fob and the key in the driver's door control double locking.
scottjoh is offline   Reply With Quote
Old 09-02-2010, 12:08 PM   #11
scottjoh
Modded ///Member
 
Join Date: Aug 2008
Location: Torrance, CA
Posts: 3,265
My Ride: '99 323i & '02 540i
Quote:
Originally Posted by jfoj View Post
Central console lock button will still not unlock the doors either when you first get in the car, or after you drive to your destination and the Auto Lock feature has locked you in your car!!!!

The problem is intermittent and seems to happen when the car has been out in the sun or during warmer weather?

I am leaning on the GM5 relay problem, however, it was unclear if the double unlocking problem was GM5 related/controlled.
jfoj, once you said it happens when the car has been out in the sun or when it's hot that cinched it. Definately GM5 relays in your case.
scottjoh is offline   Reply With Quote
Old 09-04-2010, 11:31 AM   #12
alpine003
Registered User
 
Join Date: Jan 2005
Location: Chicago
Posts: 275
My Ride: BMW
I get that from time to time but it's very weird. On my touring, it only acts up if I'm parked at a non level grade. If my car is parked level it seems fine. I'm not sure if there is a semi corroded connection or something loose. Anyone know where the GM5 unit is located?
alpine003 is offline   Reply With Quote
Old 09-04-2010, 06:23 PM   #13
jfoj
OEM ///Member
 
Join Date: Nov 2009
Location: Fairfax, VA USA
Posts: 28,888
My Ride: 330CiC, M5, X5, E93
http://www.bmwgm5.com/

Look at the GM5 removal hyperlink on the right. It appears the GM5 module is behind the glovebox.

I may be pulling the module out of a Touring tonight to change the relays.

Let me tell you that Scott from BMWGM5 is a great asset, helpful suggestions, replies to e-mail and ships parts QUICK. I ordered my relays on Thursday from him in CA and they were in my mailbox in VA on Sat!!!!!!!!!!!!!

This is awesome service, thanks Scott @BMWGM5.com, I wish I could pull the module and replace the relays as quick as he ships!!!

I will update this thread once I get the relays replaced.
jfoj is offline   Reply With Quote
Old 09-04-2010, 06:32 PM   #14
bheidelburg
Registered User
 
Join Date: Dec 2008
Location: Denver
Posts: 125
My Ride: 2000 323i
Might be the gm5 but it is not consistent on mine and sometimes the whole thing works erratically. The key still unlocks everything and the second turn of the key always unlocks the remaining doors. If I push the fob button twice and get three doors unlocked but not the driver's, I have to put the key in and lock the car (all locks lock no problems) and then unlock with the key and it works every time. That is why I think it is just the lock mech on the driver's door. It doesn't really bother me much as we don't get a lot of rain in Denver and I park in a garage both at work and at home.... More of a nuisance than anything else. If everything got fixed every time it breaks on a ten year old car, i'd be broke (or car shopping).
bheidelburg is offline   Reply With Quote
Old 09-04-2010, 10:55 PM   #15
jfoj
OEM ///Member
 
Join Date: Nov 2009
Location: Fairfax, VA USA
Posts: 28,888
My Ride: 330CiC, M5, X5, E93
OK, just finished replacing the relays in the GM5 module. Took about 1 1/2 hours taking my time. The difficult part was the actual relay replacement. Warning, do not try this unless you are VERY competent at soldering and de-soldering. If you have a de-soldering station, great, if not you WILL need a solder sucker and a good quality medium size soldering iron or a good quality soldering station. I did not have a de-soldering station, however, I have performed a lot of component level and surface mount assembly, repair and modifications, so I would say I have advanced soldering and component level repair skills.

A few notes:

1. The circuit board is "potted" or sealed with a silicon base sealer. Very much like clear silicon RTV, however, a fairly thin coating. You should remove the silicon "potting" sealer before you attempt to remove the relays. You can remove the sealer easily with a small flat blade screw driver or the carefully with an ice pick. Have an old tooth brush handy to clean off the loose silicon as it will stick to the other sealing compound on the board.

2. If you do not have a de-soldering station, you may want to actually flow a small amount of solder on the terminals to allow better thermal conduction. I found this helped me a lot to get the old solder to flow a bit better before sucking it out.

3. If you have micro drill bits and a pin vise, this will help clean out the solder through holes before installing the new relays. You make also be able to use a sewing needle, but be careful not to burn yourself!! Note there are 2 different through hole sizes. The control terminals are smaller than the load or relay terminals.

4. One thing that happened when I put the car back together and first started the car was the DCS, ABS and Brake lights on the dash were lit. I was a bit scared at first that I may have caused another problem. But in typical BMW scenario, I figured what the hell, let me test drive the car and see what happens. The car has the Auto Door Lock feature enabled, so I also wanted to make sure this was working as well. I backed up no more than 10 feet and all the brake related lights went out!! Must be that something needed a valid input after the battery was disconnected?? I ran into a similar problem on a 330cic that had a problem battery as well.

So looks like my problems are solved. I need to go at least 1 week without any problems to be 100% convinced, as this was an intermittent problem. But the problem was quickly getting much worse just before I replaced the relays, so I am about 95% sure the problem is fixed.

Again, hats off to Scott @ BMWGM5.com for his research, effort and parts. A great contributor to the BMW community.
jfoj is offline   Reply With Quote
Old 09-05-2010, 08:49 AM   #16
delmarco
Registered User
 
Join Date: Nov 2008
Location: Westchester, NY
Posts: 6,342
My Ride: 335i xDrive Deep Sea
Year: 2011
Model: 335i
Transmission: Steptronic
Send a message via ICQ to delmarco Send a message via Yahoo to delmarco
Quote:
Originally Posted by scottjoh View Post
jfoj, once you said it happens when the car has been out in the sun or when it's hot that cinched it. Definately GM5 relays in your case.
I think mine almost ALWAYS happens, when it does happen which is rare, in the mornings. When it is early like 6 am.
__________________
delmarco is offline   Reply With Quote
Old 09-05-2010, 04:13 PM   #17
scottjoh
Modded ///Member
 
Join Date: Aug 2008
Location: Torrance, CA
Posts: 3,265
My Ride: '99 323i & '02 540i
Quote:
Originally Posted by delmarco View Post
I think mine almost ALWAYS happens, when it does happen which is rare, in the mornings. When it is early like 6 am.
If it's worse during hot OR cold weather it is most likely the relays. Most people who do notice a correlation with temperature say it's worse in hot, but, some say it's worse in cold.
scottjoh is offline   Reply With Quote
Old 09-05-2010, 04:36 PM   #18
Lionelski
Registered User
 
Join Date: Jun 2004
Location: Long Island, NY
Posts: 1,193
My Ride: 325CIc
Huh?
How many passenger doors do you have on that car?
__________________
'Ski
www.WarrenvilleRailroad.com
2001 325ci Convertible - Titanium Silver

Sport Package, Premium Package
Racing Dynamics Strut Tower Brace
Conforti Shark Injector, Conforti CAI
Interior: Leather, Euro Tray, M3 Dead Pedal
Lionelski is offline   Reply With Quote
Old 09-08-2010, 05:10 PM   #19
Dan99
Registered User
 
Join Date: Nov 2007
Location: Omaha-Nebraska
Posts: 3,078
My Ride: 2001 330xi
Update:

Sent my gm5 module here
http://www.bmwgm5.com/

And Scott Johnson did the rest and now everything is back to normal.
__________________
Dan99 is offline   Reply With Quote
Old 07-16-2012, 02:32 PM   #20
bbowens
Registered User
 
Join Date: Apr 2011
Location: San Francisco Bay Area
Posts: 62
My Ride: 2003 325iT M56 SpPkg
I just used Scott's BMWGM5.com repair service; very happy with the results, too.
bbowens is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON



All times are GMT -5. The time now is 04:07 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
(c) 1999 - VerticalScope Inc. All rights reserved.