Eonon D5150 - Cliff Notes Review & Screen Failure - E46Fanatics E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 06-17-2014, 12:48 AM   #1
Guest021715
Account closed.
 
Join Date: Apr 2010
Posts: 7,237
Eonon D5150 - Cliff Notes Review & Screen Failure

deleted

Last edited by Guest021715; 02-16-2015 at 09:15 PM.
Guest021715 is offline   Reply With Quote
Old 06-17-2014, 01:19 AM   #2
JapanRot325ci
Registered User
 
Join Date: Sep 2013
Location: Toronto
Posts: 1,789
My Ride: 04 E46
seems like a software defect. best bet is to send it back to Eonon. i believe they have a 2 year warranty with these products.
JapanRot325ci is offline   Reply With Quote
Old 06-17-2014, 10:44 AM   #3
scarede46er
Registered User
 
Join Date: Aug 2012
Location: Clemson, SC
Posts: 1,456
My Ride: 2001 BMW 325i ZSP
Also, I am sure the DAC on these POS units are absolutely rubbish.
scarede46er is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-18-2014, 08:35 AM   #4
markusmarkus
Registered User
 
Join Date: Jul 2008
Location: USA
Posts: 9,210
My Ride: 2018 M240i
Your speakers need crossovers. It's not the job if the head unit to route the appropriate audio signals to each speaker. The OEM amp had built in crossovers.


Sent from BimmerApp mobile app
markusmarkus is offline   Reply With Quote
Old 06-18-2014, 08:39 AM   #5
scarede46er
Registered User
 
Join Date: Aug 2012
Location: Clemson, SC
Posts: 1,456
My Ride: 2001 BMW 325i ZSP
Quote:
Originally Posted by markusmarkus View Post
Your speakers need crossovers. It's not the job if the head unit to route the appropriate audio signals to each speaker. The OEM amp had built in crossovers.


Sent from BimmerApp mobile app
Bs. Crossovers are designed only to separate out the tweeter and midrange/midbass signals. You should never pass subwoofer signals to your main speakers and you should not pass frequencies above that range to your subwoofer. Doing so causes distortion and a general lack of fidelity.
scarede46er is offline   Reply With Quote
Old 06-18-2014, 08:43 AM   #6
Swater330i
Registered User
 
Join Date: Mar 2013
Location: Dallas, TX
Posts: 1,383
My Ride: 2003 BMW 330i 5MT
Glad I got out of a group buy. Bad company.
__________________
Quote:
I am going to install M3 fender grill on my 323ci.
Quote:
This 323 would most likely handle and drive better than a stock e46 m3.
Swater330i is offline   Reply With Quote
Old 06-18-2014, 12:13 PM   #7
Guest021715
Account closed.
 
Join Date: Apr 2010
Posts: 7,237
Quote:
Originally Posted by markusmarkus View Post
Your speakers need crossovers. It's not the job if the head unit to route the appropriate audio signals to each speaker. The OEM amp had built in crossovers.


Sent from BimmerApp mobile app
If this was the late 80's / early 90's, I would agree with you.
Guest021715 is offline   Reply With Quote
Old 06-18-2014, 12:14 PM   #8
Guest021715
Account closed.
 
Join Date: Apr 2010
Posts: 7,237
No response from the Sponsor yet? Hmm..
Guest021715 is offline   Reply With Quote
Old 06-18-2014, 01:23 PM   #9
scarede46er
Registered User
 
Join Date: Aug 2012
Location: Clemson, SC
Posts: 1,456
My Ride: 2001 BMW 325i ZSP
Sponsor took your money and ran away.
scarede46er is offline   Reply With Quote
Old 06-18-2014, 10:02 PM   #10
EononCarDVD
Registered User
 
Join Date: Aug 2013
Location: HK
Posts: 2,205
My Ride: BMW E46
Hi ac_2007, hope you can understand there's time difference between us, but I'll respond you guys as soon as I can. No worry we'll try our best to help you. Actually I've asked our tech yesterday, they're just checking your issues mentioned carefully but need to take some time. Please kindly wait for a while with patience.

For the issues mentioned:
1) For your speaker issue, our tech confirmed it has nothing to do with our unit and the high-pass filter. Pls check if it's the problem of your speaker itself. About your friend's screen issue, they're checking, I will update you if there's any advice from our tech.
2) You can add an anti-glare film on the unit screen to prevent screen-glare.
3) I will PM you the software to fix the launch.exe error later.
4) The USB/SD interface is designed in this way, hope you can understand.

Sure we will take good care of your case, it's well known that we have steady customer support and 2 year warranty, will give you a proper solution finally, thanks!

Last edited by EononCarDVD; 06-19-2014 at 11:08 PM.
EononCarDVD is offline   Reply With Quote
Old 06-19-2014, 11:20 PM   #11
EononCarDVD
Registered User
 
Join Date: Aug 2013
Location: HK
Posts: 2,205
My Ride: BMW E46
Hi ac_2007, I've sent you an Email with our tech's advice just now, pls kindly check and keep communicating there for better record, thanks a lot!
EononCarDVD is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON



All times are GMT -5. The time now is 09:53 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
(c) 1999 - VerticalScope Inc. All rights reserved.