Odd issue with coolant & heater - E46Fanatics E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 05-03-2016, 09:33 AM   #1
auf_der_jagd
Registered User
 
Join Date: Aug 2015
Location: Canada
Posts: 7
My Ride: 2000 328Ci
Odd issue with coolant & heater

Hello, so I have a 2000 328CI
that does this weird thing when while driving, with heat set to, lets say 21.5c, all of a sudden instead of hot air she starts blowing ice cold air (its also cold outside, so might be outside air?) then goes back to hot randomly and the coolant light lights up :|

facts:
water pump is brand new, but not the thermostat
coolant level (as per drawing) is perfect
no visible leaks under car or on driveway
no codes

anyone seen this before?
I'm fairly new to bimmers, and never seen this on an audi or a volkswagen aside for when the heatcore is about to go nuts

cheers




Sent from my iPhone using Tapatalk
auf_der_jagd is offline   Reply With Quote
Old 05-03-2016, 10:09 AM   #2
BMW-North
// Quandt AG (Retired) //
 
BMW-North's Avatar
 
Join Date: Feb 2008
Location: Toronto or Myrtle Beach
Posts: 3,695
My Ride: AMv8,e46,e90,e92,e83
I see hundreds of threads on here that recommend a fresh coolant bleed when it is never the issue but in your case it is.

Seen this before when there is an air pocket in the circulated coolant. When the air pocket hits the heater core you get cooler air, as the air pocket circulates and hot coolant is now in the core you are back to warm/hot air.

When the revs are higher (say above idle) the waterpump pulls the coolant from the ET and the low coolant light comes on, when you go back to idle the vacuum from the ET sucks the coolant back into the ET and the low coolant light goes off, or when you shut off the engine to check the coolant - viola the ET shows at the correct level. (Until you start engine and rev and the coolant gets sucked out again - it's a cycle)

Typical condition of a poor coolant bleed. Likely caused when the "brand new" components were installed. Find a bleed thread.
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Last edited by BMW-North; 05-03-2016 at 10:12 AM.
BMW-North is offline   Reply With Quote
Old 05-03-2016, 10:15 AM   #3
dmax
Registered User
 
dmax's Avatar
 
Join Date: Aug 2006
Location: NJ
Posts: 25,976
My Ride: '16 340i xD 6-spd
Year: 16
Model: 340i
Transmission: 6-spd
...and that need for bleeding might come from a leak you're unaware of (if you haven't done cooling system work in a bit). Two slow, invisible leaking sites are the hard pipes coming from the block, under the intake manifold. The drips will dry up before they get anywhere. You probably wouldn't smell much either...not when driving...and afterwards, perhaps only slightly if at all.
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
See Facebook for upcoming shows...and listen to my podcast!
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.




To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
dmax is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON



All times are GMT -5. The time now is 03:51 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
(c) 1999 - VerticalScope Inc. All rights reserved.