Another Door lock Thread (not like the others) - E46Fanatics E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Go Back   E46Fanatics > E46 BMW > E46 Touring

E46 Touring
The E46 touring forum. Talk about your sport wagon E46 here.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 07-20-2019, 05:15 AM   #1
Eurotuner1981
Registered User
 
Join Date: Jun 2018
Posts: 1
Another Door lock Thread (not like the others)

I have a 2001 E46 330D Touring with around 290k KM. I started having a small issue about 2 weeks after I got it. I would have to unlock lock with remote a few times to get all doors to unlock. Drivers side front always worked perfectly and still does.
Eventually front passenger, rear passenger and rear driver side doors stopped responding completely. Could only open from inside door handles.
So I did some looking around and found the "common" GM5 problem. And found a thread that talked about opening the relays on GM5 and cleaning them to see if that fixed the problem. Which it did for about 6 cycles. Cool no problem I replaced the relays with no positive result. I though maybe I screwed up the board so I tried a different GM5 from junk yard, still nothing positive. Replaced those relays and no positive results and tested all solder connections (same symptoms only driver door locks/unlocks). All door actuators make the unlock/lock noise. If I unlock all the doors I can watch them "attempt" to go down but do not.

So today and yesterday I've looked and looked for wiring schematics and diagnosis procedures for the locking system.
I attempted my own process using this diagram.
https://www.bmwgm5.com/GM5_Connections.htm
However it does not give actual voltages and intended results. But this is what I tried with my results today. Maybe someone has some input.
Test performed on drivers side rear lock actuator.
Lock wire gets 12v on Lock
Unlock wire gets 12v on unlock
Double lock gets 12v on lock but not Unlock
Should the double lock wire have power on both unlock and lock, or just lock, or just unlock..?
Eurotuner1981 is offline   Reply With Quote
Old 07-20-2019, 01:28 PM   #2
jwm5
Registered User
 
Join Date: Sep 2006
Location: Virginia Beach, VA
Posts: 4,299
My Ride: station wagon
I cant contribute to specific wiring issues, but this spring I went thru similar lock issues, ended up having to replace the General Module which fixed the lock (and also a no rear luggage compartment lighting issue which a lot of times people attribute to frayed wiring, but was not in my case). Also the key remote was still not working so I believe they replaced a module or antenna in the rear ( i know they removed my rear spoiler to access components under it...

Good luck with your issue.
jwm5 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON



All times are GMT -5. The time now is 07:59 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
(c) 1999 - VerticalScope Inc. All rights reserved.