M54B30 6 speed into 325 auto - no cruise control - E46Fanatics E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Go Back   E46Fanatics > Tuning & Tech > E46 Engine Swaps

E46 Engine Swaps
Replacing your motor? From direct replacements to more exoctic engines, if it's going under the hood of an E46 3 Series this is the forum to discuss it.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 04-10-2017, 08:16 PM   #1
18rabbit
Registered User
 
Join Date: Sep 2009
Location: Kennett Square, PA 19348
Posts: 117
My Ride: '02 330it
M54B30 6 speed into 325 auto - no cruise control

Hey folks, so a few months ago I dropped a m54b30 and a 6 speed manual transmission into an auto 325it. I've gotten the car on the road, all cluster lights sorted, and now I'm ironing out the small stuff. One of those things is the cruise control not working. I really don't even know where to start on this one. I've read a few DIY's where the cruise just works after hooking up all of the clutch wiring and such. I get the cruise control light working on the dash so I know the buttons are good...

Can anyone point me in the right direction? or any direction?
18rabbit is offline   Reply With Quote
Old 04-12-2017, 02:48 PM   #2
GhostFlame
Registered User
 
Join Date: Jun 2011
Location: :
Posts: 1,360
My Ride: :
You mentioned you have no lights on the dash right now - are any intermittent?
A faulty MAF will disable the cruise control entirely. You can check the fuse for this system as well.

Did you use the DME and wiring harness from the donor car as well?
Do your reverse lights come on when you use reverse?

On my M3, there was a sensor located on the transmission - I believe its function is to provide gear position information to the DME.
Cruise would not work without this sensor, however I am unsure if your tranny has this as well.
GhostFlame is offline   Reply With Quote
Old 04-12-2017, 02:51 PM   #3
GhostFlame
Registered User
 
Join Date: Jun 2011
Location: :
Posts: 1,360
My Ride: :
Since you are coming from an automatic car, there is also a clutch switch which you need to make sure you transplanted over.

This is the sensor that disables cruise control if you push in the clutch. If its not there, cruise will not start.
GhostFlame is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-29-2017, 07:43 PM   #4
18rabbit
Registered User
 
Join Date: Sep 2009
Location: Kennett Square, PA 19348
Posts: 117
My Ride: '02 330it
Quote:
Originally Posted by GhostFlame View Post
Since you are coming from an automatic car, there is also a clutch switch which you need to make sure you transplanted over.

This is the sensor that disables cruise control if you push in the clutch. If its not there, cruise will not start.
Hi, I was out driving the car today for a little. I had the cruise working in 4th gear for a little! I went into the store, came back out, and couldn't get it to work again... I have the reverse lights working. The DME is the original car's unit. I have the clutch switch wired up (4 wires) and it works. I don't know if I could have gotten the car to run without that one. Maybe I should look into that more carefully.
18rabbit is offline   Reply With Quote
Old 04-30-2017, 08:01 PM   #5
CarbonZHP
Because Race...Convertible?
 
CarbonZHP's Avatar
 
Join Date: Jun 2013
Location: EAS
Posts: 2,908
My Ride: goes choo choo
Year: 2004
Model: 330Cic ZHP
Transmission: AT->5MT->6MT
I needed to run power to the clutch switch, then one wire to the immobilizer and one to the ECU. These can be difficult to get a good connection when adding the pin to the ecu loom
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Original Car: Silver Grey on Grey, A/T (1 of 186)
As it sits: Silver Grey on Black, M/T (1 of 51)
Instagram: @CarbonZHP
CarbonZHP is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is OFF



All times are GMT -5. The time now is 07:34 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
(c) 1999 - VerticalScope Inc. All rights reserved.